mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: James Morse <james.morse@arm.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org
Cc: Fenghua Yu <fenghua.yu@intel.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
	H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
	shameerali.kolothum.thodi@huawei.com,
	D Scott Phillips OS <scott@os.amperecomputing.com>,
	carl@os.amperecomputing.com, lcherian@marvell.com,
	bobo.shaobowang@huawei.com, tan.shaopeng@fujitsu.com,
	baolin.wang@linux.alibaba.com,
	Jamie Iles <quic_jiles@quicinc.com>,
	Xin Hao <xhao@linux.alibaba.com>,
	peternewman@google.com, dfustini@baylibre.com,
	amitsinght@marvell.com, David Hildenbrand <david@redhat.com>,
	Rex Nie <rex.nie@jaguarmicro.com>,
	Dave Martin <dave.martin@arm.com>
Subject: Re: [PATCH v4 06/39] x86/resctrl: Move data_width to be a schema property
Date: Fri, 13 Sep 2024 19:07:59 +0100	[thread overview]
Message-ID: <c3c8bd5d-b527-4365-b4d6-3bc126a49f36@arm.com> (raw)
In-Reply-To: <44849590-d35f-4dcf-8744-a0472e6e9e3f@intel.com>

Hi Reinette,

On 14/08/2024 04:59, Reinette Chatre wrote:
> On 8/2/24 10:28 AM, James Morse wrote:
>> The resctrl architecture code gets to specify the width of the schema
>> entries that are used by resctrl. These are determined by the schema
>> format, e.g. percentage or bitmap.
>>
>> Move this property into struct resctrl_schema and get the filesystem
>> parts of resctrl to set it based on the schema format. Remove
>> rdt_init_padding(), its work is be done by schemata_list_add(),
> 
> "its work is be done by" -> "its work is done by"
> 
>> allowing max_name_width and max_data_width to be moved out of core.c
>> which has no counterpart after the move to fs.
>>
>> The logic for calculating max_name_width was moved in earlier patches,
> 
> ("patches" in changelog can be a trigger, maybe "moved in earlier patches"
> -> "moved earlier"?)
> 
>> but the definition was not moved.


>> diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> index 1ce851447923..ed06384f9161 100644
>> --- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> +++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
>> @@ -57,6 +57,12 @@ static struct kernfs_node *kn_mongrp;
>>   /* Kernel fs node for "mon_data" directory under root */
>>   static struct kernfs_node *kn_mondata;
>>   +/*
>> + * Used to store the max resource name width and max resource data width
>> + * to display the schemata in a tabular format.
>> + */
>> +int max_name_width, max_data_width;
>> +
>>   static struct seq_buf last_cmd_status;
>>   static char last_cmd_status_buf[512];
>>   @@ -2603,15 +2609,20 @@ static int schemata_list_add(struct rdt_resource *r, enum
>> resctrl_conf_type type
>>       switch (r->schema_fmt) {
>>       case RESCTRL_SCHEMA_BITMAP:
>>           s->fmt_str = "%d=%0*x";
>> +        s->data_width = (r->cache.cbm_len + 3) / 4;
>>           break;
>>       case RESCTRL_SCHEMA_PERCENTAGE:
>>           s->fmt_str = "%d=%0*u";
>> +        s->data_width = 3;
>>           break;
>>       case RESCTRL_SCHEMA_MBPS:
>>           s->fmt_str = "%d=%0*u";
>> +        s->data_width = 4;
>>           break;
>>       }
>>   +    max_data_width = max(max_data_width, s->data_width);
>> +
> 
> To me this emphasizes that RESCTRL_SCHEMA_PERCENTAGE and
> RESCTRL_SCHEMA_MBPS are not appropriate. Note how the minimum data width
> of RESCTRL_SCHEMA_MBPS is 4, this is unexpected from an actual MBps
> value. The choice of "4" is specific to AMD's input but that information
> is lost in this change.

It's preserving the current behaviour, as AMD is currently the only user.
I strongly suspect the value here is quite wrong, and what we should really do is call
snprintf() to tell us how long the string needs to be.


> We are fortunate that data_width is a minimum, allowing the software controller
> to be enabled with longer data values, but that is subtle and already
> breaks the goal of "making things tabular".

> I wonder how useful the data_width actually is. The "make things tabular"
> motivation seems to only apply to resources that have the exact same scope
> and as noted earlier seems to be broken already.

> I am skeptical that user space will be impacted if this is removed.

Makes sense. I think the only argument could be a parser written for a new kernel would be
surprised if it ran against an older kernel - and we might not care about that scenario.

I can't see how this would happen for the zero-padded values - you'd be going out of your
way to remove leading zeros before working with the field as a number.
It may be a problem for the names which have extra spaces. From what I can tell, an AMD
platform with SMBA must look like something like this:
| SMBA:0=2048
|   L3:0=00ff

I'll rip out the data_width - as fixing it, and making it a property resctrl determines
for itself is going to lead to boat over time for no benefit. I'll leave the name_width as
its marginally plausible a regex like "^L3" would misbehave with different kernel versions
on the same machine.


Thanks,

James

  reply	other threads:[~2024-09-13 18:08 UTC|newest]

Thread overview: 65+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-08-02 17:28 [PATCH v4 00/39] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2024-08-02 17:28 ` [PATCH v4 01/39] x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no monitors James Morse
2024-08-02 17:28 ` [PATCH v4 02/39] x86/resctrl: Add a helper to avoid reaching into the arch code resource list James Morse
2024-08-02 17:28 ` [PATCH v4 03/39] x86/resctrl: Remove fflags from struct rdt_resource James Morse
2024-08-14  3:53   ` Reinette Chatre
2024-08-02 17:28 ` [PATCH v4 04/39] x86/resctrl: Use schema type to determine how to parse schema values James Morse
2024-08-14  3:56   ` Reinette Chatre
2024-09-06 18:06     ` James Morse
2024-09-16 22:33       ` Reinette Chatre
2024-09-30 16:42         ` James Morse
2024-08-02 17:28 ` [PATCH v4 05/39] x86/resctrl: Use schema type to determine the schema format string James Morse
2024-08-14  3:57   ` Reinette Chatre
2024-08-02 17:28 ` [PATCH v4 06/39] x86/resctrl: Move data_width to be a schema property James Morse
2024-08-14  3:59   ` Reinette Chatre
2024-09-13 18:07     ` James Morse [this message]
2024-08-02 17:28 ` [PATCH v4 07/39] x86/resctrl: Add max_bw to struct resctrl_membw James Morse
2024-08-14  4:00   ` Reinette Chatre
2024-08-02 17:28 ` [PATCH v4 08/39] x86/resctrl: Generate default_ctrl instead of sharing it James Morse
2024-08-14  4:00   ` Reinette Chatre
2024-09-13 18:07     ` James Morse
2024-09-16 22:34       ` Reinette Chatre
2024-08-02 17:28 ` [PATCH v4 09/39] x86/resctrl: Add helper for setting CPU default properties James Morse
2024-08-02 17:28 ` [PATCH v4 10/39] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid() James Morse
2024-08-02 17:28 ` [PATCH v4 11/39] x86/resctrl: Export resctrl fs's init function James Morse
2024-08-14  4:01   ` Reinette Chatre
2024-08-02 17:28 ` [PATCH v4 12/39] x86/resctrl: Wrap resctrl_arch_find_domain() around rdt_find_domain() James Morse
2024-08-02 17:28 ` [PATCH v4 13/39] x86/resctrl: Move resctrl types to a separate header James Morse
2024-08-02 17:28 ` [PATCH v4 14/39] x86/resctrl: Add a resctrl helper to reset all the resources James Morse
2024-08-02 17:28 ` [PATCH v4 15/39] x86/resctrl: Move monitor exit work to a resctrl exit call James Morse
2024-08-14  4:01   ` Reinette Chatre
2024-09-30 16:42     ` James Morse
2024-08-02 17:28 ` [PATCH v4 16/39] x86/resctrl: Move monitor init work to a resctrl init call James Morse
2024-08-02 17:28 ` [PATCH v4 17/39] x86/resctrl: Rewrite and move the for_each_*_rdt_resource() walkers James Morse
2024-08-15  6:43   ` Shaopeng Tan (Fujitsu)
2024-09-30 16:42     ` James Morse
2024-08-02 17:28 ` [PATCH v4 18/39] x86/resctrl: Export the is_mbm_*_enabled() helpers to asm/resctrl.h James Morse
2024-08-02 17:28 ` [PATCH v4 19/39] x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC James Morse
2024-08-14  4:01   ` Reinette Chatre
2024-08-02 17:28 ` [PATCH v4 20/39] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers James Morse
2024-08-14  4:02   ` Reinette Chatre
2024-10-02 16:58     ` James Morse
2024-08-02 17:28 ` [PATCH v4 21/39] x86/resctrl: Move mbm_cfg_mask to struct rdt_resource James Morse
2024-08-02 17:28 ` [PATCH v4 22/39] x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions James Morse
2024-08-02 17:28 ` [PATCH v4 23/39] x86/resctrl: Allow an architecture to disable pseudo lock James Morse
2024-08-14  4:02   ` Reinette Chatre
2024-08-02 17:28 ` [PATCH v4 24/39] x86/resctrl: Make prefetch_disable_bits belong to the arch code James Morse
2024-08-02 17:28 ` [PATCH v4 25/39] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr James Morse
2024-08-02 17:28 ` [PATCH v4 26/39] x86/resctrl: Move thread_throttle_mode_init() to be managed by resctrl James Morse
2024-08-02 17:28 ` [PATCH v4 27/39] x86/resctrl: Move get_config_index() to a header James Morse
2024-08-02 17:28 ` [PATCH v4 28/39] x86/resctrl: Claim get_{mon,ctrl}_domain_from_cpu() helpers for resctrl James Morse
2024-08-02 17:28 ` [PATCH v4 29/39] x86/resctrl: Describe resctrl's bitmap size assumptions James Morse
2024-08-02 17:28 ` [PATCH v4 30/39] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2024-08-02 17:28 ` [PATCH v4 31/39] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2024-08-02 17:28 ` [PATCH v4 32/39] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2024-08-02 17:28 ` [PATCH v4 33/39] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2024-08-02 17:28 ` [PATCH v4 34/39] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2024-08-02 17:28 ` [PATCH v4 35/39] x86/resctrl: Remove a newline to avoid confusing the code move script James Morse
2024-08-02 17:28 ` [PATCH v4 36/39] x86/resctrl: Split trace.h James Morse
2024-08-02 17:28 ` [PATCH v4 37/39] fs/resctrl: Add boiler plate for external resctrl code James Morse
2024-08-14  4:04   ` Reinette Chatre
2024-08-02 17:28 ` [PATCH v4 38/39] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2024-08-02 17:28 ` [PATCH v4 39/39] x86/resctrl: Add python script to move resctrl code to /fs/resctrl James Morse
2024-08-06  7:13 ` [PATCH v4 00/39] x86/resctrl: Move the resctrl filesystem " Shaopeng Tan (Fujitsu)
2024-08-15  7:04   ` Shaopeng Tan (Fujitsu)
2024-10-02 16:58     ` James Morse

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=c3c8bd5d-b527-4365-b4d6-3bc126a49f36@arm.com \
    --to=james.morse@arm.com \
    --cc=Babu.Moger@amd.com \
    --cc=amitsinght@marvell.com \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=bobo.shaobowang@huawei.com \
    --cc=bp@alien8.de \
    --cc=carl@os.amperecomputing.com \
    --cc=dave.martin@arm.com \
    --cc=david@redhat.com \
    --cc=dfustini@baylibre.com \
    --cc=fenghua.yu@intel.com \
    --cc=hpa@zytor.com \
    --cc=lcherian@marvell.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peternewman@google.com \
    --cc=quic_jiles@quicinc.com \
    --cc=reinette.chatre@intel.com \
    --cc=rex.nie@jaguarmicro.com \
    --cc=scott@os.amperecomputing.com \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=tan.shaopeng@fujitsu.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    --cc=xhao@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®