From: Dave Hansen <dave.hansen@intel.com>
To: Borislav Petkov <bp@alien8.de>,
Dave Hansen <dave.hansen@linux.intel.com>
Cc: linux-kernel@vger.kernel.org, sohil.mehta@intel.com,
zhao1.liu@intel.com, "H. Peter Anvin" <hpa@zytor.com>,
Ingo Molnar <mingo@redhat.com>, Jon Kohler <jon@nutanix.com>,
Pawan Gupta <pawan.kumar.gupta@linux.intel.com>,
"Peter Zijlstra (Intel)" <peterz@infradead.org>,
Thomas Gleixner <tglx@kernel.org>,
Tony Luck <tony.luck@intel.com>,
x86@kernel.org
Subject: Re: [PATCH 4/6] x86/cpu: Add platform ID to CPU info structure
Date: Wed, 11 Feb 2026 10:40:21 -0800 [thread overview]
Message-ID: <c5a85692-3704-4462-ac15-4c5657f95147@intel.com> (raw)
In-Reply-To: <20260208213735.GCaYkCHz1cxp-Ivm7L@fat_crate.local>
On 2/8/26 13:37, Borislav Petkov wrote:
> On Fri, Feb 06, 2026 at 03:14:45PM -0800, Dave Hansen wrote:
>> diff -puN arch/x86/include/asm/processor.h~cpu-x86_stepping arch/x86/include/asm/processor.h
>> --- a/arch/x86/include/asm/processor.h~cpu-x86_stepping 2026-02-06 15:14:23.528790212 -0800
>> +++ b/arch/x86/include/asm/processor.h 2026-02-06 15:14:23.567791582 -0800
>> @@ -140,6 +140,8 @@ struct cpuinfo_x86 {
>> __u32 x86_vfm;
>> };
>> __u8 x86_stepping;
>> + /* Intel-only. 3 bits: */
>> + __u8 x86_platform_id;
> Can we call this something more generic so that we can do:
>
> /* On Intel: platform ID
> /* On AMD: something else
>
> so that we can use this on both vendors?
>
> I don't have any usage in mind on AMD now but it might come in handy some day.
I'm racking my brain but having a hard time coming up with a good name
that would work for unknown future AMD things. ;)
Any suggestions? I'm not married to the name in any way.
I could prefix it with 'intel_' to make it more clear that someone _can_
do a union in the future, like we do with "Hardware defined CPU-type".
Or we could do:
union {
u8 intel_platform_id;
u8 amd_unused;
};
to make it utterly clear that it's free for use on AMD if someone goes
looking for AMD-usable space.
next prev parent reply other threads:[~2026-02-11 18:40 UTC|newest]
Thread overview: 41+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-02-06 23:14 [PATCH 0/6] [v2] x86/cpu: Take Intel platform into account for old microcode checks Dave Hansen
2026-02-06 23:14 ` [PATCH 1/6] x86/cpu: Break Vendor/Family/Model macros into separate header Dave Hansen
2026-02-10 22:13 ` Sohil Mehta
2026-02-10 22:17 ` Dave Hansen
2026-02-10 23:03 ` Sohil Mehta
2026-02-10 23:32 ` Luck, Tony
2026-02-10 23:35 ` Dave Hansen
2026-02-10 23:52 ` Luck, Tony
2026-02-11 21:12 ` Dave Hansen
2026-02-11 21:54 ` Sohil Mehta
2026-02-11 22:32 ` Luck, Tony
2026-02-11 22:35 ` Sohil Mehta
2026-02-11 23:02 ` Dave Hansen
2026-02-11 22:21 ` Luck, Tony
2026-02-06 23:14 ` [PATCH 2/6] x86/cpu: Add missing #include Dave Hansen
2026-02-06 23:14 ` [PATCH 3/6] x86/microcode: Refactor platform ID enumeration into a helper Dave Hansen
2026-02-10 23:20 ` Sohil Mehta
2026-02-10 23:23 ` Dave Hansen
2026-02-06 23:14 ` [PATCH 4/6] x86/cpu: Add platform ID to CPU info structure Dave Hansen
2026-02-08 21:37 ` Borislav Petkov
2026-02-11 18:40 ` Dave Hansen [this message]
2026-02-12 15:22 ` Borislav Petkov
2026-02-10 23:23 ` Sohil Mehta
2026-02-06 23:14 ` [PATCH 5/6] x86/cpu: Add platform ID to CPU matching structure Dave Hansen
2026-02-10 23:27 ` Sohil Mehta
2026-02-06 23:14 ` [PATCH 6/6] x86/microcode: Add platform mask to Intel microcode "old" list Dave Hansen
2026-02-10 23:39 ` Sohil Mehta
2026-02-09 10:20 ` [PATCH 0/6] [v2] x86/cpu: Take Intel platform into account for old microcode checks Maciej Wieczor-Retman
2026-02-09 15:15 ` Dave Hansen
-- strict thread matches above, loose matches on Subject: below --
2026-01-20 14:34 [PATCH 4/6] x86/cpu: Add platform ID to CPU info structure Maciej Wieczor-Retman
2026-01-20 15:13 ` Dave Hansen
2026-01-20 16:03 ` Maciej Wieczor-Retman
2026-01-20 16:12 ` Dave Hansen
2026-01-19 19:50 [PATCH 0/6] x86/cpu: Take Intel platform into account for old microcode checks Dave Hansen
2026-01-19 19:50 ` [PATCH 4/6] x86/cpu: Add platform ID to CPU info structure Dave Hansen
2026-01-20 3:14 ` Chao Gao
2026-01-20 15:22 ` Dave Hansen
2026-01-21 2:03 ` Chao Gao
2026-01-20 8:27 ` Andy Shevchenko
2026-01-20 15:06 ` Dave Hansen
2026-01-20 20:44 ` Andy Shevchenko
2026-01-20 20:48 ` Dave Hansen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=c5a85692-3704-4462-ac15-4c5657f95147@intel.com \
--to=dave.hansen@intel.com \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=hpa@zytor.com \
--cc=jon@nutanix.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=pawan.kumar.gupta@linux.intel.com \
--cc=peterz@infradead.org \
--cc=sohil.mehta@intel.com \
--cc=tglx@kernel.org \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
--cc=zhao1.liu@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®