* Re: [PATCH net-next] i40e: Use common error handling code in i40e_register_auxiliary_dev()
2026-06-10 8:20 [PATCH net-next] i40e: Use common error handling code in i40e_register_auxiliary_dev() Markus Elfring
@ 2026-06-10 8:30 ` Manuel Ebner
2026-06-10 10:36 ` Markus Elfring
2026-06-10 9:12 ` [Intel-wired-lan] " Loktionov, Aleksandr
2026-06-11 9:13 ` Jagielski, Jedrzej
2 siblings, 1 reply; 5+ messages in thread
From: Manuel Ebner @ 2026-06-10 8:30 UTC (permalink / raw)
To: Markus Elfring, intel-wired-lan, netdev, Andrew Lunn,
David S. Miller, Eric Dumazet, Jakub Kicinski, Paolo Abeni,
Przemek Kitszel, Shiraz Saleem, Tony Nguyen
Cc: LKML, kernel-janitors
On Wed, 2026-06-10 at 10:20 +0200, Markus Elfring wrote:
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Wed, 10 Jun 2026 10:02:58 +0200
>
> [...]
>
> diff --git a/drivers/net/ethernet/intel/i40e/i40e_client.c
> b/drivers/net/ethernet/intel/i40e/i40e_client.c
> index 84a97ca8a6d8..389b8b83afbd 100644
> --- a/drivers/net/ethernet/intel/i40e/i40e_client.c
> +++ b/drivers/net/ethernet/intel/i40e/i40e_client.c
> @@ -304,15 +304,15 @@ static int i40e_register_auxiliary_dev(struct i40e_info *ldev,
> const char *name)
> ldev->aux_dev = aux_dev;
>
> ret = ida_alloc(&i40e_client_ida, GFP_KERNEL);
> - if (ret < 0) {
> - kfree(i40e_aux_dev);
> - return ret;
> - }
> + if (ret < 0)
> + goto free_aux_dev;
> +
> aux_dev->id = ret;
>
> ret = auxiliary_device_init(aux_dev);
> if (ret < 0) {
> ida_free(&i40e_client_ida, aux_dev->id);
> +free_aux_dev:
> kfree(i40e_aux_dev);
> return ret;
why do you do this? There's no functional change, right?
is it just readability?
Thanks
Manuel
^ permalink raw reply [flat|nested] 5+ messages in thread* Re: [PATCH net-next] i40e: Use common error handling code in i40e_register_auxiliary_dev()
2026-06-10 8:30 ` Manuel Ebner
@ 2026-06-10 10:36 ` Markus Elfring
0 siblings, 0 replies; 5+ messages in thread
From: Markus Elfring @ 2026-06-10 10:36 UTC (permalink / raw)
To: Manuel Ebner, intel-wired-lan, netdev, Andrew Lunn,
David S. Miller, Eric Dumazet, Jakub Kicinski, Paolo Abeni,
Przemek Kitszel, Tony Nguyen
Cc: LKML, kernel-janitors, Aleksandr Loktionov
>> +++ b/drivers/net/ethernet/intel/i40e/i40e_client.c
>> @@ -304,15 +304,15 @@ static int i40e_register_auxiliary_dev(struct i40e_info *ldev,
>> const char *name)
>> ldev->aux_dev = aux_dev;
>>
>> ret = ida_alloc(&i40e_client_ida, GFP_KERNEL);
>> - if (ret < 0) {
>> - kfree(i40e_aux_dev);
>> - return ret;
>> - }
>> + if (ret < 0)
>> + goto free_aux_dev;
>> +
>> aux_dev->id = ret;
>>
>> ret = auxiliary_device_init(aux_dev);
>> if (ret < 0) {
>> ida_free(&i40e_client_ida, aux_dev->id);
>> +free_aux_dev:
>> kfree(i40e_aux_dev);
>> return ret;
> why do you do this? There's no functional change, right?
> is it just readability?
Please take another look at corresponding information sources.
* Centralized exiting of functions
https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/Documentation/process/coding-style.rst?h=v7.1-rc7#n526
* https://cmu-sei.github.io/secure-coding-standards/sei-cert-c-coding-standard/recommendations/memory-management-mem/mem12-c/
Would you like to increase the application of scope-based resource management?
Regards,
Markus
^ permalink raw reply [flat|nested] 5+ messages in thread
* RE: [Intel-wired-lan] [PATCH net-next] i40e: Use common error handling code in i40e_register_auxiliary_dev()
2026-06-10 8:20 [PATCH net-next] i40e: Use common error handling code in i40e_register_auxiliary_dev() Markus Elfring
2026-06-10 8:30 ` Manuel Ebner
@ 2026-06-10 9:12 ` Loktionov, Aleksandr
2026-06-11 9:13 ` Jagielski, Jedrzej
2 siblings, 0 replies; 5+ messages in thread
From: Loktionov, Aleksandr @ 2026-06-10 9:12 UTC (permalink / raw)
To: Markus Elfring, intel-wired-lan, netdev, Andrew Lunn,
David S. Miller, Eric Dumazet, Jakub Kicinski, Paolo Abeni,
Kitszel, Przemyslaw, Shiraz Saleem, Nguyen, Anthony L
Cc: LKML, kernel-janitors
> -----Original Message-----
> From: Intel-wired-lan <intel-wired-lan-bounces@osuosl.org> On Behalf
> Of Markus Elfring
> Sent: Wednesday, June 10, 2026 10:20 AM
> To: intel-wired-lan@lists.osuosl.org; netdev@vger.kernel.org; Andrew
> Lunn <andrew+netdev@lunn.ch>; David S. Miller <davem@davemloft.net>;
> Eric Dumazet <edumazet@google.com>; Jakub Kicinski
> <kuba@kernel.org>; Paolo Abeni <pabeni@redhat.com>; Kitszel,
> Przemyslaw <przemyslaw.kitszel@intel.com>; Shiraz Saleem
> <shiraz.saleem@intel.com>; Nguyen, Anthony L
> <anthony.l.nguyen@intel.com>
> Cc: LKML <linux-kernel@vger.kernel.org>; kernel-
> janitors@vger.kernel.org
> Subject: [Intel-wired-lan] [PATCH net-next] i40e: Use common error
> handling code in i40e_register_auxiliary_dev()
>
> From: Markus Elfring <elfring@users.sourceforge.net>
> Date: Wed, 10 Jun 2026 10:02:58 +0200
>
> Use an additional label so that a bit of exception handling can be
> better reused at the end of an if branch.
>
> This issue was detected by using the Coccinelle software.
>
> Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
> ---
> drivers/net/ethernet/intel/i40e/i40e_client.c | 8 ++++----
> 1 file changed, 4 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/net/ethernet/intel/i40e/i40e_client.c
> b/drivers/net/ethernet/intel/i40e/i40e_client.c
> index 84a97ca8a6d8..389b8b83afbd 100644
> --- a/drivers/net/ethernet/intel/i40e/i40e_client.c
> +++ b/drivers/net/ethernet/intel/i40e/i40e_client.c
> @@ -304,15 +304,15 @@ static int i40e_register_auxiliary_dev(struct
> i40e_info *ldev, const char *name)
> ldev->aux_dev = aux_dev;
>
> ret = ida_alloc(&i40e_client_ida, GFP_KERNEL);
> - if (ret < 0) {
> - kfree(i40e_aux_dev);
> - return ret;
> - }
> + if (ret < 0)
> + goto free_aux_dev;
> +
> aux_dev->id = ret;
>
> ret = auxiliary_device_init(aux_dev);
> if (ret < 0) {
> ida_free(&i40e_client_ida, aux_dev->id);
It's not linux kernel error handling.
Please, either leave the original code as-is — the two-line duplication is not a real problem.
Or submit a proper two-label refactor with a clear commit message.
> +free_aux_dev:
> kfree(i40e_aux_dev);
> return ret;
> }
> --
> 2.54.0
^ permalink raw reply [flat|nested] 5+ messages in thread* RE: [PATCH net-next] i40e: Use common error handling code in i40e_register_auxiliary_dev()
2026-06-10 8:20 [PATCH net-next] i40e: Use common error handling code in i40e_register_auxiliary_dev() Markus Elfring
2026-06-10 8:30 ` Manuel Ebner
2026-06-10 9:12 ` [Intel-wired-lan] " Loktionov, Aleksandr
@ 2026-06-11 9:13 ` Jagielski, Jedrzej
2 siblings, 0 replies; 5+ messages in thread
From: Jagielski, Jedrzej @ 2026-06-11 9:13 UTC (permalink / raw)
To: Markus Elfring, intel-wired-lan, netdev, Andrew Lunn,
David S. Miller, Eric Dumazet, Jakub Kicinski, Paolo Abeni,
Kitszel, Przemyslaw, Shiraz Saleem, Nguyen, Anthony L
Cc: LKML, kernel-janitors
From: Markus Elfring <Markus.Elfring@web.de>
Sent: Wednesday, June 10, 2026 10:20 AM
>From: Markus Elfring <elfring@users.sourceforge.net>
>Date: Wed, 10 Jun 2026 10:02:58 +0200
>
>Use an additional label so that a bit of exception handling can be better
>reused at the end of an if branch.
>
>This issue was detected by using the Coccinelle software.
>
>Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
Hi,
Do we really need patches like this one? It's pointless
^ permalink raw reply [flat|nested] 5+ messages in thread