From: Can Guo <quic_cang@quicinc.com>
To: Andrew Halaney <ahalaney@redhat.com>, Can Guo <cang@qti.qualcomm.com>
Cc: bvanassche@acm.org, mani@kernel.org, stanley.chu@mediatek.com,
adrian.hunter@intel.com, beanhuo@micron.com, avri.altman@wdc.com,
junwoo80.lee@samsung.com, martin.petersen@oracle.com,
linux-scsi@vger.kernel.org,
"Alim Akhtar" <alim.akhtar@samsung.com>,
"James E.J. Bottomley" <jejb@linux.ibm.com>,
"Krzysztof Kozlowski" <krzysztof.kozlowski@linaro.org>,
"Andy Gross" <agross@kernel.org>,
"Bjorn Andersson" <andersson@kernel.org>,
"Konrad Dybcio" <konrad.dybcio@linaro.org>,
"Matthias Brugger" <matthias.bgg@gmail.com>,
"AngeloGioacchino Del Regno"
<angelogioacchino.delregno@collabora.com>,
"Uwe Kleine-König" <u.kleine-koenig@pengutronix.de>,
"Brian Masney" <bmasney@redhat.com>,
"moderated list:ARM/SAMSUNG S3C,
S5P AND EXYNOS ARM ARCHITECTURES"
<linux-arm-kernel@lists.infradead.org>,
"open list:ARM/SAMSUNG S3C,
S5P AND EXYNOS ARM ARCHITECTURES"
<linux-samsung-soc@vger.kernel.org>,
"open list" <linux-kernel@vger.kernel.org>,
"moderated list:UNIVERSAL FLASH STORAGE HOST CONTROLLER
DRIVER..." <linux-mediatek@lists.infradead.org>,
"open list:UNIVERSAL FLASH STORAGE HOST CONTROLLER DRIVER..."
<linux-arm-msm@vger.kernel.org>
Subject: Re: [PATCH v2 1/7] scsi: ufs: host: Rename structure ufs_dev_params to ufs_host_params
Date: Wed, 8 Nov 2023 15:44:49 +0800 [thread overview]
Message-ID: <cbe26ea4-07b9-9922-07f5-d4b96f910b56@quicinc.com> (raw)
In-Reply-To: <fcovysoo6vxvqdrypfbnfyclrmifibio46rne5zhiqnmqhzd7k@5ltemasdhfxp>
Hi Andrew,
On 11/8/2023 3:36 AM, Andrew Halaney wrote:
> On Mon, Nov 06, 2023 at 08:46:07PM -0800, Can Guo wrote:
>> From: Can Guo <quic_cang@quicinc.com>
>>
>> Structure ufs_dev_params is actually used in UFS host vendor drivers to
>> declare host specific power mode parameters, like ufs_<vendor>_params or
>> host_cap, which makes the code not very straightforward to read. Rename the
>> structure ufs_dev_params to ufs_host_params and unify the declarations in
>> all vendor drivers to host_params.
>>
>> In addition, rename the two functions ufshcd_init_dev_pwr_param() and
> nit: s/ufshcd_init_dev_pwr_param/ufshcd_init_pwr_dev_param/
sure
>
>> ufshcd_get_dev_pwr_param() which work based on the ufs_host_params to
> nit: s/ufshcd_get_dev_pwr_param/ufshcd_get_pwr_dev_param/
sure
>
>> ufshcd_init_host_param() and ufshcd_negotiate_pwr_param() respectively to
>> avoid confusions.
>>
>> This change does not change any functionalities or logic.
>>
>> Signed-off-by: Can Guo <quic_cang@quicinc.com>
>> ---
>> drivers/ufs/host/ufs-exynos.c | 7 +++---
>> drivers/ufs/host/ufs-hisi.c | 11 ++++-----
>> drivers/ufs/host/ufs-mediatek.c | 12 ++++------
>> drivers/ufs/host/ufs-qcom.c | 12 ++++------
>> drivers/ufs/host/ufshcd-pltfrm.c | 49 ++++++++++++++++++++--------------------
>> drivers/ufs/host/ufshcd-pltfrm.h | 10 ++++----
>> 6 files changed, 47 insertions(+), 54 deletions(-)
>>
> <snip>
>
>> diff --git a/drivers/ufs/host/ufshcd-pltfrm.c b/drivers/ufs/host/ufshcd-pltfrm.c
>> index da2558e..6e65b61 100644
>> --- a/drivers/ufs/host/ufshcd-pltfrm.c
>> +++ b/drivers/ufs/host/ufshcd-pltfrm.c
>> @@ -285,17 +285,17 @@ static int ufshcd_parse_operating_points(struct ufs_hba *hba)
>> }
>>
>> /**
>> - * ufshcd_get_pwr_dev_param - get finally agreed attributes for
>> + * ufshcd_negotiate_pwr_param - get finally agreed attributes for
>> * power mode change
>> - * @pltfrm_param: pointer to platform parameters
>> + * @host_param: pointer to platform parameters
>> * @dev_max: pointer to device attributes
>> * @agreed_pwr: returned agreed attributes
>> *
>> * Return: 0 on success, non-zero value on failure.
>> */
>> -int ufshcd_get_pwr_dev_param(const struct ufs_dev_params *pltfrm_param,
>> - const struct ufs_pa_layer_attr *dev_max,
>> - struct ufs_pa_layer_attr *agreed_pwr)
>> +int ufshcd_negotiate_pwr_param(const struct ufs_host_params *host_param,
>> + const struct ufs_pa_layer_attr *dev_max,
>> + struct ufs_pa_layer_attr *agreed_pwr)
>> {
>> int min_pltfrm_gear;
> If you're going to change pltfrm -> host, maybe do so for
> min_pltfrm_gear too? I think this all reads nicer with the functions
> changed as is, but the consistency would be nice in my opinion.
Sure, will address in next version.
>
> Outside of those nits, I think this reads nicer now as well.
>
> Acked-by: Andrew Halaney <ahalaney@redhat.com>
Thanks,
Can Guo
next prev parent reply other threads:[~2023-11-08 7:45 UTC|newest]
Thread overview: 53+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-11-07 4:46 [PATCH v2 0/7] Enable HS-G5 support on SM8550 Can Guo
2023-11-07 4:46 ` [PATCH v2 1/7] scsi: ufs: host: Rename structure ufs_dev_params to ufs_host_params Can Guo
2023-11-07 19:36 ` Andrew Halaney
2023-11-08 7:44 ` Can Guo [this message]
2023-11-07 20:56 ` Bart Van Assche
2023-11-08 7:48 ` Can Guo
2023-11-07 4:46 ` [PATCH v2 2/7] scsi: ufs: ufs-qcom: Setup host power mode during init Can Guo
2023-11-07 20:14 ` Andrew Halaney
2023-11-08 7:47 ` Can Guo
2023-11-08 5:07 ` Manivannan Sadhasivam
2023-11-08 8:07 ` Can Guo
2023-11-07 4:46 ` [PATCH v2 3/7] scsi: ufs: ufs-qcom: Allow the first init start with the maximum supported gear Can Guo
2023-11-08 5:23 ` Manivannan Sadhasivam
2023-11-08 8:21 ` Can Guo
2023-11-08 8:23 ` Can Guo
2023-11-09 3:47 ` Manivannan Sadhasivam
2023-11-09 4:07 ` Can Guo
2023-11-09 7:47 ` Manivannan Sadhasivam
2023-11-07 4:46 ` [PATCH v2 4/7] scsi: ufs: ufs-qcom: Limit HS-G5 Rate-A to hosts with HW version 5 Can Guo
2023-11-08 5:25 ` Manivannan Sadhasivam
2023-11-08 8:42 ` Can Guo
2023-11-09 3:27 ` Manivannan Sadhasivam
2023-11-07 4:46 ` [PATCH v2 5/7] scsi: ufs: ufs-qcom: Set initial PHY gear to max HS gear for HW ver 5 and newer Can Guo
2023-11-08 5:34 ` Manivannan Sadhasivam
2023-11-08 8:46 ` Can Guo
2023-11-07 4:46 ` [PATCH v2 6/7] phy: qualcomm: phy-qcom-qmp-ufs: Add High Speed Gear 5 support for SM8550 Can Guo
2023-11-07 13:18 ` Dmitry Baryshkov
2023-11-08 5:49 ` Manivannan Sadhasivam
2023-11-08 6:56 ` Dmitry Baryshkov
2023-11-09 3:24 ` Manivannan Sadhasivam
2023-11-09 9:40 ` Dmitry Baryshkov
2023-11-09 10:42 ` Manivannan Sadhasivam
2023-11-09 11:00 ` Dmitry Baryshkov
2023-11-09 16:04 ` Manivannan Sadhasivam
2023-11-09 22:11 ` Dmitry Baryshkov
2023-11-10 13:18 ` Manivannan Sadhasivam
2023-11-10 14:40 ` Can Guo
2023-11-11 4:12 ` Manivannan Sadhasivam
2023-11-12 5:13 ` Can Guo
2023-11-14 6:12 ` Manivannan Sadhasivam
2023-11-14 9:15 ` Dmitry Baryshkov
2023-11-15 7:51 ` Can Guo
2023-11-08 9:19 ` Can Guo
2023-11-09 3:26 ` Manivannan Sadhasivam
2023-11-08 9:02 ` Can Guo
2023-11-10 8:47 ` neil.armstrong
2023-11-10 9:03 ` Can Guo
2023-11-10 9:17 ` neil.armstrong
2023-11-10 9:32 ` Can Guo
2023-11-10 9:35 ` neil.armstrong
2023-11-07 4:46 ` [PATCH v2 7/7] scsi: ufs: ufs-qcom: Add support for UFS device version detection Can Guo
2023-11-08 5:11 ` [PATCH v2 0/7] Enable HS-G5 support on SM8550 Manivannan Sadhasivam
2023-11-08 8:09 ` Can Guo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=cbe26ea4-07b9-9922-07f5-d4b96f910b56@quicinc.com \
--to=quic_cang@quicinc.com \
--cc=adrian.hunter@intel.com \
--cc=agross@kernel.org \
--cc=ahalaney@redhat.com \
--cc=alim.akhtar@samsung.com \
--cc=andersson@kernel.org \
--cc=angelogioacchino.delregno@collabora.com \
--cc=avri.altman@wdc.com \
--cc=beanhuo@micron.com \
--cc=bmasney@redhat.com \
--cc=bvanassche@acm.org \
--cc=cang@qti.qualcomm.com \
--cc=jejb@linux.ibm.com \
--cc=junwoo80.lee@samsung.com \
--cc=konrad.dybcio@linaro.org \
--cc=krzysztof.kozlowski@linaro.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=linux-samsung-soc@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=mani@kernel.org \
--cc=martin.petersen@oracle.com \
--cc=matthias.bgg@gmail.com \
--cc=stanley.chu@mediatek.com \
--cc=u.kleine-koenig@pengutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®