mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Nitin Rawat <quic_nitirawa@quicinc.com>
To: Bjorn Andersson <quic_bjorande@quicinc.com>
Cc: <mani@kernel.org>, <agross@kernel.org>, <andersson@kernel.org>,
	<konrad.dybcio@linaro.org>, <jejb@linux.ibm.com>,
	<martin.petersen@oracle.com>, <quic_cang@quicinc.com>,
	<quic_nguyenb@quicinc.com>, <linux-scsi@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>, <linux-arm-msm@vger.kernel.org>,
	"Naveen Kumar Goud Arepalli" <quic_narepall@quicinc.com>
Subject: Re: [PATCH V6 2/6] scsi: ufs: qcom: Configure PA_VS_CORE_CLK_40NS_CYCLES
Date: Mon, 4 Sep 2023 20:05:57 +0530	[thread overview]
Message-ID: <ccff18d5-38a5-919b-461b-941e9a6f2817@quicinc.com> (raw)
In-Reply-To: <20230901153034.GS818859@hu-bjorande-lv.qualcomm.com>



On 9/1/2023 9:00 PM, Bjorn Andersson wrote:
> On Fri, Sep 01, 2023 at 05:13:32PM +0530, Nitin Rawat wrote:
>> Configure PA_VS_CORE_CLK_40NS_CYCLES with frequency of unipro core clk
>> for Qualcomm UFS controller V4.0 and onwards to align with the hardware
>> specification.
>>
>> Co-developed-by: Naveen Kumar Goud Arepalli <quic_narepall@quicinc.com>
>> Signed-off-by: Naveen Kumar Goud Arepalli <quic_narepall@quicinc.com>
>> Signed-off-by: Nitin Rawat <quic_nitirawa@quicinc.com>
>> ---
>>   drivers/ufs/host/ufs-qcom.c | 47 ++++++++++++++++++++++++++++---------
>>   drivers/ufs/host/ufs-qcom.h |  2 ++
>>   2 files changed, 38 insertions(+), 11 deletions(-)
>>
>> diff --git a/drivers/ufs/host/ufs-qcom.c b/drivers/ufs/host/ufs-qcom.c
>> index fe36003faaa8..018e391c276e 100644
>> --- a/drivers/ufs/host/ufs-qcom.c
>> +++ b/drivers/ufs/host/ufs-qcom.c
>> @@ -93,8 +93,9 @@ static const struct __ufs_qcom_bw_table {
>>   static struct ufs_qcom_host *ufs_qcom_hosts[MAX_UFS_QCOM_HOSTS];
>>
>>   static void ufs_qcom_get_default_testbus_cfg(struct ufs_qcom_host *host);
>> -static int ufs_qcom_set_dme_vs_core_clk_ctrl_clear_div(struct ufs_hba *hba,
>> -						       u32 clk_cycles);
>> +static int ufs_qcom_set_core_clk_ctrl(struct ufs_hba *hba,
>> +						       u32 clk_cycles,
>> +						       u32 clk_40ns_cycles);
>>
>>   static struct ufs_qcom_host *rcdev_to_ufs_host(struct reset_controller_dev *rcd)
>>   {
>> @@ -690,8 +691,8 @@ static int ufs_qcom_link_startup_notify(struct ufs_hba *hba,
>>   			 * set unipro core clock cycles to 150 & clear clock
>>   			 * divider
>>   			 */
>> -			err = ufs_qcom_set_dme_vs_core_clk_ctrl_clear_div(hba,
>> -									  150);
>> +			err = ufs_qcom_set_core_clk_ctrl(hba,
>> +									  150, 6);
> 
> There's no reason to maintain the line wrap here, and the new
> indentation looks wrong.

   Sure..will remove it next patchset.

> 
>>
>>   		/*
>>   		 * Some UFS devices (and may be host) have issues if LCC is
>> @@ -1295,12 +1296,12 @@ static void ufs_qcom_exit(struct ufs_hba *hba)
>>   	phy_power_off(host->generic_phy);
>>   	phy_exit(host->generic_phy);
>>   }
>> -
>> -static int ufs_qcom_set_dme_vs_core_clk_ctrl_clear_div(struct ufs_hba *hba,
>> -						       u32 cycles_in_1us)
>> +static int ufs_qcom_set_core_clk_ctrl(struct ufs_hba *hba,
>> +					u32 cycles_in_1us,
> 
> Following my comment on this rename in the last commit, here you do
> change the prototype, so here you need the rename to clarify the intent,
> so make it here instead.


We will change the order of patch so that we need change the prototype 
in 1 place.

-Nitin

> 
>> +					u32 cycles_in_40ns)
>>   {
>>   	struct ufs_qcom_host *host = ufshcd_get_variant(hba);
>> -	u32 core_clk_ctrl_reg;
>> +	u32 core_clk_ctrl_reg, reg;
> 
> Please keep one variable declaration per line, in particular when using
> names like "core_clk_ctrl_reg" which looks much more like a type than a
> variable name...
> 
> I would have preferred "reg" instead of core_clk_ctrl_reg" and you could
> have used that same variable for both sections.
> 
>>   	int ret;
>>
>>   	ret = ufshcd_dme_get(hba,
>> @@ -1325,9 +1326,33 @@ static int ufs_qcom_set_dme_vs_core_clk_ctrl_clear_div(struct ufs_hba *hba,
>>   	/* Clear CORE_CLK_DIV_EN */
>>   	core_clk_ctrl_reg &= ~DME_VS_CORE_CLK_CTRL_CORE_CLK_DIV_EN_BIT;
>>
>> -	return ufshcd_dme_set(hba,
>> +	err = ufshcd_dme_set(hba,
> 
> I might be confused, but didn't you remove "err" in patch 1? Does this
> patch compile?
> 
>>   			    UIC_ARG_MIB(DME_VS_CORE_CLK_CTRL),
>>   			    core_clk_ctrl_reg);
>> +	/*
>> +	 * UFS host controller V4.0.0 onwards needs to program
>> +	 * PA_VS_CORE_CLK_40NS_CYCLES attribute per programmed
>> +	 * frequency of unipro core clk of UFS host controller.
>> +	 */
>> +	if (!err && (host->hw_ver.major >= 4)) {
> 
> Rather than if (previous-block-didn't-fail), add an explicit return if
> err is unfavourable. That will make it more obvious that this section
> relates to version >= 4 and nothing else.

Sure..Will take care in next patchset

> 
> 
> That said, you now have one function:
> 
> core_clk_ctrl(int a, int b)
> {
> 	do stuff based on a;
> 
> 	if (version > 4)
> 		do stuff based on b;
> }
> 
> It's pretty much one function for cycles_in_1us, with a separate
> function for cycles_in_40us bolted on at the end. How about just
> splitting it in two functions instead, and provide a small wrapper that
> calls one or both functions?

Sure...Will move cycles_in_40us to different function.



> 
>> +		if (cycles_in_40ns > PA_VS_CORE_CLK_40NS_CYCLES_MASK)
>> +			return -EINVAL;
>> +
>> +		err = ufshcd_dme_get(hba,
>> +				     UIC_ARG_MIB(PA_VS_CORE_CLK_40NS_CYCLES),
>> +				     &reg);
> 
> Leaving this line unwrapped seems to end up at 89 characters wide.
> Perfectly reasonable to do, in the name of readability.
> 
  Sure..Will address this in next patchset.


>> +		if (err)
>> +			return err;
>> +
>> +		reg &= ~PA_VS_CORE_CLK_40NS_CYCLES_MASK;
>> +		reg |= cycles_in_40ns;
>> +
>> +		err = ufshcd_dme_set(hba,
>> +				     UIC_ARG_MIB(PA_VS_CORE_CLK_40NS_CYCLES),
>> +				     reg);
> 
> Same as above.
Sure..Will address this in next patchset.

> 
> Regards,
> Bjorn

Thanks,
Nitin

  reply	other threads:[~2023-09-04 14:37 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-09-01 11:43 [PATCH V6 0/6] scsi: ufs: qcom: Align programming sequence as per HW spec Nitin Rawat
2023-09-01 11:43 ` [PATCH V6 1/6] scsi: ufs: qcom: Align mask for core_clk_1us_cycles Nitin Rawat
2023-09-01 15:17   ` Bjorn Andersson
2023-09-04 14:31     ` Nitin Rawat
2023-09-01 11:43 ` [PATCH V6 2/6] scsi: ufs: qcom: Configure PA_VS_CORE_CLK_40NS_CYCLES Nitin Rawat
2023-09-01 15:30   ` Bjorn Andersson
2023-09-04 14:35     ` Nitin Rawat [this message]
2023-09-01 11:43 ` [PATCH V6 3/6] scsi: ufs: qcom: Add multiple frequency support for unipro clk attributes Nitin Rawat
2023-09-01 15:40   ` Bjorn Andersson
2023-09-04 14:41     ` Nitin Rawat
2023-09-01 11:43 ` [PATCH V6 4/6] scsi: ufs: qcom: Align unipro clk attributes configuration as per HPG Nitin Rawat
2023-09-01 15:43   ` Bjorn Andersson
2023-09-04 14:44     ` Nitin Rawat
2023-09-01 11:43 ` [PATCH V6 5/6] scsi: ufs: qcom: Refactor ufs_qcom_cfg_timers function Nitin Rawat
2023-09-01 16:06   ` Bjorn Andersson
2023-09-04 14:48     ` Nitin Rawat
2023-09-01 11:43 ` [PATCH V6 6/6] scsi: ufs: qcom: Configure clk HW division based on scaling conditions Nitin Rawat
2023-09-01 16:13   ` Bjorn Andersson
2023-09-01 12:20 ` [PATCH V6 0/6] scsi: ufs: qcom: Align programming sequence as per HW spec Konrad Dybcio
2023-09-01 14:56 ` Andrew Halaney
2023-09-01 15:18   ` Bjorn Andersson
  -- strict thread matches above, loose matches on Subject: below --
2023-09-01 11:42 Nitin Rawat
2023-09-01 11:42 ` [PATCH V6 2/6] scsi: ufs: qcom: Configure PA_VS_CORE_CLK_40NS_CYCLES Nitin Rawat

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ccff18d5-38a5-919b-461b-941e9a6f2817@quicinc.com \
    --to=quic_nitirawa@quicinc.com \
    --cc=agross@kernel.org \
    --cc=andersson@kernel.org \
    --cc=jejb@linux.ibm.com \
    --cc=konrad.dybcio@linaro.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-scsi@vger.kernel.org \
    --cc=mani@kernel.org \
    --cc=martin.petersen@oracle.com \
    --cc=quic_bjorande@quicinc.com \
    --cc=quic_cang@quicinc.com \
    --cc=quic_narepall@quicinc.com \
    --cc=quic_nguyenb@quicinc.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®