From: Zhihao Cheng <chengzhihao1@huawei.com>
To: Yangtao Li <frank.li@vivo.com>
Cc: <linux-kernel@vger.kernel.org>, <linux-mtd@lists.infradead.org>,
<richard@nod.at>
Subject: Re: [PATCH] ubifs: remove unnecessary kobject_del()
Date: Thu, 6 Apr 2023 20:29:13 +0800 [thread overview]
Message-ID: <ce162145-e88f-9c5f-6182-4a57e8efd586@huawei.com> (raw)
In-Reply-To: <20230406090813.24111-1-frank.li@vivo.com>
Hi,
>> I think we should still reserve the 'redundant' kobject_del(),
>> removing it won't bring any performance improvement.
>
> Since it's redundant, why not to remove it.
>
In my personal view, 'redundant' means removing kobject_del() is okay,
it won't bring any bugs. But removing it won't make code more
readability or gain any performance improvement, so it could be
reserved. Whether to remove kobject_del() depends on UBIFS maintainer, I
just help to check if the modification could affect the normal logic.
prev parent reply other threads:[~2023-04-06 12:29 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-04-05 13:07 Yangtao Li
2023-04-06 3:36 ` Zhihao Cheng
2023-04-06 9:08 ` Yangtao Li
2023-04-06 12:29 ` Zhihao Cheng [this message]
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=ce162145-e88f-9c5f-6182-4a57e8efd586@huawei.com \
--to=chengzhihao1@huawei.com \
--cc=frank.li@vivo.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mtd@lists.infradead.org \
--cc=richard@nod.at \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®