mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v1 0/2] pinctrl: Use named initializers for platform_device_id arrays
@ 2026-05-27 15:42 Uwe Kleine-König (The Capable Hub)
  2026-05-27 15:43 ` [PATCH v1 1/2] " Uwe Kleine-König (The Capable Hub)
                   ` (2 more replies)
  0 siblings, 3 replies; 6+ messages in thread
From: Uwe Kleine-König (The Capable Hub) @ 2026-05-27 15:42 UTC (permalink / raw)
  To: Linus Walleij
  Cc: David Rhodes, Richard Fitzgerald, Charles Keepax,
	Mika Westerberg, Andy Shevchenko, Geert Uytterhoeven,
	linux-sound, patches, linux-gpio, linux-kernel,
	linux-renesas-soc

Hello,

this series targets to use named initializers for platform_device_id
arrays. In general these are better readable for humans and more robust
to changes in the respective struct definition.

This robustness is needed as I want to do

	diff --git a/include/linux/mod_devicetable.h b/include/linux/mod_devicetable.h
	--- a/include/linux/mod_devicetable.h
	+++ b/include/linux/mod_devicetable.h
	@@ -610,4 +610,7 @@ struct dmi_system_id {
	 struct platform_device_id {
		char name[PLATFORM_NAME_SIZE];
	-	kernel_ulong_t driver_data;
	+	union {
	+		kernel_ulong_t driver_data;
	+		const void *driver_data_ptr;
	+	};
	 };

which allows dropping several casts and eases porting CHERI to mainline
linux. A possible follow-up change is the following example:

	diff --git a/drivers/pinctrl/renesas/core.c b/drivers/pinctrl/renesas/core.c
	index a466ebf99593..5bb1c1205352 100644
	--- a/drivers/pinctrl/renesas/core.c
	+++ b/drivers/pinctrl/renesas/core.c
	@@ -1313,7 +1313,7 @@ static int sh_pfc_probe(struct platform_device *pdev)
		if (pdev->dev.of_node)
			info = of_device_get_match_data(&pdev->dev);
		else
	-		info = (const void *)platform_get_device_id(pdev)->driver_data;
	+		info = platform_get_device_id(pdev)->driver_data_ptr;
	 
		pfc = devm_kzalloc(&pdev->dev, sizeof(*pfc), GFP_KERNEL);
		if (pfc == NULL)
	@@ -1380,40 +1380,40 @@ static int sh_pfc_probe(struct platform_device *pdev)
	 
	 static const struct platform_device_id sh_pfc_id_table[] = {
	 #ifdef CONFIG_PINCTRL_PFC_SH7203
	-	{ .name = "pfc-sh7203", .driver_data = (kernel_ulong_t)&sh7203_pinmux_info },
	+	{ .name = "pfc-sh7203", .driver_data_ptr = &sh7203_pinmux_info },
	 #endif
	 #ifdef CONFIG_PINCTRL_PFC_SH7264
	-	{ .name = "pfc-sh7264", .driver_data = (kernel_ulong_t)&sh7264_pinmux_info },
	+	{ .name = "pfc-sh7264", .driver_data_ptr = &sh7264_pinmux_info },
	 #endif
	 #ifdef CONFIG_PINCTRL_PFC_SH7269
	-	{ .name = "pfc-sh7269", .driver_data = (kernel_ulong_t)&sh7269_pinmux_info },
	+	{ .name = "pfc-sh7269", .driver_data_ptr = &sh7269_pinmux_info },
	 #endif
	 #ifdef CONFIG_PINCTRL_PFC_SH7720
	-	{ .name = "pfc-sh7720", .driver_data = (kernel_ulong_t)&sh7720_pinmux_info },
	+	{ .name = "pfc-sh7720", .driver_data_ptr = &sh7720_pinmux_info },
	 #endif
	 #ifdef CONFIG_PINCTRL_PFC_SH7722
	-	{ .name = "pfc-sh7722", .driver_data = (kernel_ulong_t)&sh7722_pinmux_info },
	+	{ .name = "pfc-sh7722", .driver_data_ptr = &sh7722_pinmux_info },
	 #endif
	 #ifdef CONFIG_PINCTRL_PFC_SH7723
	-	{ .name = "pfc-sh7723", .driver_data = (kernel_ulong_t)&sh7723_pinmux_info },
	+	{ .name = "pfc-sh7723", .driver_data_ptr = &sh7723_pinmux_info },
	 #endif
	 #ifdef CONFIG_PINCTRL_PFC_SH7724
	-	{ .name = "pfc-sh7724", .driver_data = (kernel_ulong_t)&sh7724_pinmux_info },
	+	{ .name = "pfc-sh7724", .driver_data_ptr = &sh7724_pinmux_info },
	 #endif
	 #ifdef CONFIG_PINCTRL_PFC_SH7734
	-	{ .name = "pfc-sh7734", .driver_data = (kernel_ulong_t)&sh7734_pinmux_info },
	+	{ .name = "pfc-sh7734", .driver_data_ptr = &sh7734_pinmux_info },
	 #endif
	 #ifdef CONFIG_PINCTRL_PFC_SH7757
	-	{ .name = "pfc-sh7757", .driver_data = (kernel_ulong_t)&sh7757_pinmux_info },
	+	{ .name = "pfc-sh7757", .driver_data_ptr = &sh7757_pinmux_info },
	 #endif
	 #ifdef CONFIG_PINCTRL_PFC_SH7785
	-	{ .name = "pfc-sh7785", .driver_data = (kernel_ulong_t)&sh7785_pinmux_info },
	+	{ .name = "pfc-sh7785", .driver_data_ptr = &sh7785_pinmux_info },
	 #endif
	 #ifdef CONFIG_PINCTRL_PFC_SH7786
	-	{ .name = "pfc-sh7786", .driver_data = (kernel_ulong_t)&sh7786_pinmux_info },
	+	{ .name = "pfc-sh7786", .driver_data_ptr = &sh7786_pinmux_info },
	 #endif
	 #ifdef CONFIG_PINCTRL_PFC_SHX3
	-	{ .name = "pfc-shx3", .driver_data = (kernel_ulong_t)&shx3_pinmux_info },
	+	{ .name = "pfc-shx3", .driver_data_ptr = &shx3_pinmux_info },
	 #endif
		{ /* sentinel */ }
	 };

increasing readability due to less casting which also improves type safety.

If you consider the 2nd patch mostly churn, just drop it.

Best regards
Uwe

Uwe Kleine-König (The Capable Hub) (2):
  pinctrl: Use named initializers for platform_device_id arrays
  pinctrl: max77620: Unify usage of space and comma in
    platform_device_id array

 drivers/pinctrl/cirrus/pinctrl-cs42l43.c  |  4 ++--
 drivers/pinctrl/intel/pinctrl-broxton.c   |  4 ++--
 drivers/pinctrl/intel/pinctrl-denverton.c |  2 +-
 drivers/pinctrl/pinctrl-max77620.c        |  6 +++---
 drivers/pinctrl/pinctrl-tps6594.c         |  4 ++--
 drivers/pinctrl/renesas/core.c            | 24 +++++++++++------------
 6 files changed, 22 insertions(+), 22 deletions(-)


base-commit: e7e28506af98ce4e1059e5ec59334b335c00a246
-- 
2.47.3


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2026-05-29 20:48 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-05-27 15:42 [PATCH v1 0/2] pinctrl: Use named initializers for platform_device_id arrays Uwe Kleine-König (The Capable Hub)
2026-05-27 15:43 ` [PATCH v1 1/2] " Uwe Kleine-König (The Capable Hub)
2026-05-27 15:51   ` Geert Uytterhoeven
2026-05-28  9:45   ` Mika Westerberg
2026-05-27 15:43 ` [PATCH v1 2/2] pinctrl: max77620: Unify usage of space and comma in platform_device_id array Uwe Kleine-König (The Capable Hub)
2026-05-29 20:48 ` [PATCH v1 0/2] pinctrl: Use named initializers for platform_device_id arrays Linus Walleij

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®