From: Dmitry Torokhov <dmitry.torokhov@gmail.com>
To: Jean Delvare <khali@linux-fr.org>
Cc: Russell King <rmk+lkml@arm.linux.org.uk>,
Greg KH <greg@kroah.com>, LKML <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] Minor change to platform_device_register_simple prototype
Date: Thu, 8 Dec 2005 16:06:36 -0500 [thread overview]
Message-ID: <d120d5000512081306t101c959cnf6b91f3fc417fbd6@mail.gmail.com> (raw)
In-Reply-To: <20051208215815.3d001dab.khali@linux-fr.org>
On 12/8/05, Jean Delvare <khali@linux-fr.org> wrote:
> Hi Russell,
>
> > On Wed, Dec 07, 2005 at 03:06:15PM -0800, Greg KH wrote:
> > > Ok, that's fine with me. Russell, any objections?
> >
> > None what so ever - that's mostly what I envisioned with the patch
> > with the _del method. However, I didn't have an existing user for it.
>
> Do you mean you have the code already? If it is so, could you please
> provide a patch Dmitry and I can give a try to?
>
I have the patch (my version anyway), I will send it out tonight.
> If not, I am willing to give it a try, if you provide some guidance. I
> think I understand that platform_device_del would be the first half of
> platform_device_unregister, but do we then want to rebuild
> platform_device_unregister on top of platform_device_del so as to avoid
> code duplication, or not?
>
Yes, _unregister is changed to be smply call to _del + _put.
--
Dmitry
next prev parent reply other threads:[~2005-12-08 21:06 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2005-12-05 20:23 Jean Delvare
2005-12-05 20:27 ` Russell King
2005-12-07 6:05 ` Dmitry Torokhov
2005-12-07 17:04 ` Greg KH
2005-12-08 21:21 ` Dmitry Torokhov
2005-12-08 21:37 ` Jean Delvare
2005-12-08 21:49 ` Dmitry Torokhov
2005-12-08 23:26 ` Russell King
2005-12-07 17:59 ` Dmitry Torokhov
2005-12-07 18:08 ` Russell King
2005-12-07 18:23 ` Dmitry Torokhov
2005-12-07 19:03 ` Russell King
2005-12-07 22:18 ` Dmitry Torokhov
2005-12-07 22:51 ` Greg KH
2005-12-07 22:59 ` Dmitry Torokhov
2005-12-07 23:06 ` Greg KH
2005-12-07 23:21 ` Russell King
2005-12-08 20:58 ` Jean Delvare
2005-12-08 21:06 ` Dmitry Torokhov [this message]
2005-12-08 23:17 ` Russell King
2005-12-08 20:52 ` Jean Delvare
2005-12-08 23:22 ` Russell King
2005-12-10 15:49 ` Jean Delvare
2005-12-11 19:44 ` Jean Delvare
2005-12-12 2:08 ` Dmitry Torokhov
2005-12-07 18:11 ` Dmitry Torokhov
2005-12-07 18:39 ` Randy.Dunlap
2005-12-07 19:05 ` Russell King
2005-12-07 6:50 ` Jean Delvare
2005-12-07 9:24 ` Russell King
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d120d5000512081306t101c959cnf6b91f3fc417fbd6@mail.gmail.com \
--to=dmitry.torokhov@gmail.com \
--cc=dtor_core@ameritech.net \
--cc=greg@kroah.com \
--cc=khali@linux-fr.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rmk+lkml@arm.linux.org.uk \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®