From: Jie Gan <quic_jiegan@quicinc.com>
To: James Clark <james.clark@linaro.org>
Cc: Tingwei Zhang <quic_tingweiz@quicinc.com>,
Jinlong Mao <quic_jinlmao@quicinc.com>,
<coresight@lists.linaro.org>,
<linux-arm-kernel@lists.infradead.org>,
<linux-kernel@vger.kernel.org>, <devicetree@vger.kernel.org>,
<linux-arm-msm@vger.kernel.org>,
<linux-stm32@st-md-mailman.stormreply.com>,
Suzuki K Poulose <suzuki.poulose@arm.com>,
Mike Leach <mike.leach@linaro.org>,
"Alexander Shishkin" <alexander.shishkin@linux.intel.com>,
Maxime Coquelin <mcoquelin.stm32@gmail.com>,
Alexandre Torgue <alexandre.torgue@foss.st.com>,
Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Bjorn Andersson <andersson@kernel.org>,
Konrad Dybcio <konradybcio@kernel.org>
Subject: Re: [PATCH v9 3/6] Coresight: Introduce a new struct coresight_path
Date: Wed, 29 Jan 2025 08:57:12 +0800 [thread overview]
Message-ID: <d5332d6d-237f-4b78-9eaf-2619bd97b7bd@quicinc.com> (raw)
In-Reply-To: <538ae543-4c43-4df2-8adc-911096fe14dd@linaro.org>
On 1/28/2025 7:54 PM, James Clark wrote:
>
>
> On 24/01/2025 7:25 am, Jie Gan wrote:
>> Add 'struct coresight_path' to store the data that is needed by
>> coresight_enable_path/coresight_disable_path. The structure
>> will be transmitted to the helper and sink device to enable
>> related funcationalities.
>>
>> Signed-off-by: Jie Gan <quic_jiegan@quicinc.com>
>> ---
>> drivers/hwtracing/coresight/coresight-core.c | 87 ++++++++++++++-----
>> drivers/hwtracing/coresight/coresight-etb10.c | 3 +-
>> .../hwtracing/coresight/coresight-etm-perf.c | 52 ++++++-----
>> .../hwtracing/coresight/coresight-etm-perf.h | 2 +-
>> drivers/hwtracing/coresight/coresight-priv.h | 21 +++--
>> drivers/hwtracing/coresight/coresight-sysfs.c | 32 +++----
>> .../hwtracing/coresight/coresight-tmc-etf.c | 3 +-
>> .../hwtracing/coresight/coresight-tmc-etr.c | 6 +-
>> drivers/hwtracing/coresight/coresight-trbe.c | 4 +-
>> drivers/hwtracing/coresight/ultrasoc-smb.c | 3 +-
>> 10 files changed, 137 insertions(+), 76 deletions(-)
>>
>
> [...]
>
>
>> INIT_LIST_HEAD(path);
>> + cs_path->path = path;
>> + /*
>> + * Since not all source devices have a defined trace_id function,
>> + * make sure to check for it before use.
>> + *
>> + * Assert the mode is CS_MODE_SYSFS, the trace_id will be assigned
>> + * again later if the mode is CS_MODE_PERF.
>> + */
>> + if (source_ops(source)->trace_id != NULL) {
>> + rc = source_ops(source)->trace_id(source, CS_MODE_SYSFS, NULL);
>
> I don't think we should do this. Doesn't this consume two trace IDs for
> each session? And I'm not even sure if it's released properly if it's
> overwritten.
Yes, you are right, we may waste our trace ID here.
>
> It should be possible to consolidate the all the trace ID allocation to
> a single step when building the path, or another function that gets
> called just after the path is built. At the moment the ID can be
> allocated from about 5 different places and it's quite hard to
> understand, especially with these new changes. I have some of it coded
> up, let me finish it off and I can share it.
Waiting for your update. I am also looking forward to another solution.
>
>> + if(IS_VALID_CS_TRACE_ID(rc))
>> + cs_path->trace_id = rc;
>> + else
>> + cs_path->trace_id = 0;
>> + }
>> + else
>> + cs_path->trace_id = 0;
>
> [...]
>
>> +/**
>> + * struct coresight_path - data needed by enable/disable path
>> + * @handle: perf aux handle for ETM.
>> + * @path: path from source to sink.
>> + * @trace_id: trace_id of the whole path.
>> + */
>> +struct coresight_path {
>> + struct perf_output_handle *handle;
>
> This is only needed to avoid adding *handle to the enable function call
> signature, but having it here implies it needs to be stored. And then we
> need to manage the lifecycle of it by nulling it on deletion. All of
> this can be avoided by just adding handle to enable().
>
> Unrelated to this patch, but I'm not sure why we were passing around
> void* for handle either. It just makes the code hard to read and implies
> some flexibility that doesn't exist. It's always "struct
> perf_output_handle", so we can change void* to that in the enable
> functions. I also have a patch for this that I'll share in a bit.
>
Thanks for support. I am totally agree with you. It's not related to the
patch series and it looks like a hack here.
Waiting for your update.
>> + struct list_head *path;
>> + u8 trace_id;
>> +};
>> +
>> static inline void coresight_insert_barrier_packet(void *buf)
>> {
>> if (buf)
>> @@ -132,16 +144,15 @@ static inline void CS_UNLOCK(void __iomem *addr)
>> } while (0);
>> }
>> -void coresight_disable_path(struct list_head *path);
>> -int coresight_enable_path(struct list_head *path, enum cs_mode mode,
>> - void *sink_data);
>> +void coresight_disable_path(struct coresight_path *cs_path);
>> +int coresight_enable_path(struct coresight_path *cs_path, enum
>> cs_mode mode);
>> struct coresight_device *coresight_get_sink(struct list_head *path);
>
> This needs to be exported otherwise the build fails because you use it
> in a module in another commit. I assume you are building as static?
>
>
Yes, you are right. I made a mistake here. I did not test it with build
as module. Sorry about the mistake.
Thanks,
Jie
next prev parent reply other threads:[~2025-01-29 0:57 UTC|newest]
Thread overview: 24+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-01-24 7:25 [PATCH v9 0/6] Coresight: Add Coresight TMC Control Unit driver Jie Gan
2025-01-24 7:25 ` [PATCH v9 1/6] Coresight: Add support for new APB clock name Jie Gan
2025-01-24 7:25 ` [PATCH v9 2/6] Coresight: Add trace_id function to retrieving the trace ID Jie Gan
2025-01-24 7:25 ` [PATCH v9 3/6] Coresight: Introduce a new struct coresight_path Jie Gan
2025-01-28 11:54 ` James Clark
2025-01-29 0:57 ` Jie Gan [this message]
2025-01-31 16:36 ` [PATCH 0/3] coresight: Alloc trace ID after building the path James Clark
2025-01-31 16:36 ` [PATCH 1/3] coresight: Don't save handle in path James Clark
2025-02-06 3:02 ` Jie Gan
2025-02-06 14:34 ` James Clark
2025-01-31 16:36 ` [PATCH 2/3] coresight: Export coresight_get_sink() James Clark
2025-01-31 16:36 ` [PATCH 3/3] coresight: Alloc trace ID after building the path James Clark
2025-02-05 4:13 ` [PATCH 0/3] " Jie Gan
2025-02-05 7:44 ` Jie Gan
2025-01-31 16:43 ` [PATCH v9 3/6] Coresight: Introduce a new struct coresight_path James Clark
2025-02-05 4:09 ` Jie Gan
2025-01-24 7:25 ` [PATCH v9 4/6] dt-bindings: arm: Add Coresight TMC Control Unit hardware Jie Gan
2025-01-24 7:25 ` [PATCH v9 5/6] Coresight: Add Coresight TMC Control Unit driver Jie Gan
2025-01-28 11:55 ` James Clark
2025-01-29 0:46 ` Jie Gan
2025-01-29 10:35 ` James Clark
2025-01-29 13:02 ` Jie Gan
2025-01-29 14:07 ` James Clark
2025-01-24 7:25 ` [PATCH v9 6/6] arm64: dts: qcom: sa8775p: Add CTCU and ETR nodes Jie Gan
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d5332d6d-237f-4b78-9eaf-2619bd97b7bd@quicinc.com \
--to=quic_jiegan@quicinc.com \
--cc=alexander.shishkin@linux.intel.com \
--cc=alexandre.torgue@foss.st.com \
--cc=andersson@kernel.org \
--cc=conor+dt@kernel.org \
--cc=coresight@lists.linaro.org \
--cc=devicetree@vger.kernel.org \
--cc=james.clark@linaro.org \
--cc=konradybcio@kernel.org \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-stm32@st-md-mailman.stormreply.com \
--cc=mcoquelin.stm32@gmail.com \
--cc=mike.leach@linaro.org \
--cc=quic_jinlmao@quicinc.com \
--cc=quic_tingweiz@quicinc.com \
--cc=robh@kernel.org \
--cc=suzuki.poulose@arm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®