mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v3] dmaengine: altera-msgdma: Fixed some inconsistent function name descriptions
@ 2022-07-06  8:26 Jiapeng Chong
  2022-07-06  8:28 ` Stefan Roese
  2022-07-06 16:30 ` Vinod Koul
  0 siblings, 2 replies; 3+ messages in thread
From: Jiapeng Chong @ 2022-07-06  8:26 UTC (permalink / raw)
  To: olivierdautricourt; +Cc: sr, vkoul, dmaengine, linux-kernel, Jiapeng Chong

Inconsistent function names describing msgdma_chan_remove() and
msgdma_dma_remove are modified to msgdma_dev_remove() and msgdma_remove().

Remove some warnings found by running scripts/kernel-doc, which is caused
by using 'make W=1'.

drivers/dma/altera-msgdma.c:927: warning: expecting prototype for msgdma_dma_remove(). Prototype was for msgdma_remove() instead.
drivers/dma/altera-msgdma.c:758: warning: expecting prototype for msgdma_chan_remove(). Prototype was for msgdma_dev_remove() instead.

Signed-off-by: Jiapeng Chong <jiapeng.chong@linux.alibaba.com>
---
Changes in v3:
  -Modified the commit title and message.

 drivers/dma/altera-msgdma.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/dma/altera-msgdma.c b/drivers/dma/altera-msgdma.c
index 6f56dfd375e3..4153c2edb049 100644
--- a/drivers/dma/altera-msgdma.c
+++ b/drivers/dma/altera-msgdma.c
@@ -749,7 +749,7 @@ static irqreturn_t msgdma_irq_handler(int irq, void *data)
 }
 
 /**
- * msgdma_chan_remove - Channel remove function
+ * msgdma_dev_remove() - Device remove function
  * @mdev: Pointer to the Altera mSGDMA device structure
  */
 static void msgdma_dev_remove(struct msgdma_device *mdev)
@@ -918,7 +918,7 @@ static int msgdma_probe(struct platform_device *pdev)
 }
 
 /**
- * msgdma_dma_remove - Driver remove function
+ * msgdma_remove() - Driver remove function
  * @pdev: Pointer to the platform_device structure
  *
  * Return: Always '0'
-- 
2.20.1.7.g153144c


^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v3] dmaengine: altera-msgdma: Fixed some inconsistent function name descriptions
  2022-07-06  8:26 [PATCH v3] dmaengine: altera-msgdma: Fixed some inconsistent function name descriptions Jiapeng Chong
@ 2022-07-06  8:28 ` Stefan Roese
  2022-07-06 16:30 ` Vinod Koul
  1 sibling, 0 replies; 3+ messages in thread
From: Stefan Roese @ 2022-07-06  8:28 UTC (permalink / raw)
  To: Jiapeng Chong, olivierdautricourt; +Cc: vkoul, dmaengine, linux-kernel

On 06.07.22 10:26, Jiapeng Chong wrote:
> Inconsistent function names describing msgdma_chan_remove() and
> msgdma_dma_remove are modified to msgdma_dev_remove() and msgdma_remove().
> 
> Remove some warnings found by running scripts/kernel-doc, which is caused
> by using 'make W=1'.
> 
> drivers/dma/altera-msgdma.c:927: warning: expecting prototype for msgdma_dma_remove(). Prototype was for msgdma_remove() instead.
> drivers/dma/altera-msgdma.c:758: warning: expecting prototype for msgdma_chan_remove(). Prototype was for msgdma_dev_remove() instead.
> 
> Signed-off-by: Jiapeng Chong <jiapeng.chong@linux.alibaba.com>

Reviewed-by: Stefan Roese <sr@denx.de>

Thanks,
Stefan

> ---
> Changes in v3:
>    -Modified the commit title and message.
> 
>   drivers/dma/altera-msgdma.c | 4 ++--
>   1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/dma/altera-msgdma.c b/drivers/dma/altera-msgdma.c
> index 6f56dfd375e3..4153c2edb049 100644
> --- a/drivers/dma/altera-msgdma.c
> +++ b/drivers/dma/altera-msgdma.c
> @@ -749,7 +749,7 @@ static irqreturn_t msgdma_irq_handler(int irq, void *data)
>   }
>   
>   /**
> - * msgdma_chan_remove - Channel remove function
> + * msgdma_dev_remove() - Device remove function
>    * @mdev: Pointer to the Altera mSGDMA device structure
>    */
>   static void msgdma_dev_remove(struct msgdma_device *mdev)
> @@ -918,7 +918,7 @@ static int msgdma_probe(struct platform_device *pdev)
>   }
>   
>   /**
> - * msgdma_dma_remove - Driver remove function
> + * msgdma_remove() - Driver remove function
>    * @pdev: Pointer to the platform_device structure
>    *
>    * Return: Always '0'

Viele Grüße,
Stefan Roese

-- 
DENX Software Engineering GmbH,      Managing Director: Wolfgang Denk
HRB 165235 Munich, Office: Kirchenstr.5, D-82194 Groebenzell, Germany
Phone: (+49)-8142-66989-51 Fax: (+49)-8142-66989-80 Email: sr@denx.de

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH v3] dmaengine: altera-msgdma: Fixed some inconsistent function name descriptions
  2022-07-06  8:26 [PATCH v3] dmaengine: altera-msgdma: Fixed some inconsistent function name descriptions Jiapeng Chong
  2022-07-06  8:28 ` Stefan Roese
@ 2022-07-06 16:30 ` Vinod Koul
  1 sibling, 0 replies; 3+ messages in thread
From: Vinod Koul @ 2022-07-06 16:30 UTC (permalink / raw)
  To: Jiapeng Chong; +Cc: olivierdautricourt, sr, dmaengine, linux-kernel

On 06-07-22, 16:26, Jiapeng Chong wrote:
> Inconsistent function names describing msgdma_chan_remove() and
> msgdma_dma_remove are modified to msgdma_dev_remove() and msgdma_remove().
> 
> Remove some warnings found by running scripts/kernel-doc, which is caused
> by using 'make W=1'.
> 
> drivers/dma/altera-msgdma.c:927: warning: expecting prototype for msgdma_dma_remove(). Prototype was for msgdma_remove() instead.
> drivers/dma/altera-msgdma.c:758: warning: expecting prototype for msgdma_chan_remove(). Prototype was for msgdma_dev_remove() instead.

Applied, thanks

-- 
~Vinod

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2022-07-06 16:30 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2022-07-06  8:26 [PATCH v3] dmaengine: altera-msgdma: Fixed some inconsistent function name descriptions Jiapeng Chong
2022-07-06  8:28 ` Stefan Roese
2022-07-06 16:30 ` Vinod Koul

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®