mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Alexandre Torgue <alexandre.torgue@st.com>
To: Benjamin Gaignard <benjamin.gaignard@linaro.org>,
	<robh+dt@kernel.org>, <mark.rutland@arm.com>,
	<linux@armlinux.org.uk>, <mcoquelin.stm32@gmail.com>,
	<daniel.lezcano@linaro.org>, <tglx@linutronix.de>,
	<ludovic.barre@st.com>, <julien.thierry@arm.com>,
	<sudeep.holla@arm.com>, <arnd@arndb.de>
Cc: <devicetree@vger.kernel.org>,
	<linux-arm-kernel@lists.infradead.org>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v8 0/6] stm32 clocksource driver rework
Date: Tue, 5 Dec 2017 11:12:09 +0100	[thread overview]
Message-ID: <dcff2fd0-58ca-51bb-ea2d-dfd1c5ca0cc3@st.com> (raw)
In-Reply-To: <1510649563-22975-1-git-send-email-benjamin.gaignard@linaro.org>

Hi

On 11/14/2017 09:52 AM, Benjamin Gaignard wrote:
> version 8:
>   - rebased on timers/core
>   - change timer_of_exit() name to timer_of_cleanup()
>   - update stm32 clocksource driver to use this function
> 
> version 7:
>   - reword "clocksource: stm32: only use 32 bits timers" commit message
>     to give more details about why 16 bits are problematics.
> 
> version 6:
>   - add dedicated patch min delta change
>   - rework commit messages, I hope it will be better now
>   - change new function name from timer_of_deinit to timer_of_exit
>   - make stm32_clock_event_set_next_event() safer like done in other
>     drivers
> 
> version 6:
> - add timer_of_deinit function in core
> - rework failure cases in probe function
> 
> version 5:
> - rebase on top of timer/core branch
> - rework commit message of the first patch
> 
> version 4:
> - split patch in 3 parts
>    - convert code to timer_of
>    - only use 32 bits timers
>    - add clocksource support
> 
> version 3:
> - fix comments done by Daniel
> - use timer_of helper functions
> 
> version 2:
> - fix uninitialized variable
> 
> Benjamin Gaignard (6):
>    clocksource: timer_of: rename timer_of_exit to timer_of_cleanup
>    clocksource: stm32: convert driver to timer_of
>    clocksource: stm32: increase min delta value
>    clocksource: stm32: only use 32 bits timers
>    clocksource: stm32: add clocksource support
>    arm: dts: stm32: remove useless clocksource nodes
> 
>   arch/arm/boot/dts/stm32f429.dtsi  |  32 -----
>   arch/arm/boot/dts/stm32f746.dtsi  |  32 -----
>   drivers/clocksource/Kconfig       |   1 +
>   drivers/clocksource/timer-of.c    |   9 +-
>   drivers/clocksource/timer-of.h    |   2 +-
>   drivers/clocksource/timer-stm32.c | 242 ++++++++++++++++++++------------------
>   6 files changed, 138 insertions(+), 180 deletions(-)
> 

What is the status of this patch-set ? Is there a chance to have it for 
v4.16 ?

Thanks
Alex

  parent reply	other threads:[~2017-12-05 10:13 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-11-14  8:52 Benjamin Gaignard
2017-11-14  8:52 ` [PATCH v8 1/6] clocksource: timer_of: rename timer_of_exit to timer_of_cleanup Benjamin Gaignard
2017-11-14 10:24   ` [tip:timers/urgent] clocksource/timer_of: Rename " tip-bot for Benjamin Gaignard
2017-11-14  8:52 ` [PATCH v8 2/6] clocksource: stm32: convert driver to timer_of Benjamin Gaignard
2017-11-14  8:52 ` [PATCH v8 3/6] clocksource: stm32: increase min delta value Benjamin Gaignard
2017-12-08  9:28   ` Daniel Lezcano
2017-11-14  8:52 ` [PATCH v8 4/6] clocksource: stm32: only use 32 bits timers Benjamin Gaignard
2017-12-07 15:27   ` Daniel Lezcano
2017-12-07 16:33     ` Benjamin Gaignard
2017-12-07 16:49       ` Daniel Lezcano
2017-12-07 20:36         ` Benjamin Gaignard
2017-12-08  7:52           ` Daniel Lezcano
2017-12-08  8:34   ` Daniel Lezcano
2017-12-08  9:25     ` Benjamin Gaignard
2017-12-08  9:29       ` Daniel Lezcano
2017-12-08  9:31         ` Benjamin Gaignard
2017-11-14  8:52 ` [PATCH v8 5/6] clocksource: stm32: add clocksource support Benjamin Gaignard
2017-11-14  8:52 ` [PATCH v8 6/6] arm: dts: stm32: remove useless clocksource nodes Benjamin Gaignard
2017-11-27 10:44 ` [PATCH v8 0/6] stm32 clocksource driver rework Benjamin Gaignard
2017-12-05 10:12 ` Alexandre Torgue [this message]
2017-12-05 10:15   ` Daniel Lezcano
2017-12-05 10:16     ` Alexandre Torgue

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=dcff2fd0-58ca-51bb-ea2d-dfd1c5ca0cc3@st.com \
    --to=alexandre.torgue@st.com \
    --cc=arnd@arndb.de \
    --cc=benjamin.gaignard@linaro.org \
    --cc=daniel.lezcano@linaro.org \
    --cc=devicetree@vger.kernel.org \
    --cc=julien.thierry@arm.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@armlinux.org.uk \
    --cc=ludovic.barre@st.com \
    --cc=mark.rutland@arm.com \
    --cc=mcoquelin.stm32@gmail.com \
    --cc=robh+dt@kernel.org \
    --cc=sudeep.holla@arm.com \
    --cc=tglx@linutronix.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome