From: tip-bot for Benjamin Gaignard <tipbot@zytor.com>
To: linux-tip-commits@vger.kernel.org
Cc: linux-kernel@vger.kernel.org, mingo@kernel.org, hpa@zytor.com,
tglx@linutronix.de, benjamin.gaignard@linaro.org
Subject: [tip:timers/urgent] clocksource/timer_of: Rename timer_of_exit to timer_of_cleanup
Date: Tue, 14 Nov 2017 02:24:41 -0800 [thread overview]
Message-ID: <tip-558de28249508dc3ec0ec8981d1315eb8b63f0d9@git.kernel.org> (raw)
In-Reply-To: <1510649563-22975-2-git-send-email-benjamin.gaignard@linaro.org>
Commit-ID: 558de28249508dc3ec0ec8981d1315eb8b63f0d9
Gitweb: https://git.kernel.org/tip/558de28249508dc3ec0ec8981d1315eb8b63f0d9
Author: Benjamin Gaignard <benjamin.gaignard@linaro.org>
AuthorDate: Tue, 14 Nov 2017 09:52:38 +0100
Committer: Thomas Gleixner <tglx@linutronix.de>
CommitDate: Tue, 14 Nov 2017 11:20:24 +0100
clocksource/timer_of: Rename timer_of_exit to timer_of_cleanup
Change the function name to something more explicit since it is only used
in init error cases.
Add __init annotation and description about the function usage.
Signed-off-by: Benjamin Gaignard <benjamin.gaignard@linaro.org>
Signed-off-by: Thomas Gleixner <tglx@linutronix.de>
Cc: mark.rutland@arm.com
Cc: devicetree@vger.kernel.org
Cc: alexandre.torgue@st.com
Cc: arnd@arndb.de
Cc: julien.thierry@arm.com
Cc: daniel.lezcano@linaro.org
Cc: linux@armlinux.org.uk
Cc: robh+dt@kernel.org
Cc: linux-arm-kernel@lists.infradead.org
Cc: mcoquelin.stm32@gmail.com
Cc: sudeep.holla@arm.com
Cc: ludovic.barre@st.com
Link: https://lkml.kernel.org/r/1510649563-22975-2-git-send-email-benjamin.gaignard@linaro.org
---
drivers/clocksource/timer-of.c | 9 ++++++++-
drivers/clocksource/timer-of.h | 2 +-
2 files changed, 9 insertions(+), 2 deletions(-)
diff --git a/drivers/clocksource/timer-of.c b/drivers/clocksource/timer-of.c
index 7c64a5c1..a319904 100644
--- a/drivers/clocksource/timer-of.c
+++ b/drivers/clocksource/timer-of.c
@@ -177,7 +177,14 @@ out_fail:
return ret;
}
-void timer_of_exit(struct timer_of *to)
+/**
+ * timer_of_cleanup - release timer_of ressources
+ * @to: timer_of structure
+ *
+ * Release the ressources that has been used in timer_of_init().
+ * This function should be called in init error cases
+ */
+void __init timer_of_cleanup(struct timer_of *to)
{
if (to->flags & TIMER_OF_IRQ)
timer_irq_exit(&to->of_irq);
diff --git a/drivers/clocksource/timer-of.h b/drivers/clocksource/timer-of.h
index 43f5ba3..3f708f1 100644
--- a/drivers/clocksource/timer-of.h
+++ b/drivers/clocksource/timer-of.h
@@ -68,6 +68,6 @@ static inline unsigned long timer_of_period(struct timer_of *to)
extern int __init timer_of_init(struct device_node *np,
struct timer_of *to);
-extern void timer_of_exit(struct timer_of *to);
+extern void __init timer_of_cleanup(struct timer_of *to);
#endif
next prev parent reply other threads:[~2017-11-14 10:26 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-11-14 8:52 [PATCH v8 0/6] stm32 clocksource driver rework Benjamin Gaignard
2017-11-14 8:52 ` [PATCH v8 1/6] clocksource: timer_of: rename timer_of_exit to timer_of_cleanup Benjamin Gaignard
2017-11-14 10:24 ` tip-bot for Benjamin Gaignard [this message]
2017-11-14 8:52 ` [PATCH v8 2/6] clocksource: stm32: convert driver to timer_of Benjamin Gaignard
2017-11-14 8:52 ` [PATCH v8 3/6] clocksource: stm32: increase min delta value Benjamin Gaignard
2017-12-08 9:28 ` Daniel Lezcano
2017-11-14 8:52 ` [PATCH v8 4/6] clocksource: stm32: only use 32 bits timers Benjamin Gaignard
2017-12-07 15:27 ` Daniel Lezcano
2017-12-07 16:33 ` Benjamin Gaignard
2017-12-07 16:49 ` Daniel Lezcano
2017-12-07 20:36 ` Benjamin Gaignard
2017-12-08 7:52 ` Daniel Lezcano
2017-12-08 8:34 ` Daniel Lezcano
2017-12-08 9:25 ` Benjamin Gaignard
2017-12-08 9:29 ` Daniel Lezcano
2017-12-08 9:31 ` Benjamin Gaignard
2017-11-14 8:52 ` [PATCH v8 5/6] clocksource: stm32: add clocksource support Benjamin Gaignard
2017-11-14 8:52 ` [PATCH v8 6/6] arm: dts: stm32: remove useless clocksource nodes Benjamin Gaignard
2017-11-27 10:44 ` [PATCH v8 0/6] stm32 clocksource driver rework Benjamin Gaignard
2017-12-05 10:12 ` Alexandre Torgue
2017-12-05 10:15 ` Daniel Lezcano
2017-12-05 10:16 ` Alexandre Torgue
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=tip-558de28249508dc3ec0ec8981d1315eb8b63f0d9@git.kernel.org \
--to=tipbot@zytor.com \
--cc=benjamin.gaignard@linaro.org \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=mingo@kernel.org \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome