* [PATCH][next] drm/gud: Use size_add() in call to struct_size()
@ 2023-09-15 18:43 Gustavo A. R. Silva
2023-09-15 18:52 ` Kees Cook
2023-09-29 19:15 ` Kees Cook
0 siblings, 2 replies; 4+ messages in thread
From: Gustavo A. R. Silva @ 2023-09-15 18:43 UTC (permalink / raw)
To: Noralf Trønnes, David Airlie, Daniel Vetter, Peter Stuge
Cc: dri-devel, linux-kernel, Gustavo A. R. Silva, linux-hardening
If, for any reason, the open-coded arithmetic causes a wraparound, the
protection that `struct_size()` adds against potential integer overflows
is defeated. Fix this by hardening call to `struct_size()` with `size_add()`.
Fixes: 40e1a70b4aed ("drm: Add GUD USB Display driver")
Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
---
drivers/gpu/drm/gud/gud_pipe.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/gpu/drm/gud/gud_pipe.c b/drivers/gpu/drm/gud/gud_pipe.c
index d2f199ea3c11..a02f75be81f0 100644
--- a/drivers/gpu/drm/gud/gud_pipe.c
+++ b/drivers/gpu/drm/gud/gud_pipe.c
@@ -503,7 +503,7 @@ int gud_pipe_check(struct drm_simple_display_pipe *pipe,
return -ENOENT;
len = struct_size(req, properties,
- GUD_PROPERTIES_MAX_NUM + GUD_CONNECTOR_PROPERTIES_MAX_NUM);
+ size_add(GUD_PROPERTIES_MAX_NUM, GUD_CONNECTOR_PROPERTIES_MAX_NUM));
req = kzalloc(len, GFP_KERNEL);
if (!req)
return -ENOMEM;
--
2.34.1
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH][next] drm/gud: Use size_add() in call to struct_size()
2023-09-15 18:43 [PATCH][next] drm/gud: Use size_add() in call to struct_size() Gustavo A. R. Silva
@ 2023-09-15 18:52 ` Kees Cook
2023-09-15 18:56 ` Gustavo A. R. Silva
2023-09-29 19:15 ` Kees Cook
1 sibling, 1 reply; 4+ messages in thread
From: Kees Cook @ 2023-09-15 18:52 UTC (permalink / raw)
To: Gustavo A. R. Silva
Cc: Noralf Trønnes, David Airlie, Daniel Vetter, Peter Stuge,
dri-devel, linux-kernel, linux-hardening
On Fri, Sep 15, 2023 at 12:43:20PM -0600, Gustavo A. R. Silva wrote:
> If, for any reason, the open-coded arithmetic causes a wraparound, the
> protection that `struct_size()` adds against potential integer overflows
> is defeated. Fix this by hardening call to `struct_size()` with `size_add()`.
>
> Fixes: 40e1a70b4aed ("drm: Add GUD USB Display driver")
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
> ---
> drivers/gpu/drm/gud/gud_pipe.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/gpu/drm/gud/gud_pipe.c b/drivers/gpu/drm/gud/gud_pipe.c
> index d2f199ea3c11..a02f75be81f0 100644
> --- a/drivers/gpu/drm/gud/gud_pipe.c
> +++ b/drivers/gpu/drm/gud/gud_pipe.c
> @@ -503,7 +503,7 @@ int gud_pipe_check(struct drm_simple_display_pipe *pipe,
> return -ENOENT;
>
> len = struct_size(req, properties,
> - GUD_PROPERTIES_MAX_NUM + GUD_CONNECTOR_PROPERTIES_MAX_NUM);
> + size_add(GUD_PROPERTIES_MAX_NUM, GUD_CONNECTOR_PROPERTIES_MAX_NUM));
There are both constant expressions, so there's not too much value in
wrapping them with size_add(), but for maintaining a common coding style
for dealing with allocation sizes, I can be convinced of the change. :)
Reviewed-by: Kees Cook <keescook@chromium.org>
> req = kzalloc(len, GFP_KERNEL);
> if (!req)
> return -ENOMEM;
> --
> 2.34.1
>
--
Kees Cook
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH][next] drm/gud: Use size_add() in call to struct_size()
2023-09-15 18:52 ` Kees Cook
@ 2023-09-15 18:56 ` Gustavo A. R. Silva
0 siblings, 0 replies; 4+ messages in thread
From: Gustavo A. R. Silva @ 2023-09-15 18:56 UTC (permalink / raw)
To: Kees Cook, Gustavo A. R. Silva
Cc: Noralf Trønnes, David Airlie, Daniel Vetter, Peter Stuge,
dri-devel, linux-kernel, linux-hardening
On 9/15/23 12:52, Kees Cook wrote:
> On Fri, Sep 15, 2023 at 12:43:20PM -0600, Gustavo A. R. Silva wrote:
>> If, for any reason, the open-coded arithmetic causes a wraparound, the
>> protection that `struct_size()` adds against potential integer overflows
>> is defeated. Fix this by hardening call to `struct_size()` with `size_add()`.
>>
>> Fixes: 40e1a70b4aed ("drm: Add GUD USB Display driver")
>> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
>> ---
>> drivers/gpu/drm/gud/gud_pipe.c | 2 +-
>> 1 file changed, 1 insertion(+), 1 deletion(-)
>>
>> diff --git a/drivers/gpu/drm/gud/gud_pipe.c b/drivers/gpu/drm/gud/gud_pipe.c
>> index d2f199ea3c11..a02f75be81f0 100644
>> --- a/drivers/gpu/drm/gud/gud_pipe.c
>> +++ b/drivers/gpu/drm/gud/gud_pipe.c
>> @@ -503,7 +503,7 @@ int gud_pipe_check(struct drm_simple_display_pipe *pipe,
>> return -ENOENT;
>>
>> len = struct_size(req, properties,
>> - GUD_PROPERTIES_MAX_NUM + GUD_CONNECTOR_PROPERTIES_MAX_NUM);
>> + size_add(GUD_PROPERTIES_MAX_NUM, GUD_CONNECTOR_PROPERTIES_MAX_NUM));
>
> There are both constant expressions, so there's not too much value in
> wrapping them with size_add(), but for maintaining a common coding style
> for dealing with allocation sizes, I can be convinced of the change. :)
Yep; I've found a mix of constant expressions and variables doing open-coded arithmetic
in `struct_size()`, so I'm sending them all.
>
> Reviewed-by: Kees Cook <keescook@chromium.org>
Thanks!
--
Gustavo
>
>
>> req = kzalloc(len, GFP_KERNEL);
>> if (!req)
>> return -ENOMEM;
>> --
>> 2.34.1
>>
>
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH][next] drm/gud: Use size_add() in call to struct_size()
2023-09-15 18:43 [PATCH][next] drm/gud: Use size_add() in call to struct_size() Gustavo A. R. Silva
2023-09-15 18:52 ` Kees Cook
@ 2023-09-29 19:15 ` Kees Cook
1 sibling, 0 replies; 4+ messages in thread
From: Kees Cook @ 2023-09-29 19:15 UTC (permalink / raw)
To: Noralf Trønnes, David Airlie, Daniel Vetter, Peter Stuge,
Gustavo A. R. Silva
Cc: Kees Cook, dri-devel, linux-kernel, linux-hardening
On Fri, 15 Sep 2023 12:43:20 -0600, Gustavo A. R. Silva wrote:
> If, for any reason, the open-coded arithmetic causes a wraparound, the
> protection that `struct_size()` adds against potential integer overflows
> is defeated. Fix this by hardening call to `struct_size()` with `size_add()`.
>
>
Applied to for-next/hardening, thanks!
[1/1] drm/gud: Use size_add() in call to struct_size()
https://git.kernel.org/kees/c/836ccb46073e
Take care,
--
Kees Cook
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2023-09-29 19:15 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2023-09-15 18:43 [PATCH][next] drm/gud: Use size_add() in call to struct_size() Gustavo A. R. Silva
2023-09-15 18:52 ` Kees Cook
2023-09-15 18:56 ` Gustavo A. R. Silva
2023-09-29 19:15 ` Kees Cook
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®