From: Bart Van Assche <bart.vanassche@gmail.com>
To: Philipp Reisner <philipp.reisner@linbit.com>
Cc: linux-kernel@vger.kernel.org, Jens Axboe <jens.axboe@oracle.com>,
Greg KH <gregkh@suse.de>, Neil Brown <neilb@suse.de>,
James Bottomley <James.Bottomley@hansenpartnership.com>,
Andi Kleen <andi@firstfloor.org>, Sam Ravnborg <sam@ravnborg.org>,
Dave Jones <davej@redhat.com>,
Nikanth Karthikesan <knikanth@suse.de>,
Lars Marowsky-Bree <lmb@suse.de>,
"Nicholas A. Bellinger" <nab@linux-iscsi.org>,
Lars Ellenberg <lars.ellenberg@linbit.com>
Subject: Re: [PATCH 07/14] DRBD: internal_data_structures
Date: Sun, 12 Apr 2009 18:44:53 +0200 [thread overview]
Message-ID: <e2e108260904120944t1d0fec44yccbc50b6246988d0@mail.gmail.com> (raw)
In-Reply-To: <1239365545-10356-8-git-send-email-philipp.reisner@linbit.com>
On Fri, Apr 10, 2009 at 2:12 PM, Philipp Reisner
<philipp.reisner@linbit.com> wrote:
> diff -uNrp linux-2.6.30-rc1/drivers/block/drbd/drbd_int.h linux-2.6.30-rc1-drbd/drivers/block/drbd/drbd_int.h
...
> +#define PRINTK(level, fmt, args...) \
> + printk(level "drbd%d: " fmt, \
> + mdev->minor , ##args)
The above looks similar to dev_printk() from <linux/device.h>. It
would be great if some of the DRBD-specific macro's could be replaced
by existing Linux macro's. This would improve the readability of the
DRBD source code.
...
> +#define D_ASSERT(exp) if (!(exp)) \
> + ERR("ASSERT( " #exp " ) in %s:%d\n", __FILE__, __LINE__)
> +
> +#define ERR_IF(exp) if (({ \
> + int _b = (exp) != 0; \
> + if (_b) ERR("%s: (%s) in %s:%d\n", \
> + __func__, #exp, __FILE__, __LINE__); \
> + _b; \
> + }))
How about replacing invocations of D_ASSERT() and/or ERR_IF() by WARN_ON() ?
Bart.
next prev parent reply other threads:[~2009-04-12 16:45 UTC|newest]
Thread overview: 28+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-04-10 12:12 [PATCH 00/14] DRBD: a block device for HA clusters Philipp Reisner
2009-04-10 12:12 ` [PATCH 01/14] DRBD: major.h Philipp Reisner
2009-04-10 12:12 ` [PATCH 02/14] DRBD: lru_cache Philipp Reisner
2009-04-10 12:12 ` [PATCH 03/14] DRBD: activity_log Philipp Reisner
2009-04-10 12:12 ` [PATCH 04/14] DRBD: bitmap Philipp Reisner
2009-04-10 12:12 ` [PATCH 05/14] DRBD: request Philipp Reisner
2009-04-10 12:12 ` [PATCH 06/14] DRBD: userspace_interface Philipp Reisner
2009-04-10 12:12 ` [PATCH 07/14] DRBD: internal_data_structures Philipp Reisner
2009-04-10 12:12 ` [PATCH 08/14] DRBD: main Philipp Reisner
2009-04-10 12:12 ` [PATCH 09/14] DRBD: receiver Philipp Reisner
2009-04-10 12:12 ` [PATCH 10/14] DRBD: proc Philipp Reisner
2009-04-10 12:12 ` [PATCH 11/14] DRBD: worker Philipp Reisner
2009-04-10 12:12 ` [PATCH 12/14] DRBD: variable_length_integer_encoding Philipp Reisner
2009-04-10 12:12 ` [PATCH 13/14] DRBD: misc Philipp Reisner
2009-04-10 12:12 ` [PATCH 14/14] DRBD: final Philipp Reisner
2009-04-11 7:18 ` [PATCH 07/14] DRBD: internal_data_structures Bart Van Assche
2009-04-14 13:53 ` Philipp Reisner
2009-04-12 16:44 ` Bart Van Assche [this message]
2009-04-16 13:35 ` Philipp Reisner
2009-04-12 16:23 ` [PATCH 06/14] DRBD: userspace_interface Bart Van Assche
2009-04-17 13:24 ` Philipp Reisner
2009-04-14 2:33 ` Kyle Moffett
2009-04-22 10:31 ` Philipp Reisner
2009-04-16 7:06 ` [PATCH 05/14] DRBD: request Bart Van Assche
2009-04-16 15:32 ` Philipp Reisner
2009-04-10 12:24 ` [PATCH 02/14] DRBD: lru_cache Bart Van Assche
2009-04-14 11:54 ` Nikanth Karthikesan
2009-04-15 15:29 ` Philipp Reisner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e2e108260904120944t1d0fec44yccbc50b6246988d0@mail.gmail.com \
--to=bart.vanassche@gmail.com \
--cc=James.Bottomley@hansenpartnership.com \
--cc=andi@firstfloor.org \
--cc=davej@redhat.com \
--cc=gregkh@suse.de \
--cc=jens.axboe@oracle.com \
--cc=knikanth@suse.de \
--cc=lars.ellenberg@linbit.com \
--cc=linux-kernel@vger.kernel.org \
--cc=lmb@suse.de \
--cc=nab@linux-iscsi.org \
--cc=neilb@suse.de \
--cc=philipp.reisner@linbit.com \
--cc=sam@ravnborg.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®