mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Qi Zheng <zhengqi.arch@bytedance.com>
To: Josh Poimboeuf <jpoimboe@kernel.org>
Cc: peterz@infradead.org, keescook@chromium.org,
	dave.hansen@linux.intel.com, bp@alien8.de, mingo@redhat.com,
	tglx@linutronix.de, rostedt@goodmis.org, x86@kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/2] x86: make __get_wchan() use arch_stack_walk()
Date: Wed, 12 Apr 2023 15:10:59 +0800	[thread overview]
Message-ID: <e41a58eb-c950-acff-0880-a693515aa650@bytedance.com> (raw)
In-Reply-To: <20230412052037.nz75jeoeqibx6otr@treble>



On 2023/4/12 13:20, Josh Poimboeuf wrote:
> On Sun, Apr 09, 2023 at 02:30:23PM +0800, Qi Zheng wrote:
>>
>>
>> On 2023/4/9 06:12, Josh Poimboeuf wrote:
>>> On Sat, Apr 08, 2023 at 01:36:06PM +0800, Qi Zheng wrote:
>>>>
>>>>
>>>> On 2023/4/8 13:08, Josh Poimboeuf wrote:
>>>>> On Thu, Mar 30, 2023 at 04:15:52PM +0800, Qi Zheng wrote:
>>>>>> Make __get_wchan() use arch_stack_walk() directly to
>>>>>> avoid open-coding of unwind logic.
>>>>>>
>>>>>> Signed-off-by: Qi Zheng <zhengqi.arch@bytedance.com>
>>>>>
>>>>> Can we just have a shared version of __get_wchan() for all
>>>>> CONFIG_ARCH_STACKWALK arches?
>>>>
>>>>   From a quick glance, I think it's ok, but we still need to define
>>>> the arch's own get_wchan_cb(). I will try to do it.
>>>
>>> Hm, why would we need to do that?
>>
>> Because I see checks for count++ < 16 exist in __get_wchan() for some
>> arches and some don't. So I'm not sure if this check can be discarded
>> after using arch_stack_walk(). And I see that this check is retained in
>> arm64, see [1] for details.
>>
>> [1]. https://github.com/torvalds/linux/commit/4f62bb7cb165f3e7b0a91279fe9dd5c56daf3457
> 
> That difference seems to have nothing to do with individual arch
> differences.
> 
> The 16-check limit looks like some ancient cargo cult ritual which was
> copy-pasted decades ago, presumably to avoid some kind of infinite stack
> recursion loop in scheduler code, which should never happen.  That
> should definitely be removed.

Got it.

> 
> Another good reason to unify them, to get rid of cruft like that.

OK, will try to make a shared version of __get_wchan() for all
CONFIG_ARCH_STACKWALK arches.

Thanks,
Qi

> 


  reply	other threads:[~2023-04-12  7:12 UTC|newest]

Thread overview: 15+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-03-30  8:15 [PATCH 0/2] some fixes and cleanups for x86 Qi Zheng
2023-03-30  8:15 ` [PATCH 1/2] x86: make profile_pc() use arch_stack_walk() Qi Zheng
2023-04-08  4:56   ` Josh Poimboeuf
2023-04-08  5:26     ` Qi Zheng
2023-03-30  8:15 ` [PATCH 2/2] x86: make __get_wchan() " Qi Zheng
2023-04-08  5:08   ` Josh Poimboeuf
2023-04-08  5:36     ` Qi Zheng
2023-04-08 22:12       ` Josh Poimboeuf
2023-04-09  6:30         ` Qi Zheng
2023-04-12  5:20           ` Josh Poimboeuf
2023-04-12  7:10             ` Qi Zheng [this message]
2023-04-12 13:15     ` Peter Zijlstra
2023-04-12 13:23       ` Peter Zijlstra
2023-04-12 17:24         ` Qi Zheng
2023-04-07  3:47 ` [PATCH 0/2] some fixes and cleanups for x86 Qi Zheng

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e41a58eb-c950-acff-0880-a693515aa650@bytedance.com \
    --to=zhengqi.arch@bytedance.com \
    --cc=bp@alien8.de \
    --cc=dave.hansen@linux.intel.com \
    --cc=jpoimboe@kernel.org \
    --cc=keescook@chromium.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peterz@infradead.org \
    --cc=rostedt@goodmis.org \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®