mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Joe Perches <joe@perches.com>
To: Yury Norov <yury.norov@gmail.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Andrew Morton <akpm@linux-foundation.org>,
	Allison Randal <allison@lohutok.net>,
	William Breathitt Gray <vilhelm.gray@gmail.com>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 3/3] lib/find_bit.c: uninline helper _find_next_bit()
Date: Fri, 03 Jan 2020 13:46:07 -0800	[thread overview]
Message-ID: <e76bdf736141d5a390e57f2bc8f6f6f9fbe574c1.camel@perches.com> (raw)
In-Reply-To: <20200103202846.21616-3-yury.norov@gmail.com>

On Fri, 2020-01-03 at 12:28 -0800, Yury Norov wrote:
> It saves 25% of .text for arm64, and more for BE architectures.

This seems a rather misleading code size reduction description.

Please detail the specific code sizes using "size lib/find_bit.o"
before and after this change.

Also, _find_next_bit is used 3 times, perhaps any code size
increase is appropriate given likely reduced run time.

> Signed-off-by: Yury Norov <yury.norov@gmail.com>
> ---
>  lib/find_bit.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/lib/find_bit.c b/lib/find_bit.c
> index c03cbecb2b1f6..0e4b2b90c9c02 100644
> --- a/lib/find_bit.c
> +++ b/lib/find_bit.c
> @@ -27,7 +27,7 @@
>   *    searching it for one bits.
>   *  - The optional "addr2", which is anded with "addr1" if present.
>   */
> -static inline unsigned long _find_next_bit(const unsigned long *addr1,
> +static unsigned long _find_next_bit(const unsigned long *addr1,
>  		const unsigned long *addr2, unsigned long nbits,
>  		unsigned long start, unsigned long invert, unsigned long le)
>  {


  reply	other threads:[~2020-01-03 21:47 UTC|newest]

Thread overview: 6+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-03 20:28 [PATCH 1/3] uapi: rename ext2_swab() to swab() and share globally in swab.h Yury Norov
2020-01-03 20:28 ` [PATCH 2/3] lib/find_bit.c: join _find_next_bit{_le} Yury Norov
2020-01-03 20:28 ` [PATCH 3/3] lib/find_bit.c: uninline helper _find_next_bit() Yury Norov
2020-01-03 21:46   ` Joe Perches [this message]
2020-01-04  0:11     ` Yury Norov
2020-01-04  1:05       ` Yury Norov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e76bdf736141d5a390e57f2bc8f6f6f9fbe574c1.camel@perches.com \
    --to=joe@perches.com \
    --cc=akpm@linux-foundation.org \
    --cc=allison@lohutok.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=tglx@linutronix.de \
    --cc=vilhelm.gray@gmail.com \
    --cc=yury.norov@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®