From: yangxingui <yangxingui@huawei.com>
To: John Garry <john.g.garry@oracle.com>, <yanaijie@huawei.com>,
<jejb@linux.ibm.com>, <martin.petersen@oracle.com>
Cc: <linux-scsi@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<linuxarm@huawei.com>, <liyihang9@h-partners.com>,
<liuyonglong@huawei.com>, <kangfenglong@huawei.com>
Subject: Re: [PATCH v9 1/2] scsi: libsas: refactor sas_ex_to_ata() using new helper sas_ex_to_dev()
Date: Tue, 11 Aug 2026 11:02:50 +0800 [thread overview]
Message-ID: <e7980d39-09e6-19db-2514-d45a7448045a@huawei.com> (raw)
In-Reply-To: <11581a25-caa6-4ea3-9aa0-2a4dacb7f34e@oracle.com>
Hi John,
Thanks for the review.
On 2026/8/10 23:51, John Garry wrote:
> On 24/06/2026 07:32, Xingui Yang wrote:
>> Introduce sas_ex_to_dev() to return any device type attached to an
>> expander phy. The new helper is then used by sas_ex_to_ata() to reduce
>> code duplication.
>>
>> Also add a defensive NULL check for ex_dev to guard against callers
>> passing a NULL device.
>>
>
> Why would someone want to lookup a device attached to an expander device
> which is NULL? If this is possible later, then mention it.
No current caller passes a NULL ex_dev. The check was added in v7 based
on an automated Sashiko AI review suggestion, which may contain some
noise. Removed in v10.
>> Signed-off-by: Xingui Yang <yangxingui@huawei.com>
>> ---
>> drivers/scsi/libsas/sas_expander.c | 19 ++++++++++++++-----
>> drivers/scsi/libsas/sas_internal.h | 1 +
>> 2 files changed, 15 insertions(+), 5 deletions(-)
>>
>> diff --git a/drivers/scsi/libsas/sas_expander.c
>> b/drivers/scsi/libsas/sas_expander.c
>> index f471ab464a78..fc6d8f3c9dca 100644
>> --- a/drivers/scsi/libsas/sas_expander.c
>> +++ b/drivers/scsi/libsas/sas_expander.c
>> @@ -345,13 +345,16 @@ static void sas_set_ex_phy(struct domain_device
>> *dev, int phy_id,
>> SAS_ADDR(phy->attached_sas_addr), type);
>> }
>> -/* check if we have an existing attached ata device on this expander
>> phy */
>> -struct domain_device *sas_ex_to_ata(struct domain_device *ex_dev, int
>> phy_id)
>> +/* return the domain device attached to an expander phy */
>> +struct domain_device *sas_ex_to_dev(struct domain_device *ex_dev, int
>> phy_id)
>> {
>
> sas_ex_phy_to_dev() seems a better name, as sas_ex_to_dev() is quite
> vague. I know that it matches sas_ex_to_ata(), but it is not a good
> pattern to match.
Ok, Renamed to sas_ex_phy_to_dev() for consistency with
sas_ex_phy_discover() and other phy-related helpers.
Thanks.
Xingui
next prev parent reply other threads:[~2026-08-11 3:03 UTC|newest]
Thread overview: 7+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-24 6:32 [PATCH v9 0/2] libsas: rediscover improvements for linkrate/sas_addr changes Xingui Yang
2026-06-24 6:32 ` [PATCH v9 1/2] scsi: libsas: refactor sas_ex_to_ata() using new helper sas_ex_to_dev() Xingui Yang
2026-08-10 15:51 ` John Garry
2026-08-11 3:02 ` yangxingui [this message]
2026-06-24 6:32 ` [PATCH v9 2/2] scsi: libsas: Add linkrate and sas_addr change detection in rediscover Xingui Yang
2026-07-13 3:09 ` yangxingui
2026-08-07 8:35 ` [PATCH v9 0/2] libsas: rediscover improvements for linkrate/sas_addr changes yangxingui
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e7980d39-09e6-19db-2514-d45a7448045a@huawei.com \
--to=yangxingui@huawei.com \
--cc=jejb@linux.ibm.com \
--cc=john.g.garry@oracle.com \
--cc=kangfenglong@huawei.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-scsi@vger.kernel.org \
--cc=linuxarm@huawei.com \
--cc=liuyonglong@huawei.com \
--cc=liyihang9@h-partners.com \
--cc=martin.petersen@oracle.com \
--cc=yanaijie@huawei.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®