From: Stefan Agner <stefan@agner.ch>
To: Sanchayan Maity <maitysanchayan@gmail.com>
Cc: Peter.Chen@freescale.com, gregkh@linuxfoundation.org,
linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/3] usb: chipidea: Add chipidea revision information
Date: Wed, 24 Dec 2014 17:22:44 +0100 [thread overview]
Message-ID: <e7c92089fe1938c9f7f97bde12c6d8bc@agner.ch> (raw)
In-Reply-To: <1da552d2284380f8606bd16d1d3c0cf51caa60ff.1418981438.git.maitysanchayan@gmail.com>
On 2014-12-19 10:55, Sanchayan Maity wrote:
> Define ci_get_revision API to know the controller revision
> information according to chipidea 1.1a, 2.0a, 2.4 and 2.5a
> spec. Besides, add one entry in struct ci_hdrc to indicate
> revision information. This can be used for adding different
> code for revisions, implementing erratas.
>
> Signed-off-by: Sanchayan Maity <maitysanchayan@gmail.com>
> ---
> drivers/usb/chipidea/bits.h | 10 ++++++++++
> drivers/usb/chipidea/core.c | 23 +++++++++++++++++++++--
> 2 files changed, 31 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/usb/chipidea/bits.h b/drivers/usb/chipidea/bits.h
> index ca57e3d..e935ccc 100644
> --- a/drivers/usb/chipidea/bits.h
> +++ b/drivers/usb/chipidea/bits.h
> @@ -15,6 +15,16 @@
>
> #include <linux/usb/ehci_def.h>
>
> +/*
> + * ID
> + * For 1.x revision, bit24 - bit31 are reserved
> + * For 2.x revision, bit25 - bit28 are 0x2
> + */
> +#define TAG (0x1F << 16)
> +#define REVISION (0xF << 21)
> +#define VERSION (0xF << 25)
> +#define CIVERSION (0x7 << 29)
> +
Hm, the other defines use spaces in this file, I like tabs more too, but
I guess uniformity wins here.. Peter?
> /* HCCPARAMS */
> #define HCCPARAMS_LEN BIT(17)
>
> diff --git a/drivers/usb/chipidea/core.c b/drivers/usb/chipidea/core.c
> index 9bdc6bd..33a8c4a 100644
> --- a/drivers/usb/chipidea/core.c
> +++ b/drivers/usb/chipidea/core.c
> @@ -136,6 +136,22 @@ static int hw_alloc_regmap(struct ci_hdrc *ci, bool is_lpm)
> return 0;
> }
>
> +static enum CI_REVISION ci_get_revision(struct ci_hdrc *ci)
> +{
> + int ver = hw_read_id_reg(ci, ID_ID, VERSION) >> __ffs(VERSION);
> + enum CI_REVISION rev = CI_REVISION_UNKNOWN;
> +
> + if (ver == 0x2) {
> + int rev_reg = hw_read_id_reg
> + (ci, ID_ID, REVISION) >> __ffs(REVISION);
This line break is somewhat awkward, doesn't help for good readability.
Is the local integer variable necessary at all? Enums are arithmetic
types, so afaik this should be fine too:
rev = CI_REVISION_20;
rev += hw_read_id_reg(ci, ID_ID, REVISION) >> __ffs(REVISION);
> + rev = rev_reg + CI_REVISION_20;
> + } else if (ver == 0x0) {
> + rev = CI_REVISION_1X;
> + }
> +
> + return rev;
> +}
> +
> /**
> * hw_read_intr_enable: returns interrupt enable register
> *
> @@ -245,8 +261,11 @@ static int hw_device_init(struct ci_hdrc *ci,
> void __iomem *base)
> /* Clear all interrupts status bits*/
> hw_write(ci, OP_USBSTS, 0xffffffff, 0xffffffff);
>
> - dev_dbg(ci->dev, "ChipIdea HDRC found, lpm: %d; cap: %p op: %p\n",
> - ci->hw_bank.lpm, ci->hw_bank.cap, ci->hw_bank.op);
> + ci->rev = ci_get_revision(ci);
> +
> + dev_dbg(ci->dev,
> + "ChipIdea HDRC found, revision: %d, lpm: %d; cap: %p op: %p\n",
> + ci->rev, ci->hw_bank.lpm, ci->hw_bank.cap, ci->hw_bank.op);
>
> /* setup lock mode ? */
next prev parent reply other threads:[~2014-12-24 16:23 UTC|newest]
Thread overview: 20+ messages / expand[flat|nested] mbox.gz Atom feed top
2014-12-19 9:55 [PATCH 0/3] usb: chipidea: add one errata for revision 2.40a Sanchayan Maity
2014-12-19 9:55 ` [PATCH 1/3] usb: chipidea: Add identification registers access APIs Sanchayan Maity
2014-12-24 16:00 ` Stefan Agner
2014-12-24 16:15 ` Sanchayan Maity
2014-12-24 16:41 ` Stefan Agner
2014-12-25 2:13 ` Peter Chen
2014-12-25 3:33 ` Sanchayan Maity
2014-12-25 2:03 ` Peter Chen
2014-12-19 9:55 ` [PATCH 2/3] usb: chipidea: Add chipidea revision information Sanchayan Maity
2014-12-24 16:22 ` Stefan Agner [this message]
2014-12-25 2:30 ` Peter Chen
2014-12-19 9:55 ` [PATCH 3/3] usb: chipidea: Add errata for revision 2.40a Sanchayan Maity
2014-12-22 1:18 ` [PATCH 0/3] usb: chipidea: add one " Peter Chen
2014-12-22 13:09 ` Sanchayan Maity
2014-12-23 0:09 ` Peter Chen
2014-12-23 4:11 ` Sanchayan Maity
2014-12-24 7:50 ` Sanchayan Maity
2014-12-24 9:00 ` Peter Chen
2014-12-24 9:20 ` Sanchayan Maity
2014-12-24 15:42 ` Stefan Agner
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e7c92089fe1938c9f7f97bde12c6d8bc@agner.ch \
--to=stefan@agner.ch \
--cc=Peter.Chen@freescale.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=maitysanchayan@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®