mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: David Lechner <dlechner@baylibre.com>
To: Marcelo Schmitt <marcelo.schmitt1@gmail.com>
Cc: Marcelo Schmitt <marcelo.schmitt@analog.com>,
	linux-iio@vger.kernel.org, linux-kernel@vger.kernel.org,
	cosmin.tanislav@analog.com, jic23@kernel.org, lars@metafoo.de,
	granquet@baylibre.com, u.kleine-koenig@baylibre.com
Subject: Re: [PATCH v2 0/3] Re-add filter_type/filter_mode
Date: Tue, 7 Jan 2025 11:48:25 -0600	[thread overview]
Message-ID: <e7e9266f-082a-4bb4-931c-505c7ff20d47@baylibre.com> (raw)
In-Reply-To: <Z31n9C8FwgzV0hs0@debian-BULLSEYE-live-builder-AMD64>

On 1/7/25 11:44 AM, Marcelo Schmitt wrote:
> On 01/07, David Lechner wrote:
>> On 1/7/25 9:11 AM, Marcelo Schmitt wrote:
>>> Better document sysfs ABI for ADC digital filter configuration.
>>>
>>> Change log v1 -> v2
>>> - Split into 3 patches.
>>> - Re-added sysfs-bus-iio-adc-ad4130 to keep filter_mode separate from filter_type.
>>
>> If ad7779 is the only driver with filter_type{,available} attributes while
>> ad4130 and admv8818 both have filter_mode{,available} attributes, shouldn't we
>> be deprecating filter_type and promoting filter_mode?
> 
> Oh, I had only grepped the adc dir and I didn't noticed admv8818 also had
> filter_mode.
> Hmm, don't know, though still biased towards filter_type.
> 
> - The admv8818 filter_mode_available ABI exports different values (auto,
>   manual, bypass).

Ah, I didn't look that far, so yes, I agree this is a good reason to standardize
on filter_type instead.

> - AD7768-1, ADAQ7768-1, AD7768/AD7768-4, AD7124-4, and AD4170 datasheets
>   refer to sinc filters as filter types (though not all of those designs are
>   supported in IIO or have filter attributes).
> - The AD4130 datasheets also refers to the digital filter as filter type in
>   some occasions.
> 
> But some datasheets seem to use filter mode and filter type interchangeably
> so I don't know. The admv8818 use case is valid and is both low and high-pass
> filtering while the ADCs sinc digital filters act like low-pass filter.
> Maybe even provide a different name for ADC digital filtering?
> digital_filter_type (or digital_filter_mode)?.
> 
> Thanks for pointing that out.


      reply	other threads:[~2025-01-07 17:48 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-01-07 15:11 Marcelo Schmitt
2025-01-07 15:12 ` [PATCH v2 1/3] Documentation: ABI: IIO: Re-add sysfs-bus-iio-adc-ad4130 Marcelo Schmitt
2025-01-07 15:13 ` [PATCH v2 2/3] Documentation: ABI: IIO: Add filter_type documentation Marcelo Schmitt
2025-01-07 15:13 ` [PATCH v2 3/3] Documentation: ABI: IIO: Drop AD4130 specific filter_type_available options Marcelo Schmitt
2025-01-07 17:53   ` David Lechner
2025-01-12 11:56     ` Jonathan Cameron
2025-01-07 16:32 ` [PATCH v2 0/3] Re-add filter_type/filter_mode David Lechner
2025-01-07 17:44   ` Marcelo Schmitt
2025-01-07 17:48     ` David Lechner [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e7e9266f-082a-4bb4-931c-505c7ff20d47@baylibre.com \
    --to=dlechner@baylibre.com \
    --cc=cosmin.tanislav@analog.com \
    --cc=granquet@baylibre.com \
    --cc=jic23@kernel.org \
    --cc=lars@metafoo.de \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marcelo.schmitt1@gmail.com \
    --cc=marcelo.schmitt@analog.com \
    --cc=u.kleine-koenig@baylibre.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®