mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Huang, Kai" <kai.huang@intel.com>
To: "dave.hansen@linux.intel.com" <dave.hansen@linux.intel.com>,
	"bp@alien8.de" <bp@alien8.de>, "x86@kernel.org" <x86@kernel.org>,
	"mingo@redhat.com" <mingo@redhat.com>,
	"Williams, Dan J" <dan.j.williams@intel.com>,
	"kirill.shutemov@linux.intel.com"
	<kirill.shutemov@linux.intel.com>,
	"Xing, Cedric" <cedric.xing@intel.com>,
	"tglx@linutronix.de" <tglx@linutronix.de>,
	"hpa@zytor.com" <hpa@zytor.com>
Cc: "linux-coco@lists.linux.dev" <linux-coco@lists.linux.dev>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 1/4] tsm: Add TVM Measurement Register support
Date: Mon, 17 Feb 2025 10:44:49 +0000	[thread overview]
Message-ID: <e9a0953921530a6ec058b8236e45d2f4217d9c0e.camel@intel.com> (raw)
In-Reply-To: <828df2dd-a099-4146-96fe-0915cfa2e4b5@intel.com>

On Mon, 2025-02-17 at 13:17 +1300, Huang, Kai wrote:
> Hi Cedric,
> 
> [...]
> 
> > +static ssize_t tmr_digest_read(struct file *filp, struct kobject *kobj, struct bin_attribute *attr,
> > +			       char *page, loff_t off, size_t count)
> 
> Better to rename 'page' to 'buffer'?
> 
> Since page normally implies 4KB alignment but I don't see we need the 
> alignment here.
> 
> > +{
> > +	const struct tsm_measurement_register *mr;
> > +	struct tmr_provider *pvd;
> > +	int rc;
> > +
> > +	if (off < 0 || off > attr->size)
> > +		return -EINVAL;
> > +
> > +	count = min(count, attr->size - (size_t)off);
> > +	if (!count)
> > +		return count;
> > +
> > +	mr = (typeof(mr))attr->private;
> > +	pvd = tmr_mr_to_provider(mr, kobj);
> > +	rc = down_read_interruptible(&pvd->rwsem);
> > +	if (rc)
> > +		return rc;
> > +
> > +	if ((mr->mr_flags & TSM_MR_F_L) && !pvd->in_sync) {
> > +		up_read(&pvd->rwsem);
> > +
> > +		rc = down_write_killable(&pvd->rwsem);
> > +		if (rc)
> > +			return rc;
> > +
> > +		if (!pvd->in_sync) {
> > +			rc = tmr_call_refresh(pvd, mr);
> > +			pvd->in_sync = !rc;
> > +		}
> > +
> > +		downgrade_write(&pvd->rwsem);
> > +	}
> > +
> > +	if (!rc)
> > +		memcpy(page, mr->mr_value + off, count);
> > +
> > +	up_read(&pvd->rwsem);
> > +	return rc ?: count;
> > +}
> > +
> > +static ssize_t tmr_digest_write(struct file *filp, struct kobject *kobj, struct bin_attribute *attr,
> > +				char *page, loff_t off, size_t count)
> > +{
> > +	const struct tsm_measurement_register *mr;
> > +	struct tmr_provider *pvd;
> > +	ssize_t rc;
> > +
> > +	if (off != 0 || count != attr->size)
> > +		return -EINVAL;
> > +
> > +	mr = (typeof(mr))attr->private;
> > +	pvd = tmr_mr_to_provider(mr, kobj);
> > +	rc = down_write_killable(&pvd->rwsem);
> > +	if (rc)
> > +		return rc;
> > +
> > +	if (mr->mr_flags & TSM_MR_F_X)
> > +		rc = tmr_call_extend(pvd, mr, page);
> > +	else
> > +		memcpy(mr->mr_value, page, count);
> > +
> > +	if (!rc)
> > +		pvd->in_sync = false;
> > +
> > +	up_write(&pvd->rwsem);
> > +	return rc ?: count;
> > +}
> 
> The logic around using pvd->in_sync is kinda complicated.  MR operations 
> seem like a classic reader/writer contention problem and I am not sure 
> why pvd->in_sync is needed.  Could you help to clarify?
> 
> [...]

[...]

> > 
> > +#define TSM_MR_(mr, hash)                                                           \
> > +	.mr_name = #mr, .mr_size = hash##_DIGEST_SIZE, .mr_hash = HASH_ALGO_##hash, \
> > +	.mr_flags = TSM_MR_F_R
> > +
> > +/**
> > + * struct tsm_measurement - define CC specific MRs and methods for updating them
> > + * @name: name of the measurement provider
> > + * @mrs: array of MR definitions ending with mr_name set to %NULL
> > + * @refresh: invoked to update the specified MR
> > + * @extend: invoked to extend the specified MR with mr_size bytes
> > + */
> > +struct tsm_measurement {
> > +	const char *name;
> > +	const struct tsm_measurement_register *mrs;
> > +	int (*refresh)(struct tsm_measurement *tmr, const struct tsm_measurement_register *mr);
> > +	int (*extend)(struct tsm_measurement *tmr, const struct tsm_measurement_register *mr,
> > +		      const u8 *data);
> > +};
> 
>  From the description above, I don't quite follow what does ->refresh() 
> do exactly.  Could you clarify why we need it?
> 

After reading patch 4, I figured out the purpose of the pvd->in_sync and the
refresh() myself:

Each call of ->extend() will update the value of the MR, but only in the
hardware/firmware.  The MR value maintained by the kernel is unchanged so it
will be out-of-date after the ->extend().  Therefore the kernel needs to keep
them synced first when userspace reads the MR, using the ->refresh().

It's also feasible to always sync/refresh after each extend(), eliminating the
pvd->in_sync logic completely, but it's not desired -- because the sync
operation talks to the hardware/firmware thus could be time-consuming, and we in
general only needs to sync before reading the value to the userspace.  E.g.,
this saves a lot of sync operation if userspace extends the MR multi-times with
large chunk of data and then reads the final value once.

So the pvd->in_sync logic seems useful to me, but I think it would be better to
a comment to explain this in both tmr_digest_read() and tmr_digest_write(). 
E.g., something like below before the code which checks pvd->in_sync in the
tmr_digest_read()?

	/*
	 * Each write-and-extend to the MR will update the MR, but only in
	 * TSM hardware/firmware, leaving the MR value maintained by the kernel
	 * out-of-date.  Sync MR value in TSM hardware/firmware to the kernel 
	 * before returning to the userspace in this case.
	 */
	if ((mr->mr_flags & TSM_MR_F_L) && !pvd->in_sync) {
		...

The description of the refresh() callback is also not clear to me.  Perhaps
something like below?

	/*
	 * ...
	 * @refresh: sync MR value in TSM hardware/firmware to the kernel
buffer
	 * ...
	 */

	
	   

  reply	other threads:[~2025-02-17 10:44 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-13  2:23 [PATCH 0/4] tsm: Unified Measurement Register ABI for TVMs Cedric Xing
2025-02-13  2:23 ` [PATCH 1/4] tsm: Add TVM Measurement Register support Cedric Xing
2025-02-14  0:55   ` kernel test robot
2025-02-17  0:17   ` Huang, Kai
2025-02-17 10:44     ` Huang, Kai [this message]
2025-02-17 20:57     ` Xing, Cedric
2025-02-18  9:14       ` Huang, Kai
2025-02-18 18:13         ` Xing, Cedric
2025-02-18  1:10   ` Sathyanarayanan Kuppuswamy
2025-02-20  1:01     ` Xing, Cedric
2025-02-13  2:23 ` [PATCH 2/4] tsm: Add TSM measurement sample code Cedric Xing
2025-02-13  2:23 ` [PATCH 3/4] x86/tdx: Add tdx_mcall_rtmr_extend() interface Cedric Xing
2025-02-17  0:40   ` Huang, Kai
2025-02-17 20:58     ` Xing, Cedric
2025-02-17 21:39       ` Sathyanarayanan Kuppuswamy
2025-02-13  2:23 ` [PATCH 4/4] x86/tdx: Expose TDX MRs through TSM sysfs interface Cedric Xing
2025-02-13  4:50 ` [PATCH 0/4] tsm: Unified Measurement Register ABI for TVMs Dave Hansen
2025-02-13 16:21   ` Xing, Cedric
2025-02-13 16:58     ` Dave Hansen
2025-02-13 21:50       ` Xing, Cedric
2025-02-13 23:19         ` Dave Hansen
2025-02-14 16:19           ` Xing, Cedric
2025-02-14 16:26             ` Dave Hansen
2025-02-14 21:59               ` Xing, Cedric
2025-02-18 16:25                 ` Dan Middleton
2025-02-18 16:57                   ` Dave Hansen
2025-02-18 23:57                     ` Dionna Amalie Glaze
2025-02-19  0:41                       ` Dave Hansen
2025-02-19  3:21                         ` Dionna Amalie Glaze
2025-02-19 13:29                           ` James Bottomley
2025-02-19 15:24                             ` Dan Middleton
2025-02-19 20:53                               ` James Bottomley
2025-02-19 22:25                                 ` Xing, Cedric
2025-02-19 23:02                                 ` Dan Williams
2025-05-02  1:45                       ` Dan Williams
2025-02-18 14:49         ` Mikko Ylinen
2025-02-19  4:04           ` Xing, Cedric
2025-02-19 11:31             ` Huang, Kai
2025-02-20  4:37               ` Xing, Cedric
2025-02-19 14:03             ` Mikko Ylinen
2025-02-20  5:07               ` Xing, Cedric
2025-02-18  1:10 ` Sathyanarayanan Kuppuswamy

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=e9a0953921530a6ec058b8236e45d2f4217d9c0e.camel@intel.com \
    --to=kai.huang@intel.com \
    --cc=bp@alien8.de \
    --cc=cedric.xing@intel.com \
    --cc=dan.j.williams@intel.com \
    --cc=dave.hansen@linux.intel.com \
    --cc=hpa@zytor.com \
    --cc=kirill.shutemov@linux.intel.com \
    --cc=linux-coco@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®