mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Krishna Kurapati PSSNV <krishna.kurapati@oss.qualcomm.com>
To: Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>
Cc: linux-arm-msm@vger.kernel.org, devicetree@vger.kernel.org,
	Bjorn Andersson <andersson@kernel.org>,
	Konrad Dybcio <konradybcio@kernel.org>,
	Rob Herring <robh@kernel.org>,
	Krzysztof Kozlowski <krzk+dt@kernel.org>,
	Conor Dooley <conor+dt@kernel.org>,
	Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH v5] arm64: dts: qcom: lemans-evk: Add OTG support for primary USB controller
Date: Tue, 25 Nov 2025 17:24:41 +0530	[thread overview]
Message-ID: <ea7b151d-7b32-4ebd-b3e0-3fe4b62f702d@oss.qualcomm.com> (raw)
In-Reply-To: <117f95a4-5f31-4372-a2e2-a0a969dc3d5e@oss.qualcomm.com>



On 11/25/2025 5:09 PM, Konrad Dybcio wrote:
> On 11/25/25 12:04 PM, Krishna Kurapati wrote:
>> Enable OTG support for primary USB controller on EVK Platform. Add
>> HD3SS3220 Type-C port controller present between Type-C port and SoC
>> that provides role switch notifications to controller.
>>
>> Signed-off-by: Krishna Kurapati <krishna.kurapati@oss.qualcomm.com>
>> ---
> 
> [...]
> 
>> --- a/arch/arm64/boot/dts/qcom/lemans.dtsi
>> +++ b/arch/arm64/boot/dts/qcom/lemans.dtsi
>> @@ -4026,7 +4026,27 @@ usb_0: usb@a600000 {
>>   			snps,dis-u1-entry-quirk;
>>   			snps,dis-u2-entry-quirk;
>>   
>> +			usb-role-switch;
>>   			status = "disabled";
>> +
>> +			ports {
>> +				#address-cells = <1>;
>> +				#size-cells = <0>;
>> +
>> +				port@0 {
>> +					reg = <0>;
>> +
>> +					usb3_0_hs_ep: endpoint {
> 
> The patch looks good, but I'm a little puzzled why the endpoints of 'usb_0' are
> named 'usb3_0'.. This will make the DTs look like:
> 
> &usb_0 {
> 	// foo
> };
> 
> &usb_1 {
> 	// foo
> };
> 
> // usb_0 children
> &usb3_0_hs_ep {
> 	// foo
> };
> 
> 
> &usb3_0_ss_ep {
> 	// foo
> };
> 
> // usb_1 children
> &usb3_1_hs_ep {
> 	// foo
> };
> 
> &usb3_1_ss_ep {
> 	// foo
> };
> 

Shall I rename them to "usb_0_dwc3_hs" and "usb_0_dwc3_ss" ?

Regards,
Krishna,

      reply	other threads:[~2025-11-25 11:55 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-11-25 11:04 Krishna Kurapati
2025-11-25 11:39 ` Konrad Dybcio
2025-11-25 11:54   ` Krishna Kurapati PSSNV [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ea7b151d-7b32-4ebd-b3e0-3fe4b62f702d@oss.qualcomm.com \
    --to=krishna.kurapati@oss.qualcomm.com \
    --cc=andersson@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=dmitry.baryshkov@oss.qualcomm.com \
    --cc=konrad.dybcio@oss.qualcomm.com \
    --cc=konradybcio@kernel.org \
    --cc=krzk+dt@kernel.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robh@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®