mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Krishna Kurapati PSSNV <quic_kriskura@quicinc.com>
To: Johan Hovold <johan@kernel.org>
Cc: Krzysztof Kozlowski <krzysztof.kozlowski+dt@linaro.org>,
	Rob Herring <robh+dt@kernel.org>,
	Bjorn Andersson <andersson@kernel.org>,
	Wesley Cheng <quic_wcheng@quicinc.com>,
	Konrad Dybcio <konrad.dybcio@linaro.org>,
	"Greg Kroah-Hartman" <gregkh@linuxfoundation.org>,
	Conor Dooley <conor+dt@kernel.org>,
	Thinh Nguyen <Thinh.Nguyen@synopsys.com>,
	Felipe Balbi <balbi@kernel.org>, <devicetree@vger.kernel.org>,
	<linux-arm-msm@vger.kernel.org>, <linux-usb@vger.kernel.org>,
	<linux-kernel@vger.kernel.org>, <quic_ppratap@quicinc.com>,
	<quic_jackp@quicinc.com>
Subject: Re: [PATCH v16 7/9] usb: dwc3: qcom: Refactor IRQ handling in glue driver
Date: Tue, 26 Mar 2024 15:36:27 +0530	[thread overview]
Message-ID: <ec3bf11a-0dc2-4313-ba93-c81494c4cc38@quicinc.com> (raw)
In-Reply-To: <ZgKHNuziNtBhGO9V@hovoldconsulting.com>



On 3/26/2024 1:58 PM, Johan Hovold wrote:
> On Tue, Mar 26, 2024 at 01:41:52PM +0530, Krishna Kurapati PSSNV wrote:
>> On 3/26/2024 1:15 AM, Johan Hovold wrote:
>>
>>> Just change the logic in dwc3_qcom_find_num_ports() so that it returns 1
>>> if "dp_hs_phy_1" is missing, and otherwise you determine the number of
>>> ports by iterating from 2 to DWC3_MAX_PORTS - 1.
> 
>> I made this change and it works. Removed any return value check for the
>> find_num_ports call as it can return only 1/2/3/4 now.
>>
>> ---
>>       irq = platform_get_irq_byname_optional(pdev, "qusb2_phy");
>>           if (irq > 0)
>>                   return 1;
>>
>>           irq = platform_get_irq_byname_optional(pdev, "dp_hs_phy_irq");
>>           if (irq > 0)
>>                   return 1;
> 
> As I mentioned above, these two lookups are no longer needed and should
> be removed.
>   
>>           irq = platform_get_irq_byname_optional(pdev, "dp_hs_phy_1");
>>           if (irq <= 0)
>>                   return 1;
> 
> Just assume it's a single port controller unless "dp_hs_phy_1" is
> present.
>   
>>           for (port_index = 1; port_index < DWC3_MAX_PORTS - 1;
>> port_index++) {
> 
> I think this would be more readable if you use port (num) as iterator
> (2..DWC3_MAX_PORTS) as you're returning a number of ports.
> 
>>                   sprintf(irq_name, "dp_hs_phy_%d", port_index + 1);
> 
> Then this would use just "port";
> 
>>
>>                   irq = platform_get_irq_byname_optional(pdev, irq_name);
>>                   if (irq <= 0)
>>                           return port_index;
> 
> And return "port - 1" here.
> 
>>           }
>>
>>           return DWC3_MAX_PORTS;

Ok,Thanks.

With the above fixed, can I put your RB tag given on [1] or will you be 
providing another one. Asking because when you gave that RB, this 
malformed DT thing wasn't there. So wanted to check with you before 
pushing the code.

[1]: https://lore.kernel.org/all/ZgFyukBXIIwZo7v-@hovoldconsulting.com/

Regards,
Krishna,

  reply	other threads:[~2024-03-26 10:06 UTC|newest]

Thread overview: 27+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-03-07  6:20 [PATCH v16 0/9] Add multiport support for DWC3 controllers Krishna Kurapati
2024-03-07  6:20 ` [PATCH v16 1/9] dt-bindings: usb: Add bindings for multiport properties on DWC3 controller Krishna Kurapati
2024-03-25 12:30   ` Johan Hovold
2024-03-07  6:20 ` [PATCH v16 2/9] usb: dwc3: core: Access XHCI address space temporarily to read port info Krishna Kurapati
2024-03-25 12:31   ` Johan Hovold
2024-03-07  6:20 ` [PATCH v16 3/9] usb: dwc3: core: Skip setting event buffers for host only controllers Krishna Kurapati
2024-03-07  6:20 ` [PATCH v16 4/9] usb: dwc3: core: Refactor PHY logic to support Multiport Controller Krishna Kurapati
2024-03-25 12:33   ` Johan Hovold
2024-03-07  6:20 ` [PATCH v16 5/9] dt-bindings: usb: qcom,dwc3: Add bindings for SC8280 Multiport Krishna Kurapati
2024-03-25 12:34   ` Johan Hovold
2024-03-07  6:20 ` [PATCH v16 6/9] usb: dwc3: qcom: Add helper function to request wakeup interrupts Krishna Kurapati
2024-03-25 12:35   ` Johan Hovold
2024-03-07  6:20 ` [PATCH v16 7/9] usb: dwc3: qcom: Refactor IRQ handling in glue driver Krishna Kurapati
2024-03-25 12:48   ` Johan Hovold
2024-03-25 13:15     ` Krishna Kurapati PSSNV
2024-03-25 13:23       ` Johan Hovold
2024-03-25 17:29         ` Krishna Kurapati PSSNV
2024-03-25 19:45           ` Johan Hovold
2024-03-26  8:11             ` Krishna Kurapati PSSNV
2024-03-26  8:28               ` Johan Hovold
2024-03-26 10:06                 ` Krishna Kurapati PSSNV [this message]
2024-03-26 10:14                   ` Johan Hovold
2024-03-07  6:20 ` [PATCH v16 8/9] usb: dwc3: qcom: Enable wakeup for applicable ports of multiport Krishna Kurapati
2024-03-25 12:50   ` Johan Hovold
2024-03-07  6:20 ` [PATCH v16 9/9] usb: dwc3: qcom: Add multiport suspend/resume support for wrapper Krishna Kurapati
2024-03-25 12:52   ` Johan Hovold
2024-03-25 13:15     ` Krishna Kurapati PSSNV

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ec3bf11a-0dc2-4313-ba93-c81494c4cc38@quicinc.com \
    --to=quic_kriskura@quicinc.com \
    --cc=Thinh.Nguyen@synopsys.com \
    --cc=andersson@kernel.org \
    --cc=balbi@kernel.org \
    --cc=conor+dt@kernel.org \
    --cc=devicetree@vger.kernel.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=johan@kernel.org \
    --cc=konrad.dybcio@linaro.org \
    --cc=krzysztof.kozlowski+dt@linaro.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=quic_jackp@quicinc.com \
    --cc=quic_ppratap@quicinc.com \
    --cc=quic_wcheng@quicinc.com \
    --cc=robh+dt@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®