mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v5 0/2] x86/resctrl: Track llc_occupancy of RMIDs in limbo list
@ 2024-03-08  7:41 Haifeng Xu
  2024-03-08  7:41 ` [PATCH v5 1/2] x86/resctrl: Rename pseudo_lock_event.h to trace.h Haifeng Xu
  2024-03-08  7:41 ` [PATCH v5 2/2] x86/resctrl: Add tracepoint for llc_occupancy tracking Haifeng Xu
  0 siblings, 2 replies; 7+ messages in thread
From: Haifeng Xu @ 2024-03-08  7:41 UTC (permalink / raw)
  To: reinette.chatre, james.morse
  Cc: fenghua.yu, babu.moger, tglx, mingo, bp, dave.hansen, hpa,
	peternewman, x86, linux-kernel, corbet, linux-doc, Haifeng Xu

After removing a monitor group, its RMID may not be freed immediately
unless its llc_occupancy is less than the re-allocation threshold. If
turning up the threshold, the RMID can be reused. In order to know how
much the threshold should be, it's necessary to acquire the llc_occupancy.

The patch series provides a new tracepoint to track the llc_occupancy.

Changes since v1:
- Rename pseudo_lock_event.h instead of creating a new header file.
- Modify names used in the tracepoint.
- Update changelog.

Changes since v2:
- Fix typo and use the x86/resctrl subject prefix in the cover letter.
- Track both CLOSID and RMID in the tracepoint.
- Remove the details on how perf can be used in patch2's changelog.

Changes since v3:
- Put the tracepoint in the 'else' section of the if/else after
  resctrl_arch_rmid_read().
- Modify names used in the tracepoint.
- Document the properties of the tracepoint.

Changes since v4:
- Add Reviewed-by tags.
- Include more maintainers in the submission.

Haifeng Xu (2):
  x86/resctrl: Rename pseudo_lock_event.h to trace.h
  x86/resctrl: Add tracepoint for llc_occupancy tracking

 Documentation/arch/x86/resctrl.rst            |  8 +++++++
 arch/x86/kernel/cpu/resctrl/monitor.c         |  9 ++++++++
 arch/x86/kernel/cpu/resctrl/pseudo_lock.c     |  2 +-
 .../resctrl/{pseudo_lock_event.h => trace.h}  | 22 ++++++++++++++++---
 4 files changed, 37 insertions(+), 4 deletions(-)
 rename arch/x86/kernel/cpu/resctrl/{pseudo_lock_event.h => trace.h} (57%)

-- 
2.25.1


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2024-03-19  6:38 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-03-08  7:41 [PATCH v5 0/2] x86/resctrl: Track llc_occupancy of RMIDs in limbo list Haifeng Xu
2024-03-08  7:41 ` [PATCH v5 1/2] x86/resctrl: Rename pseudo_lock_event.h to trace.h Haifeng Xu
2024-03-13 22:46   ` Reinette Chatre
2024-03-19  6:27     ` Haifeng Xu
2024-03-08  7:41 ` [PATCH v5 2/2] x86/resctrl: Add tracepoint for llc_occupancy tracking Haifeng Xu
2024-03-13 22:47   ` Reinette Chatre
2024-03-19  6:38     ` Haifeng Xu

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome