From: "David Hildenbrand (Arm)" <david@kernel.org>
To: Jianyue Wu <wujianyue000@gmail.com>,
Andrew Morton <akpm@linux-foundation.org>,
Chris Li <chrisl@kernel.org>, Kairui Song <kasong@tencent.com>,
Kemeng Shi <shikemeng@huaweicloud.com>,
Nhat Pham <nphamcs@gmail.com>, Baoquan He <bhe@redhat.com>,
Barry Song <baohua@kernel.org>,
Youngjun Park <youngjun.park@lge.com>,
Qi Zheng <qi.zheng@linux.dev>,
Shakeel Butt <shakeel.butt@linux.dev>,
Axel Rasmussen <axelrasmussen@google.com>,
Yuanchu Xie <yuanchu@google.com>, Wei Xu <weixugc@google.com>,
Johannes Weiner <hannes@cmpxchg.org>,
Michal Hocko <mhocko@kernel.org>,
Lorenzo Stoakes <ljs@kernel.org>,
"Liam R. Howlett" <liam@infradead.org>,
Vlastimil Babka <vbabka@kernel.org>,
Mike Rapoport <rppt@kernel.org>,
Suren Baghdasaryan <surenb@google.com>,
Michal Hocko <mhocko@suse.com>, Hugh Dickins <hughd@google.com>,
Baolin Wang <baolin.wang@linux.alibaba.com>
Cc: linux-mm@kvack.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 2/3] mm: move folio LRU code out of swap
Date: Mon, 1 Jun 2026 16:48:55 +0200 [thread overview]
Message-ID: <f49466ea-61c1-4546-861b-e3b518710042@kernel.org> (raw)
In-Reply-To: <20260531-ch-swap-series-plus-folio-lru-cleanup-v2-2-1b9a4ac255b4@gmail.com>
On 5/31/26 11:50, Jianyue Wu wrote:
> Rename mm/swap.c to mm/folio_lru.c so the filename better matches
> the code's main responsibility.
I agree that this is cleaner than "swap.c" ...
>
> This keeps the implementation split from swap-specific code without
> changing the published LRU helper interfaces.
>
> Signed-off-by: Jianyue Wu <wujianyue000@gmail.com>
> ---
> mm/Makefile | 2 +-
> mm/{swap.c => folio_lru.c} | 2 +-
> 2 files changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/mm/Makefile b/mm/Makefile
> index eff9f9e7e061..5f712f9bbe73 100644
> --- a/mm/Makefile
> +++ b/mm/Makefile
> @@ -50,7 +50,7 @@ endif
>
> obj-y := filemap.o mempool.o oom_kill.o fadvise.o \
> maccess.o page-writeback.o folio-compat.o \
> - readahead.o swap.o truncate.o vmscan.o shrinker.o \
> + readahead.o folio_lru.o truncate.o vmscan.o shrinker.o \
> shmem.o util.o mmzone.o vmstat.o backing-dev.o \
> mm_init.o percpu.o slab_common.o \
> compaction.o show_mem.o \
> diff --git a/mm/swap.c b/mm/folio_lru.c
> similarity index 99%
> rename from mm/swap.c
> rename to mm/folio_lru.c
> index e4b3dadaa6dc..7dab6a544d94 100644
> --- a/mm/swap.c
> +++ b/mm/folio_lru.c
> @@ -1,6 +1,6 @@
> // SPDX-License-Identifier: GPL-2.0-only
> /*
> - * linux/mm/swap.c
> + * linux/mm/folio_lru.c
> *
> * Copyright (C) 1991, 1992, 1993, 1994 Linus Torvalds
> */
>
This likely needs a MAINTAINER update?
--
Cheers,
David
next prev parent reply other threads:[~2026-06-01 14:49 UTC|newest]
Thread overview: 9+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-05-31 9:50 [PATCH v2 0/3] mm: clean up folio LRU and swap declarations Jianyue Wu
2026-05-31 9:50 ` [PATCH v2 1/3] mm/swap: colocate page-cluster sysctl with swap readahead Jianyue Wu
2026-05-31 22:06 ` Barry Song
2026-06-01 0:59 ` Jianyue Wu
2026-05-31 9:50 ` [PATCH v2 2/3] mm: move folio LRU code out of swap Jianyue Wu
2026-06-01 14:48 ` David Hildenbrand (Arm) [this message]
2026-05-31 9:50 ` [PATCH v2 3/3] mm: move reclaim-internal declarations out of swap.h Jianyue Wu
2026-06-01 14:57 ` David Hildenbrand (Arm)
2026-06-01 23:46 ` Jianyue Wu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=f49466ea-61c1-4546-861b-e3b518710042@kernel.org \
--to=david@kernel.org \
--cc=akpm@linux-foundation.org \
--cc=axelrasmussen@google.com \
--cc=baohua@kernel.org \
--cc=baolin.wang@linux.alibaba.com \
--cc=bhe@redhat.com \
--cc=chrisl@kernel.org \
--cc=hannes@cmpxchg.org \
--cc=hughd@google.com \
--cc=kasong@tencent.com \
--cc=liam@infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mm@kvack.org \
--cc=ljs@kernel.org \
--cc=mhocko@kernel.org \
--cc=mhocko@suse.com \
--cc=nphamcs@gmail.com \
--cc=qi.zheng@linux.dev \
--cc=rppt@kernel.org \
--cc=shakeel.butt@linux.dev \
--cc=shikemeng@huaweicloud.com \
--cc=surenb@google.com \
--cc=vbabka@kernel.org \
--cc=weixugc@google.com \
--cc=wujianyue000@gmail.com \
--cc=youngjun.park@lge.com \
--cc=yuanchu@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome