mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v2 0/3] mm: clean up folio LRU and swap declarations
@ 2026-05-31  9:50 Jianyue Wu
  2026-05-31  9:50 ` [PATCH v2 1/3] mm/swap: colocate page-cluster sysctl with swap readahead Jianyue Wu
                   ` (2 more replies)
  0 siblings, 3 replies; 9+ messages in thread
From: Jianyue Wu @ 2026-05-31  9:50 UTC (permalink / raw)
  To: Andrew Morton, Chris Li, Kairui Song, Kemeng Shi, Nhat Pham,
	Baoquan He, Barry Song, Youngjun Park, Qi Zheng, Shakeel Butt,
	Axel Rasmussen, Yuanchu Xie, Wei Xu, Johannes Weiner,
	David Hildenbrand, Michal Hocko, Lorenzo Stoakes,
	Liam R. Howlett, Vlastimil Babka, Mike Rapoport,
	Suren Baghdasaryan, Michal Hocko, Hugh Dickins, Baolin Wang
  Cc: linux-mm, linux-kernel, Jianyue Wu

This is a v2 of the previous single-patch cleanup:

  https://lore.kernel.org/r/20260407110002.204755-1-wujianyue000@gmail.com

The previous version moved the folio LRU helpers out of mm/swap.c in
one step. Based on review feedback from Johannes, Baoquan and Barry,
split the cleanup into smaller steps:

  - move the page-cluster sysctl next to swap readahead in mm/swap_state.c
  - rename mm/swap.c to mm/folio_lru.c after the swap-specific bits move out
  - move MM-internal reclaim declarations out of include/linux/swap.h

The first patch handles the swap-specific page-cluster state before the
file rename, so the rename commit only carries folio LRU code. The last
patch keeps the LRU helpers used outside mm/ in include/linux/swap.h and
moves the internal reclaim/workingset declarations to mm/internal.h.

This series is based on Christoph Hellwig's swap_ops series, which
moves swap I/O dispatch behind swap_ops and leaves mm/swap.c with less
swap-specific state. That makes the folio LRU cleanup more natural to
split out on top.

  https://lore.kernel.org/r/20260528124559.2566481-1-hch@lst.de

Signed-off-by: Jianyue Wu <wujianyue000@gmail.com>
---
Jianyue Wu (3):
      mm/swap: colocate page-cluster sysctl with swap readahead
      mm: move folio LRU code out of swap
      mm: move reclaim-internal declarations out of swap.h

 include/linux/swap.h       | 75 ++++------------------------------------------
 mm/Makefile                |  2 +-
 mm/{swap.c => folio_lru.c} | 38 +----------------------
 mm/internal.h              | 66 ++++++++++++++++++++++++++++++++++++++++
 mm/memfd.c                 |  1 +
 mm/swap.h                  |  2 --
 mm/swap_state.c            | 37 +++++++++++++++++++++++
 mm/vmscan.c                |  2 +-
 8 files changed, 113 insertions(+), 110 deletions(-)
---
base-commit: d7be408821acadd7d713d1da16a6742886799114
change-id: 20260531-ch-swap-series-plus-folio-lru-cleanup-d9781c8332dc

Best regards,
-- 
Jianyue Wu <wujianyue000@gmail.com>


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2026-06-01 23:46 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-05-31  9:50 [PATCH v2 0/3] mm: clean up folio LRU and swap declarations Jianyue Wu
2026-05-31  9:50 ` [PATCH v2 1/3] mm/swap: colocate page-cluster sysctl with swap readahead Jianyue Wu
2026-05-31 22:06   ` Barry Song
2026-06-01  0:59     ` Jianyue Wu
2026-05-31  9:50 ` [PATCH v2 2/3] mm: move folio LRU code out of swap Jianyue Wu
2026-06-01 14:48   ` David Hildenbrand (Arm)
2026-05-31  9:50 ` [PATCH v2 3/3] mm: move reclaim-internal declarations out of swap.h Jianyue Wu
2026-06-01 14:57   ` David Hildenbrand (Arm)
2026-06-01 23:46     ` Jianyue Wu

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®