mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: AngeloGioacchino Del Regno  <angelogioacchino.delregno@collabora.com>
To: "Shawn Sung (宋孝謙)" <Shawn.Sung@mediatek.com>,
	"CK Hu (胡俊光)" <ck.hu@mediatek.com>,
	"matthias.bgg@gmail.com" <matthias.bgg@gmail.com>,
	"robh+dt@kernel.org" <robh+dt@kernel.org>,
	"krzysztof.kozlowski+dt@linaro.org"
	<krzysztof.kozlowski+dt@linaro.org>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"linux-mediatek@lists.infradead.org"
	<linux-mediatek@lists.infradead.org>,
	"chunkuang.hu@kernel.org" <chunkuang.hu@kernel.org>,
	"Jason-JH Lin (林睿祥)" <Jason-JH.Lin@mediatek.com>,
	"devicetree@vger.kernel.org" <devicetree@vger.kernel.org>,
	"Nancy Lin (林欣螢)" <Nancy.Lin@mediatek.com>,
	"Moudy Ho (何宗原)" <Moudy.Ho@mediatek.com>,
	"daniel@ffwll.ch" <daniel@ffwll.ch>,
	"p.zabel@pengutronix.de" <p.zabel@pengutronix.de>,
	"dri-devel@lists.freedesktop.org"
	<dri-devel@lists.freedesktop.org>,
	"Nathan Lu (呂東霖)" <Nathan.Lu@mediatek.com>,
	"airlied@gmail.com" <airlied@gmail.com>,
	"sean@poorly.run" <sean@poorly.run>,
	"linux-arm-kernel@lists.infradead.org"
	<linux-arm-kernel@lists.infradead.org>,
	"fshao@chromium.org" <fshao@chromium.org>,
	"johnson.wang@mediatek.corp-partner.google.com"
	<johnson.wang@mediatek.corp-partner.google.com>
Subject: Re: [PATCH v10 20/24] drm/mediatek: Add Padding to OVL adaptor
Date: Thu, 19 Oct 2023 11:55:50 +0200	[thread overview]
Message-ID: <fdeea37a-6683-44dd-b946-ee708a0b9000@collabora.com> (raw)
In-Reply-To: <9939f8f5fbc2fcc469db212cf53fd3be0231384f.camel@mediatek.com>

Il 19/10/23 11:20, Shawn Sung (宋孝謙) ha scritto:
> Hi Angelo,
> 
> On Thu, 2023-10-19 at 11:10 +0200, AngeloGioacchino Del Regno wrote:
>>>    static const struct of_device_id mtk_ovl_adaptor_comp_dt_ids[] =
>>> {
>>> +	{ .compatible = "mediatek,mt8188-padding", .data = (void
>>> *)OVL_ADAPTOR_TYPE_PADDING },
>>
>> Uhm, for consistency I'd call this "mediatek,mt8188-disp-padding"
>> (you don't have
>> to drop Reviewed-by tags for such a change, not here and not in the
>> yaml commit),
>> but it's fine if you have reasons against that.
>>
>> So, regardless of this being changed or not
>>
>> Reviewed-by: AngeloGioacchino Del Regno <
>> angelogioacchino.delregno@collabora.com>
>>
>>>    	{ .compatible = "mediatek,mt8195-disp-ethdr", .data = (void
>>> *)OVL_ADAPTOR_TYPE_ETHDR },
>>>    	{ .compatible = "mediatek,mt8195-disp-merge", .data = (void
>>> *)OVL_ADAPTOR_TYPE_MERGE },
>>>    	{ .compatible = "mediatek,mt8195-vdo1-rdma", .data = (void
>>> *)OVL_ADAPTOR_TYPE_MDP_RDMA },
>>
> 
> Thanks for pointing this out. Had changed Padding driver's name to
> "mtk-disp-padding", but I just notice that Padding will also be used by
> MDP and they will share the same driver with display. Should we change
> the name again or is it just fine to use "mtk-disp-padding"?
> 

That's like many other components in MediaTek, so we can keep the mtk-disp-padding
name.... in devicetree, we will anyway use "mediatek,mt8195-mdp3-padding" as one of
the compatible string(s).

This is the only way that we have to actually distinguish between components used
for MDP3 and components used for the display subsystem, if we keep them "generic"
we won't understand what's going on in case of issues.

The driver name should contain "disp" for consistency with all of the component
drivers in mediatek-drm; if this wasn't in this folder, we could've dropped the
"disp" in the name, but that's not the case.

Consistency is #1.

Cheers,
Angelo

> Thanks,
> Shawn




  reply	other threads:[~2023-10-19  9:56 UTC|newest]

Thread overview: 38+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-10-19  5:55 [PATCH v10 00/24] Add display driver for MT8188 VDOSYS1 Hsiao Chien Sung
2023-10-19  5:55 ` [PATCH v10 01/24] dt-bindings: display: mediatek: ethdr: Add compatible for MT8188 Hsiao Chien Sung
2023-10-19  5:55 ` [PATCH v10 02/24] dt-bindings: display: mediatek: mdp-rdma: " Hsiao Chien Sung
2023-10-19  5:55 ` [PATCH v10 03/24] dt-bindings: display: mediatek: merge: " Hsiao Chien Sung
2023-10-19  5:55 ` [PATCH v10 04/24] dt-bindings: display: mediatek: padding: Add MT8188 Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 05/24] dt-bindings: arm: mediatek: Add compatible for MT8188 Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 06/24] dt-bindings: reset: mt8188: Add VDOSYS reset control bits Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 07/24] soc: mediatek: Support MT8188 VDOSYS1 in mtk-mmsys Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 08/24] soc: mediatek: Support MT8188 VDOSYS1 Padding " Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 09/24] soc: mediatek: Support reset bit mapping in mmsys driver Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 10/24] soc: mediatek: Add MT8188 VDOSYS reset bit map Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 11/24] drm/mediatek: Rename OVL_ADAPTOR_TYPE_RDMA Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 12/24] drm/mediatek: Add component ID to component match structure Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 13/24] drm/mediatek: Manage component's clock with function pointers Hsiao Chien Sung
2023-10-19  9:10   ` AngeloGioacchino Del Regno
2023-10-24  7:55   ` CK Hu (胡俊光)
2023-10-19  5:56 ` [PATCH v10 14/24] drm/mediatek: Power on/off devices " Hsiao Chien Sung
2023-10-19  9:07   ` AngeloGioacchino Del Regno
2023-10-24  8:12   ` CK Hu (胡俊光)
2023-10-19  5:56 ` [PATCH v10 15/24] drm/mediatek: Remove ineffectual power management codes Hsiao Chien Sung
2023-10-19  9:07   ` AngeloGioacchino Del Regno
2023-10-19  9:52     ` Shawn Sung (宋孝謙)
2023-10-19 10:17       ` AngeloGioacchino Del Regno
2023-10-24  9:25   ` CK Hu (胡俊光)
2023-10-24  9:39     ` Shawn Sung (宋孝謙)
2023-10-19  5:56 ` [PATCH v10 16/24] drm/mediatek: Start/Stop components with function pointers Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 17/24] drm/mediatek: Sort OVL adaptor components Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 18/24] drm/mediatek: Refine device table of OVL adaptor Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 19/24] drm/mediatek: Support MT8188 Padding in display driver Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 20/24] drm/mediatek: Add Padding to OVL adaptor Hsiao Chien Sung
2023-10-19  9:10   ` AngeloGioacchino Del Regno
2023-10-19  9:20     ` Shawn Sung (宋孝謙)
2023-10-19  9:55       ` AngeloGioacchino Del Regno [this message]
2023-10-19 11:50         ` Shawn Sung (宋孝謙)
2023-10-19  5:56 ` [PATCH v10 21/24] drm/mediatek: Return error if MDP RDMA failed to enable the clock Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 22/24] drm/mediatek: Remove the redundant driver data for DPI Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 23/24] drm/mediatek: Fix underrun in VDO1 when switches off the layer Hsiao Chien Sung
2023-10-19  5:56 ` [PATCH v10 24/24] drm/mediatek: Support MT8188 VDOSYS1 in display driver Hsiao Chien Sung

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=fdeea37a-6683-44dd-b946-ee708a0b9000@collabora.com \
    --to=angelogioacchino.delregno@collabora.com \
    --cc=Jason-JH.Lin@mediatek.com \
    --cc=Moudy.Ho@mediatek.com \
    --cc=Nancy.Lin@mediatek.com \
    --cc=Nathan.Lu@mediatek.com \
    --cc=Shawn.Sung@mediatek.com \
    --cc=airlied@gmail.com \
    --cc=chunkuang.hu@kernel.org \
    --cc=ck.hu@mediatek.com \
    --cc=daniel@ffwll.ch \
    --cc=devicetree@vger.kernel.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=fshao@chromium.org \
    --cc=johnson.wang@mediatek.corp-partner.google.com \
    --cc=krzysztof.kozlowski+dt@linaro.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mediatek@lists.infradead.org \
    --cc=matthias.bgg@gmail.com \
    --cc=p.zabel@pengutronix.de \
    --cc=robh+dt@kernel.org \
    --cc=sean@poorly.run \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®