* [PATCH] mtd: powernv_flash: fix kernel-doc for powernv_flash_release
@ 2026-09-07 0:48 Rosen Penev
2026-09-07 3:28 ` Ritesh Harjani
0 siblings, 1 reply; 2+ messages in thread
From: Rosen Penev @ 2026-09-07 0:48 UTC (permalink / raw)
To: linux-mtd
Cc: Miquel Raynal, Richard Weinberger, Vignesh Raghavendra,
Madhavan Srinivasan, Michael Ellerman, Nicholas Piggin,
Christophe Leroy (CS GROUP),
open list:LINUX FOR POWERPC (32-BIT AND 64-BIT),
open list
The function is powernv_flash_release, not op_release. Update the
kernel-doc comment to match.
Fixes W=1 warning:
Warning: drivers/mtd/devices/powernv_flash.c:271 expecting prototype for op_release(). Prototype was for powernv_flash_release() instead
Assisted-by: Opencode:BigPickle
Signed-off-by: Rosen Penev <rosenp@gmail.com>
---
drivers/mtd/devices/powernv_flash.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/mtd/devices/powernv_flash.c b/drivers/mtd/devices/powernv_flash.c
index a12427d9e20f..fe1d6684d0bd 100644
--- a/drivers/mtd/devices/powernv_flash.c
+++ b/drivers/mtd/devices/powernv_flash.c
@@ -263,7 +263,7 @@ static int powernv_flash_probe(struct platform_device *pdev)
}
/**
- * op_release - Release the driver
+ * powernv_flash_release - Release the driver
* @pdev: the platform device
*
* Returns 0
--
2.55.0
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH] mtd: powernv_flash: fix kernel-doc for powernv_flash_release
2026-09-07 0:48 [PATCH] mtd: powernv_flash: fix kernel-doc for powernv_flash_release Rosen Penev
@ 2026-09-07 3:28 ` Ritesh Harjani
0 siblings, 0 replies; 2+ messages in thread
From: Ritesh Harjani @ 2026-09-07 3:28 UTC (permalink / raw)
To: Rosen Penev, linux-mtd
Cc: Miquel Raynal, Richard Weinberger, Vignesh Raghavendra,
Madhavan Srinivasan, Michael Ellerman, Nicholas Piggin,
Christophe Leroy (CS GROUP),
open list:LINUX FOR POWERPC (32-BIT AND 64-BIT),
open list
Rosen Penev <rosenp@gmail.com> writes:
> The function is powernv_flash_release, not op_release. Update the
> kernel-doc comment to match.
>
> Fixes W=1 warning:
>
> Warning: drivers/mtd/devices/powernv_flash.c:271 expecting prototype for op_release(). Prototype was for powernv_flash_release() instead
>
> Assisted-by: Opencode:BigPickle
> Signed-off-by: Rosen Penev <rosenp@gmail.com>
> ---
> drivers/mtd/devices/powernv_flash.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
LGTM. Please feel free to add:
Reviewed-by: Ritesh Harjani (IBM) <ritesh.list@gmail.com>
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2026-09-07 3:29 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-09-07 0:48 [PATCH] mtd: powernv_flash: fix kernel-doc for powernv_flash_release Rosen Penev
2026-09-07 3:28 ` Ritesh Harjani
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®