From: ebiederm@xmission.com (Eric W. Biederman)
To: "Serge E. Hallyn" <serue@us.ibm.com>
Cc: Andrew Morton <akpm@osdl.org>,
containers@lists.osdl.org, linux-kernel@vger.kernel.org,
Oleg Nesterov <oleg@tv-sign.ru>
Subject: Re: [Containers] [PATCH 2/7] pid: Add do_each_pid_task
Date: Wed, 16 Aug 2006 00:34:51 -0600 [thread overview]
Message-ID: <m1zme55gtw.fsf@ebiederm.dsl.xmission.com> (raw)
In-Reply-To: <20060816031043.GE15241@sergelap.austin.ibm.com> (Serge E. Hallyn's message of "Tue, 15 Aug 2006 22:10:43 -0500")
"Serge E. Hallyn" <serue@us.ibm.com> writes:
> Quoting Eric W. Biederman (ebiederm@xmission.com):
>> To avoid pid rollover confusion the kernel needs to work with
>> struct pid * instead of pid_t. Currently there is not an iterator
>> that walks through all of the tasks of a given pid type starting
>> with a struct pid. This prevents us replacing some pid_t instances
>> with struct pid. So this patch adds do_each_pid_task which walks
>> through the set of task for a given pid type starting with a struct pid.
>>
>> Signed-off-by: Eric W. Biederman <ebiederm@xmission.com>
>> ---
>> include/linux/pid.h | 13 +++++++++++++
>> 1 files changed, 13 insertions(+), 0 deletions(-)
>>
>> diff --git a/include/linux/pid.h b/include/linux/pid.h
>> index 93da7e2..4007114 100644
>> --- a/include/linux/pid.h
>> +++ b/include/linux/pid.h
>> @@ -118,4 +118,17 @@ #define while_each_task_pid(who, type, t
>> 1; }) ); \
>> }
>>
>> +#define do_each_pid_task(pid, type, task) \
>
> Hmm, defining do_each_pid_task right after do_each_task_pid could result
> in some frustration :)
>
> Though not sure of a better name - do_each_task_structpid?
A couple of things.
- I think do_each_pid_task is probably the most descriptive name
I can come up with. As these are tasks of a pid. I don't quite understand
where the old name came from.
- Whatever we pick for the new function is the name we are going to use
for a long time so I don't want it to be clumsy. The existing function
will go away after everything is updated.
- If you pick the wrong one you will get a compile error, as integers and
pointers are not very interchangeable.
I hate the temporary confusion but I don't see a better alternative.
Eric
next prev parent reply other threads:[~2006-08-16 6:35 UTC|newest]
Thread overview: 38+ messages / expand[flat|nested] mbox.gz Atom feed top
2006-08-15 18:21 Start using struct pid Eric W. Biederman
2006-08-15 18:23 ` [PATCH 1/7] pid: Implement access helpers for a tacks various process groups Eric W. Biederman
2006-08-15 18:40 ` Dave Hansen
2006-08-15 19:03 ` Eric W. Biederman
2006-08-16 8:04 ` [Containers] " Kirill Korotaev
2006-08-15 18:23 ` [PATCH 2/7] pid: Add do_each_pid_task Eric W. Biederman
2006-08-16 3:10 ` [Containers] " Serge E. Hallyn
2006-08-16 4:28 ` Andrew Morton
2006-08-16 6:15 ` Eric W. Biederman
2006-08-16 6:34 ` Eric W. Biederman [this message]
2006-08-16 11:57 ` Serge E. Hallyn
2006-08-16 19:17 ` Oleg Nesterov
2006-08-17 21:16 ` [PATCH -mm] simplify pid iterators Oleg Nesterov
2006-08-15 18:23 ` [PATCH 3/7] pid: Implement signal functions that take a struct pid * Eric W. Biederman
2006-08-15 18:23 ` [PATCH 4/7] pid: Export the symbols needed to use " Eric W. Biederman
2006-08-15 18:23 ` [PATCH 5/7] pid: Implement pid_nr Eric W. Biederman
2006-08-15 18:37 ` Dave Hansen
2006-08-15 19:00 ` Eric W. Biederman
2006-08-15 19:15 ` [Containers] " Dave Hansen
2006-08-16 6:29 ` Eric W. Biederman
2006-08-16 16:27 ` Jan Engelhardt
2006-08-16 17:48 ` Eric W. Biederman
2006-08-16 18:19 ` Oleg Nesterov
2006-08-16 16:18 ` Eric W. Biederman
2006-08-16 21:03 ` Oleg Nesterov
2006-08-16 17:18 ` Eric W. Biederman
2006-08-15 18:23 ` [PATCH 6/7] vt: Update spawnpid to be a struct pid_t Eric W. Biederman
2006-08-15 18:53 ` Alan Cox
2006-08-15 18:45 ` Eric W. Biederman
2006-08-16 8:04 ` [Containers] " Kirill Korotaev
2006-08-16 14:23 ` Eric W. Biederman
2006-08-15 19:38 ` Ray Lehtiniemi
2006-08-16 19:35 ` Oleg Nesterov
2006-08-16 15:43 ` Andrew Morton
2006-08-16 17:55 ` Eric W. Biederman
2006-08-15 18:23 ` [PATCH 7/7] file: Modify struct fown_struct to use a struct pid Eric W. Biederman
2006-08-16 18:45 ` Oleg Nesterov
2006-08-16 18:48 ` Oleg Nesterov
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=m1zme55gtw.fsf@ebiederm.dsl.xmission.com \
--to=ebiederm@xmission.com \
--cc=akpm@osdl.org \
--cc=containers@lists.osdl.org \
--cc=linux-kernel@vger.kernel.org \
--cc=oleg@tv-sign.ru \
--cc=serue@us.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome