From: "Christopher Hall" <christopher.s.hall@intel.com>
To: "Richard Cochran" <richardcochran@gmail.com>
Cc: tglx@linutronix.de, mingo@redhat.com, john.stultz@linaro.org,
hpa@zytor.com, jeffrey.t.kirsher@intel.com, x86@kernel.org,
linux-kernel@vger.kernel.org, intel-wired-lan@lists.osuosl.org,
netdev@vger.kernel.org, kevin.b.stanton@intel.com,
kevin.j.clarke@intel.com
Subject: Re: [PATCH v7 3/8] time: Remove duplicated code in ktime_get_raw_and_real()
Date: Tue, 16 Feb 2016 10:23:01 -0800 [thread overview]
Message-ID: <op.ycxuonx01774gr@chall-mobl2.amr.corp.intel.com> (raw)
In-Reply-To: <20160216075210.GA2461@localhost.localdomain>
On Mon, 15 Feb 2016 23:52:10 -0800, Richard Cochran
<richardcochran@gmail.com> wrote:
>> @@ -888,6 +888,8 @@ void ktime_get_snapshot(struct system_time_snapshot
>> *systime_snapshot)
>> s64 nsec_real;
>> cycle_t now;
>>
>> + WARN_ON(timekeeping_suspended);
> ...
>> - WARN_ON_ONCE(timekeeping_suspended);
>
> Is this change intentional?
Yes it is. The code I replaced in pps_kernel.h (pps_get_ts()) has two call
paths depending on whether CONFIG_NTP_PPS is set. On one call path
(realtime only, config unset) WARN_ON(), from getnstimeofday64, is used,
on the other WARN_ON_ONCE(), from ktime_get_raw_and_real_ts64(), is used.
I opted for the greater verbosity of the two when I combined the code.
Is WARN_ON_ONCE() better here?
Thanks,
Chris
next prev parent reply other threads:[~2016-02-16 18:25 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-02-12 20:25 [PATCH v7 0/8] Patchset enabling hardware based cross-timestamps for next gen Intel platforms Christopher S. Hall
2016-02-12 20:25 ` [PATCH v7 1/8] time: Add cycles to nanoseconds translation Christopher S. Hall
2016-02-12 20:25 ` [PATCH v7 2/8] time: Add timekeeping snapshot code capturing system time and counter Christopher S. Hall
2016-02-12 20:25 ` [PATCH v7 3/8] time: Remove duplicated code in ktime_get_raw_and_real() Christopher S. Hall
2016-02-16 7:52 ` Richard Cochran
2016-02-16 18:23 ` Christopher Hall [this message]
2016-02-12 20:25 ` [PATCH v7 4/8] time: Add driver cross timestamp interface for higher precision time synchronization Christopher S. Hall
2016-02-16 7:56 ` Richard Cochran
2016-02-12 20:25 ` [PATCH v7 5/8] time: Add history to cross timestamp interface supporting slower devices Christopher S. Hall
2016-02-18 22:17 ` Richard Cochran
2016-02-19 17:33 ` John Stultz
2016-02-12 20:25 ` [PATCH v7 6/8] x86: tsc: Always Running Timer (ART) correlated clocksource Christopher S. Hall
2016-02-18 21:11 ` Andy Lutomirski
2016-02-23 2:38 ` Christopher Hall
2016-02-23 2:49 ` Andy Lutomirski
2016-02-12 20:25 ` [PATCH v7 7/8] ptp: Add PTP_SYS_OFFSET_PRECISE for driver crosstimestamping Christopher S. Hall
2016-02-12 20:25 ` [PATCH v7 8/8] net: e1000e: Adds hardware supported cross timestamp on e1000e nic Christopher S. Hall
2016-02-19 0:43 ` Jeff Kirsher
2016-02-18 19:26 ` [PATCH v7 0/8] Patchset enabling hardware based cross-timestamps for next gen Intel platforms John Stultz
2016-02-22 18:33 ` Christopher Hall
2016-02-22 18:49 ` John Stultz
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=op.ycxuonx01774gr@chall-mobl2.amr.corp.intel.com \
--to=christopher.s.hall@intel.com \
--cc=hpa@zytor.com \
--cc=intel-wired-lan@lists.osuosl.org \
--cc=jeffrey.t.kirsher@intel.com \
--cc=john.stultz@linaro.org \
--cc=kevin.b.stanton@intel.com \
--cc=kevin.j.clarke@intel.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=netdev@vger.kernel.org \
--cc=richardcochran@gmail.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome