* [PATCH] ALSA: hda: use swap() to make code cleaner
@ 2021-12-18 1:54 davidcomponentone
2021-12-25 8:15 ` Takashi Iwai
0 siblings, 1 reply; 2+ messages in thread
From: davidcomponentone @ 2021-12-18 1:54 UTC (permalink / raw)
To: perex
Cc: davidcomponentone, tiwai, broonie, joe, alsa-devel, linux-kernel,
Yang Guang, Zeal Robot
From: Yang Guang <yang.guang5@zte.com.cn>
Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
opencoding it.
Reported-by: Zeal Robot <zealci@zte.com.cn>
Signed-off-by: David Yang <davidcomponentone@gmail.com>
Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
---
sound/pci/hda/hda_auto_parser.c | 6 +-----
1 file changed, 1 insertion(+), 5 deletions(-)
diff --git a/sound/pci/hda/hda_auto_parser.c b/sound/pci/hda/hda_auto_parser.c
index 4a854475a0e6..82c492b05667 100644
--- a/sound/pci/hda/hda_auto_parser.c
+++ b/sound/pci/hda/hda_auto_parser.c
@@ -92,14 +92,10 @@ static int compare_input_type(const void *ap, const void *bp)
*/
static void reorder_outputs(unsigned int nums, hda_nid_t *pins)
{
- hda_nid_t nid;
-
switch (nums) {
case 3:
case 4:
- nid = pins[1];
- pins[1] = pins[2];
- pins[2] = nid;
+ swap(pins[1], pins[2]);
break;
}
}
--
2.30.2
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH] ALSA: hda: use swap() to make code cleaner
2021-12-18 1:54 [PATCH] ALSA: hda: use swap() to make code cleaner davidcomponentone
@ 2021-12-25 8:15 ` Takashi Iwai
0 siblings, 0 replies; 2+ messages in thread
From: Takashi Iwai @ 2021-12-25 8:15 UTC (permalink / raw)
To: davidcomponentone
Cc: perex, tiwai, broonie, joe, alsa-devel, linux-kernel, Yang Guang,
Zeal Robot
On Sat, 18 Dec 2021 02:54:16 +0100,
davidcomponentone@gmail.com wrote:
>
> From: Yang Guang <yang.guang5@zte.com.cn>
>
> Use the macro 'swap()' defined in 'include/linux/minmax.h' to avoid
> opencoding it.
>
> Reported-by: Zeal Robot <zealci@zte.com.cn>
> Signed-off-by: David Yang <davidcomponentone@gmail.com>
> Signed-off-by: Yang Guang <yang.guang5@zte.com.cn>
Applied now. Thanks.
Takashi
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2021-12-25 8:15 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-12-18 1:54 [PATCH] ALSA: hda: use swap() to make code cleaner davidcomponentone
2021-12-25 8:15 ` Takashi Iwai
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®