mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 1/2] dell-led: Change dell-led.h to dell-common.h
@ 2018-03-08  7:12 Kai-Heng Feng
  2018-03-08  7:12 ` [PATCH 2/2] platform/x86: dell-*: Add interface for switchable graphics status query Kai-Heng Feng
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: Kai-Heng Feng @ 2018-03-08  7:12 UTC (permalink / raw)
  To: mjg59, pali.rohar, dvhart, andy, mario.limonciello, tiwai
  Cc: platform-driver-x86, linux-kernel, alsa-devel, Kai-Heng Feng

This header will be used for more than just led. Change it to a more
generic name.

Signed-off-by: Kai-Heng Feng <kai.heng.feng@canonical.com>
---
 drivers/platform/x86/dell-laptop.c          | 2 +-
 include/linux/{dell-led.h => dell-common.h} | 4 ++--
 sound/pci/hda/dell_wmi_helper.c             | 2 +-
 3 files changed, 4 insertions(+), 4 deletions(-)
 rename include/linux/{dell-led.h => dell-common.h} (61%)

diff --git a/drivers/platform/x86/dell-laptop.c b/drivers/platform/x86/dell-laptop.c
index c52c6723374b..8ba820e6c3d0 100644
--- a/drivers/platform/x86/dell-laptop.c
+++ b/drivers/platform/x86/dell-laptop.c
@@ -29,7 +29,7 @@
 #include <linux/mm.h>
 #include <linux/i8042.h>
 #include <linux/debugfs.h>
-#include <linux/dell-led.h>
+#include <linux/dell-common.h>
 #include <linux/seq_file.h>
 #include <acpi/video.h>
 #include "dell-rbtn.h"
diff --git a/include/linux/dell-led.h b/include/linux/dell-common.h
similarity index 61%
rename from include/linux/dell-led.h
rename to include/linux/dell-common.h
index 92521471517f..37e4b614dd74 100644
--- a/include/linux/dell-led.h
+++ b/include/linux/dell-common.h
@@ -1,6 +1,6 @@
 /* SPDX-License-Identifier: GPL-2.0 */
-#ifndef __DELL_LED_H__
-#define __DELL_LED_H__
+#ifndef __DELL_COMMON_H__
+#define __DELL_COMMON_H__
 
 int dell_micmute_led_set(int on);
 
diff --git a/sound/pci/hda/dell_wmi_helper.c b/sound/pci/hda/dell_wmi_helper.c
index 1b48a8c19d28..56050cc3c0ee 100644
--- a/sound/pci/hda/dell_wmi_helper.c
+++ b/sound/pci/hda/dell_wmi_helper.c
@@ -4,7 +4,7 @@
  */
 
 #if IS_ENABLED(CONFIG_DELL_LAPTOP)
-#include <linux/dell-led.h>
+#include <linux/dell-common.h>
 
 enum {
 	MICMUTE_LED_ON,
-- 
2.15.1

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2018-03-08  8:35 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2018-03-08  7:12 [PATCH 1/2] dell-led: Change dell-led.h to dell-common.h Kai-Heng Feng
2018-03-08  7:12 ` [PATCH 2/2] platform/x86: dell-*: Add interface for switchable graphics status query Kai-Heng Feng
2018-03-08  7:34   ` Mario.Limonciello
2018-03-08  8:20     ` Kai Heng Feng
2018-03-08  8:35       ` Mario.Limonciello
2018-03-08  7:23 ` [PATCH 1/2] dell-led: Change dell-led.h to dell-common.h Takashi Iwai
2018-03-08  7:31 ` Mario.Limonciello

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®