* [PATCH v1 v1] target: fix incorrect function name in pr_err
@ 2024-10-30 2:18 Baolin Liu
2024-11-03 0:34 ` Martin K. Petersen
0 siblings, 1 reply; 2+ messages in thread
From: Baolin Liu @ 2024-10-30 2:18 UTC (permalink / raw)
To: martin.petersen
Cc: linux-scsi, target-devel, linux-kernel, liubaolin12138, Baolin Liu
From: Baolin Liu <liubaolin@kylinos.cn>
in pr_err(),bdev_open_by_path() should be renamed to
bdev_file_open_by_path()
Fixes: 034f0cf8fdf9 ("target: port block device access to file")
Signed-off-by: Baolin Liu <liubaolin@kylinos.cn>
---
drivers/target/target_core_pscsi.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/target/target_core_pscsi.c b/drivers/target/target_core_pscsi.c
index 440e07b1d5cd..287ac5b0495f 100644
--- a/drivers/target/target_core_pscsi.c
+++ b/drivers/target/target_core_pscsi.c
@@ -369,7 +369,7 @@ static int pscsi_create_type_disk(struct se_device *dev, struct scsi_device *sd)
bdev_file = bdev_file_open_by_path(dev->udev_path,
BLK_OPEN_WRITE | BLK_OPEN_READ, pdv, NULL);
if (IS_ERR(bdev_file)) {
- pr_err("pSCSI: bdev_open_by_path() failed\n");
+ pr_err("pSCSI: bdev_file_open_by_path() failed\n");
scsi_device_put(sd);
return PTR_ERR(bdev_file);
}
--
2.39.2
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH v1 v1] target: fix incorrect function name in pr_err
2024-10-30 2:18 [PATCH v1 v1] target: fix incorrect function name in pr_err Baolin Liu
@ 2024-11-03 0:34 ` Martin K. Petersen
0 siblings, 0 replies; 2+ messages in thread
From: Martin K. Petersen @ 2024-11-03 0:34 UTC (permalink / raw)
To: Baolin Liu
Cc: martin.petersen, linux-scsi, target-devel, linux-kernel, Baolin Liu
Baolin,
> in pr_err(),bdev_open_by_path() should be renamed to
> bdev_file_open_by_path()
Applied to 6.13/scsi-staging, thanks!
--
Martin K. Petersen Oracle Linux Engineering
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2024-11-03 0:34 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-10-30 2:18 [PATCH v1 v1] target: fix incorrect function name in pr_err Baolin Liu
2024-11-03 0:34 ` Martin K. Petersen
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome