From: "Måns Rullgård" <mans@mansr.com>
To: behanw@converseincode.com
Cc: linux@arm.linux.org.uk, Tejun Heo <tj@kernel.org>,
Christoph Lameter <cl@linux-foundation.org>,
Mark Charlebois <charlebm@gmail.com>,
linux-arm-kernel@lists.infradead.org (moderated list:ARM PORT),
linux-kernel@vger.kernel.org (open list)
Subject: Re: [PATCH 2/5] arm: LLVMLinux: use current_stack_pointer for percpu
Date: Fri, 06 Sep 2013 23:31:26 +0100 [thread overview]
Message-ID: <yw1xioyd1t1d.fsf@unicorn.mansr.com> (raw)
In-Reply-To: <1378502899-1241-3-git-send-email-behanw@converseincode.com> (behanw@converseincode.com's message of "Fri, 6 Sep 2013 17:28:08 -0400")
behanw@converseincode.com writes:
> From: Behan Webster <behanw@converseincode.com>
>
> The existing code uses named registers to get the value of the stack pointer.
> The new current_stack_pointer macro is more readable and allows for a central
> portable implementation of how to get the stack pointer with ASM. This change
> supports being able to compile the kernel with both gcc and Clang.
>
> Signed-off-by: Mark Charlebois <charlebm@gmail.com>
> Signed-off-by: Behan Webster <behanw@converseincode.com>
> Reviewed-by: Jan-Simon Möller <dl9pf@gmx.de>
> ---
> arch/arm/include/asm/percpu.h | 4 ++--
> 1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/arch/arm/include/asm/percpu.h b/arch/arm/include/asm/percpu.h
> index 209e650..629a975 100644
> --- a/arch/arm/include/asm/percpu.h
> +++ b/arch/arm/include/asm/percpu.h
> @@ -30,14 +30,14 @@ static inline void set_my_cpu_offset(unsigned long off)
> static inline unsigned long __my_cpu_offset(void)
> {
> unsigned long off;
> - register unsigned long *sp asm ("sp");
> + unsigned long sp = current_stack_pointer;
>
> /*
> * Read TPIDRPRW.
> * We want to allow caching the value, so avoid using volatile and
> * instead use a fake stack read to hazard against barrier().
> */
> - asm("mrc p15, 0, %0, c13, c0, 4" : "=r" (off) : "Q" (*sp));
> + asm("mrc p15, 0, %0, c13, c0, 4" : "=r" (off) : "Q" (sp));
This doesn't do quite the same thing. The existing code pretends to
read something from the stack in order to create a barrier of some
sort. Your new code stores the value of the stack pointer to a location
on the stack for consumption by the "Q" memory constraint. This store
is not necessary and should preferably be avoided.
--
Måns Rullgård
mans@mansr.com
next prev parent reply other threads:[~2013-09-06 22:31 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2013-09-06 21:28 [PATCH 0/5] arm: LLVMLinux: Add current_stack_pointer behanw
2013-09-06 21:28 ` [PATCH 1/5] arm: LLVMLinux: Add current_stack_pointer macro for ARM behanw
2013-09-06 22:12 ` Måns Rullgård
2013-09-06 22:20 ` Russell King - ARM Linux
2013-09-06 21:28 ` [PATCH 2/5] arm: LLVMLinux: use current_stack_pointer for percpu behanw
2013-09-06 22:22 ` Russell King - ARM Linux
2013-09-06 22:31 ` Måns Rullgård [this message]
2013-09-07 5:12 ` Nicolas Pitre
2013-09-09 9:59 ` Will Deacon
2013-09-06 21:28 ` [PATCH 3/5] arm: LLVMLinux: Use current_stack_pointer for return_address behanw
2013-09-06 21:28 ` [PATCH 4/5] arm: LLVMLinux: Use current_stack_pointer in save_stack_trace_tsk behanw
2013-09-06 21:28 ` [PATCH 5/5] arm: LLVMLinux: Use current_stack_pointer in unwind_backtrace behanw
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=yw1xioyd1t1d.fsf@unicorn.mansr.com \
--to=mans@mansr.com \
--cc=behanw@converseincode.com \
--cc=charlebm@gmail.com \
--cc=cl@linux-foundation.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@arm.linux.org.uk \
--cc=tj@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome