From: "Sven Püschel" <s.pueschel@pengutronix.de>
To: Nicolas Dufresne <nicolas@ndufresne.ca>,
Jacob Chen <jacob-chen@iotwrt.com>,
Ezequiel Garcia <ezequiel@vanguardiasur.com.ar>,
Mauro Carvalho Chehab <mchehab@kernel.org>,
Heiko Stuebner <heiko@sntech.de>, Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>
Cc: linux-media@vger.kernel.org, linux-rockchip@lists.infradead.org,
linux-arm-kernel@lists.infradead.org,
linux-kernel@vger.kernel.org, devicetree@vger.kernel.org,
kernel@pengutronix.de
Subject: Re: [PATCH v2 11/22] media: rockchip: rga: check scaling factor
Date: Fri, 9 Jan 2026 13:18:40 +0100 [thread overview]
Message-ID: <03fd04f7-629c-48cd-b498-0a1ebb67690d@pengutronix.de> (raw)
In-Reply-To: <02ac025c0ecf17354377c7f2c2fc83b40a3a41e1.camel@ndufresne.ca>
On 12/24/25 4:39 PM, Nicolas Dufresne wrote:
> Le mercredi 03 décembre 2025 à 16:52 +0100, Sven Püschel a écrit :
>> Check the scaling factor to avoid potential problems. This is relevant
>> for the upcoming RGA3 support, as it can hang when the scaling factor
>> is exceeded.
>>
>> There are two relevant scenarios that have to be considered to protect
>> against invalid scaling values:
>>
>> When the output or capture is already streaming, setting the format on
>> the other side should consider the max scaling factor and clamp it
>> accordingly. This is only done in the streaming case, as it otherwise
>> may unintentionally clamp the value when the application sets the first
>> format (due to a default format on the other side).
>>
>> When the format is set on both sides first, then the format won't be
>> corrected by above means. Therefore the second streamon call has to
>> check the scaling factor and fail otherwise.
> In codec specifications, we resolve this issue by resetting the capture format
> every-time the output format is set. But without specification for color
> transforms, its impossible to say if this is right or wrong, and I don't expect
> perfect interroperability between drivers until someone make the effort to
> specify this type of hardware.
>
> What you describe is fine of course, but its a bit off nature of the way format
> is normally being fixed by the driver to stay valid.
thanks for the info. Given the missing spec, I'd keep it at the current
unusual implementation unless I'd need to adjust it for the try_fmt
state issue.
>> Signed-off-by: Sven Püschel <s.pueschel@pengutronix.de>
>> ---
>> drivers/media/platform/rockchip/rga/rga-hw.c | 1 +
>> drivers/media/platform/rockchip/rga/rga-hw.h | 1 +
>> drivers/media/platform/rockchip/rga/rga.c | 60 +++++++++++++++++++++++++---
>> drivers/media/platform/rockchip/rga/rga.h | 1 +
>> 4 files changed, 58 insertions(+), 5 deletions(-)
>>
>> diff --git a/drivers/media/platform/rockchip/rga/rga-hw.c b/drivers/media/platform/rockchip/rga/rga-hw.c
>> index 8cdfe089fd636..2ed4f22a999d5 100644
>> --- a/drivers/media/platform/rockchip/rga/rga-hw.c
>> +++ b/drivers/media/platform/rockchip/rga/rga-hw.c
>> @@ -624,6 +624,7 @@ const struct rga_hw rga2_hw = {
>> .max_width = MAX_WIDTH,
>> .min_height = MIN_HEIGHT,
>> .max_height = MAX_HEIGHT,
>> + .max_scaling_factor = MAX_SCALING_FACTOR,
>> .stride_alignment = 4,
>>
>> .setup_cmdbuf = rga_hw_setup_cmdbuf,
>> diff --git a/drivers/media/platform/rockchip/rga/rga-hw.h b/drivers/media/platform/rockchip/rga/rga-hw.h
>> index f4752aa823051..fffcab0131225 100644
>> --- a/drivers/media/platform/rockchip/rga/rga-hw.h
>> +++ b/drivers/media/platform/rockchip/rga/rga-hw.h
>> @@ -14,6 +14,7 @@
>>
>> #define MIN_WIDTH 34
>> #define MIN_HEIGHT 34
>> +#define MAX_SCALING_FACTOR 16
>>
>> #define RGA_TIMEOUT 500
>>
>> diff --git a/drivers/media/platform/rockchip/rga/rga.c b/drivers/media/platform/rockchip/rga/rga.c
>> index f02ae02de26ca..46dc94db6f85e 100644
>> --- a/drivers/media/platform/rockchip/rga/rga.c
>> +++ b/drivers/media/platform/rockchip/rga/rga.c
>> @@ -346,18 +346,47 @@ static int vidioc_g_fmt(struct file *file, void *priv, struct v4l2_format *f)
>> static int vidioc_try_fmt(struct file *file, void *priv, struct v4l2_format *f)
>> {
>> struct v4l2_pix_format_mplane *pix_fmt = &f->fmt.pix_mp;
>> - struct rockchip_rga *rga = video_drvdata(file);
>> + struct rga_ctx *ctx = file_to_rga_ctx(file);
>> + struct rockchip_rga *rga = ctx->rga;
>> const struct rga_hw *hw = rga->hw;
>> struct rga_fmt *fmt;
>> + u32 min_width = hw->min_width;
>> + u32 max_width = hw->max_width;
>> + u32 min_height = hw->min_height;
>> + u32 max_height = hw->max_height;
>>
>> fmt = rga_fmt_find(rga, pix_fmt->pixelformat);
>> if (!fmt)
>> fmt = &hw->formats[0];
>>
>> - pix_fmt->width = clamp(pix_fmt->width,
>> - hw->min_width, hw->max_width);
>> - pix_fmt->height = clamp(pix_fmt->height,
>> - hw->min_height, hw->max_height);
>> + if (V4L2_TYPE_IS_OUTPUT(f->type) &&
>> + v4l2_m2m_get_dst_vq(ctx->fh.m2m_ctx)->streaming) {
> What if userspace wanted to get the buffer size computed, so it can allocate
> externally before it calls streamoff ? Hans did mention recently that try
> function should only be state aware if specified.
My plan is to move the try logic into a separate helper function with an
additional boolean parameter depending on which I do the state aware
adjustments. And then call this helper with false for try_fmt and true
for set_fmt.
Or is this also problematic as it violates the contract that try_fmt is
equivalent to set_fmt?
>
> I'd like other reviewers feedback on what should be done here, of course writing
> a spec would be ideal.
>
> Nicolas
>
>> + min_width =
>> + MAX(min_width, DIV_ROUND_UP(ctx->out.pix.width,
>> + hw->max_scaling_factor));
>> + max_width = MIN(max_width,
>> + ctx->out.pix.width * hw->max_scaling_factor);
>> + min_height =
>> + MAX(min_height, DIV_ROUND_UP(ctx->out.pix.height,
>> + hw->max_scaling_factor));
>> + max_height = MIN(max_height,
>> + ctx->out.pix.height * hw->max_scaling_factor);
>> + } else if (V4L2_TYPE_IS_CAPTURE(f->type) &&
>> + v4l2_m2m_get_src_vq(ctx->fh.m2m_ctx)->streaming) {
>> + min_width =
>> + MAX(min_width, DIV_ROUND_UP(ctx->in.pix.width,
>> + hw->max_scaling_factor));
>> + max_width = MIN(max_width,
>> + ctx->in.pix.width * hw->max_scaling_factor);
>> + min_height =
>> + MAX(min_height, DIV_ROUND_UP(ctx->in.pix.height,
>> + hw->max_scaling_factor));
>> + max_height = MIN(max_height,
>> + ctx->in.pix.height * hw->max_scaling_factor);
>> + }
>> +
>> + pix_fmt->width = clamp(pix_fmt->width, min_width, max_width);
>> + pix_fmt->height = clamp(pix_fmt->height, min_height, max_height);
>>
>> v4l2_fill_pixfmt_mp_aligned(pix_fmt, pix_fmt->pixelformat,
>> pix_fmt->width, pix_fmt->height, hw->stride_alignment);
>> @@ -523,12 +552,33 @@ static int vidioc_s_selection(struct file *file, void *priv,
>> return ret;
>> }
>>
>> +static bool check_scaling(const struct rga_hw *hw, u32 src_size, u32 dst_size)
>> +{
>> + if (src_size < dst_size)
>> + return src_size * hw->max_scaling_factor >= dst_size;
>> + else
>> + return dst_size * hw->max_scaling_factor >= src_size;
>> +}
>> +
>> static int vidioc_streamon(struct file *file, void *priv,
>> enum v4l2_buf_type type)
>> {
>> struct rga_ctx *ctx = file_to_rga_ctx(file);
>> const struct rga_hw *hw = ctx->rga->hw;
>>
>> + if ((V4L2_TYPE_IS_OUTPUT(type) &&
>> + v4l2_m2m_get_dst_vq(ctx->fh.m2m_ctx)->streaming) ||
>> + (V4L2_TYPE_IS_CAPTURE(type) &&
>> + v4l2_m2m_get_src_vq(ctx->fh.m2m_ctx)->streaming)) {
>> + /*
>> + * As the other side is already streaming,
>> + * check that the max scaling factor isn't exceeded.
>> + */
>> + if (!check_scaling(hw, ctx->in.pix.width, ctx->out.pix.width) ||
>> + !check_scaling(hw, ctx->in.pix.height, ctx->out.pix.height))
>> + return -EINVAL;
>> + }
>> +
>> hw->setup_cmdbuf(ctx);
>>
>> return v4l2_m2m_streamon(file, ctx->fh.m2m_ctx, type);
>> diff --git a/drivers/media/platform/rockchip/rga/rga.h b/drivers/media/platform/rockchip/rga/rga.h
>> index 93162b118d069..d02d5730b4e3b 100644
>> --- a/drivers/media/platform/rockchip/rga/rga.h
>> +++ b/drivers/media/platform/rockchip/rga/rga.h
>> @@ -152,6 +152,7 @@ struct rga_hw {
>> size_t cmdbuf_size;
>> u32 min_width, min_height;
>> u32 max_width, max_height;
>> + u8 max_scaling_factor;
>> u8 stride_alignment;
>>
>> void (*setup_cmdbuf)(struct rga_ctx *ctx);
next prev parent reply other threads:[~2026-01-09 12:19 UTC|newest]
Thread overview: 52+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-12-03 15:52 [PATCH v2 00/22] media: platform: rga: Add RGA3 support Sven Püschel
2025-12-03 15:52 ` [PATCH v2 01/22] media: dt-bindings: media: rockchip-rga: add rockchip,rk3588-rga3 Sven Püschel
2025-12-03 20:28 ` Krzysztof Kozlowski
2025-12-03 21:21 ` Sven Püschel
2025-12-03 15:52 ` [PATCH v2 02/22] media: v4l2-common: add has_alpha to v4l2_format_info Sven Püschel
2025-12-24 14:24 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 03/22] media: v4l2-common: add v4l2_fill_pixfmt_mp_aligned helper Sven Püschel
2025-12-24 14:47 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 04/22] media: rockchip: rga: use clk_bulk api Sven Püschel
2025-12-24 14:48 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 05/22] media: rockchip: rga: use stride for offset calculation Sven Püschel
2025-12-24 15:00 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 06/22] media: rockchip: rga: remove redundant rga_frame variables Sven Püschel
2025-12-24 15:03 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 07/22] media: rockchip: rga: move hw specific parts to a dedicated struct Sven Püschel
2025-12-24 15:05 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 08/22] media: rockchip: rga: move cmdbuf to rga_ctx Sven Püschel
2025-12-24 15:21 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 09/22] media: rockchip: rga: align stride to 4 bytes Sven Püschel
2025-12-24 15:26 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 10/22] media: rockchip: rga: prepare cmdbuf on streamon Sven Püschel
2025-12-24 15:29 ` Nicolas Dufresne
2026-01-07 12:00 ` Sven Püschel
2025-12-03 15:52 ` [PATCH v2 11/22] media: rockchip: rga: check scaling factor Sven Püschel
2025-12-24 15:39 ` Nicolas Dufresne
2026-01-09 12:18 ` Sven Püschel [this message]
2025-12-03 15:52 ` [PATCH v2 12/22] media: rockchip: rga: use card type to specify rga type Sven Püschel
2025-12-24 15:40 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 13/22] media: rockchip: rga: change offset to dma_addresses Sven Püschel
2025-12-24 15:41 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 14/22] media: rockchip: rga: support external iommus Sven Püschel
2025-12-24 15:50 ` Nicolas Dufresne
2026-01-07 14:19 ` Sven Püschel
2026-01-07 14:24 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 15/22] media: rockchip: rga: share the interrupt when an external iommu is used Sven Püschel
2025-12-24 15:50 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 16/22] media: rockchip: rga: remove size from rga_frame Sven Püschel
2025-12-24 15:54 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 17/22] media: rockchip: rga: remove stride " Sven Püschel
2025-12-24 15:56 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 18/22] media: rockchip: rga: move rga_fmt to rga-hw.h Sven Püschel
2025-12-24 15:59 ` Nicolas Dufresne
2026-01-07 14:52 ` Sven Püschel
2025-12-03 15:52 ` [PATCH v2 19/22] media: rockchip: rga: add feature flags Sven Püschel
2025-12-24 16:00 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 20/22] media: rockchip: rga: disable multi-core support Sven Püschel
2025-12-24 16:02 ` Nicolas Dufresne
2025-12-03 15:52 ` [PATCH v2 21/22] media: rockchip: rga: add rga3 support Sven Püschel
2025-12-24 16:34 ` Nicolas Dufresne
2026-01-21 14:40 ` Sven Püschel
2025-12-03 15:52 ` [PATCH v2 22/22] arm64: dts: rockchip: add rga3 dt nodes Sven Püschel
2025-12-05 22:36 ` [PATCH v2 00/22] media: platform: rga: Add RGA3 support Rob Herring
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=03fd04f7-629c-48cd-b498-0a1ebb67690d@pengutronix.de \
--to=s.pueschel@pengutronix.de \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=ezequiel@vanguardiasur.com.ar \
--cc=heiko@sntech.de \
--cc=jacob-chen@iotwrt.com \
--cc=kernel@pengutronix.de \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-media@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=mchehab@kernel.org \
--cc=nicolas@ndufresne.ca \
--cc=robh@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®