From: Franklin S Cooper Jr <fcooper@ti.com>
To: Oliver Hartkopp <socketcan@hartkopp.net>,
<linux-kernel@vger.kernel.org>, <devicetree@vger.kernel.org>,
<netdev@vger.kernel.org>, <linux-can@vger.kernel.org>,
<wg@grandegger.com>, <mkl@pengutronix.de>, <robh+dt@kernel.org>,
<quentin.schulz@free-electrons.com>,
<dev.kurt@vandijck-laurijssen.be>, <andrew@lunn.ch>
Subject: Re: [PATCH 1/4] can: dev: Add support for limiting configured bitrate
Date: Thu, 20 Jul 2017 10:55:51 -0500 [thread overview]
Message-ID: <055c00f5-0775-4e35-309c-0d1c8aa0afdf@ti.com> (raw)
In-Reply-To: <f45ea1b4-0f46-0002-a89b-b997f2693bb5@hartkopp.net>
Hi Oliver
On 07/20/2017 02:43 AM, Oliver Hartkopp wrote:
> Hi Franklin,
>
> On 07/20/2017 01:36 AM, Franklin S Cooper Jr wrote:
>
>> +#ifdef CONFIG_OF
>> +void of_transceiver_is_fixed(struct net_device *dev)
>> +{
>
> (..)
>
>> +}
>> +EXPORT_SYMBOL(of_transceiver_is_fixed);
>> +#endif
>
> I'm not sure about the naming here.
>
> As this is a CAN transceiver related option it should be named accordingly:
>
> E.g.
>
> can_transceiver_is_fixed
> of_can_transceiver_is_fixed
> ...
>
> Especially as it is defined in include/linux/can/dev.h
Thanks for the feedback. I'll go with of_can_transceiver_is_fixed
>
> Regards,
> Oliver
>
>
next prev parent reply other threads:[~2017-07-20 15:56 UTC|newest]
Thread overview: 13+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-07-19 23:36 [PATCH 0/4] can: Add new binding to limit bit rate used Franklin S Cooper Jr
2017-07-19 23:36 ` [PATCH 1/4] can: dev: Add support for limiting configured bitrate Franklin S Cooper Jr
2017-07-20 7:43 ` Oliver Hartkopp
2017-07-20 15:55 ` Franklin S Cooper Jr [this message]
2017-07-26 20:04 ` Kurt Van Dijck
2017-07-27 1:44 ` Franklin S Cooper Jr
2017-07-20 9:52 ` Sergei Shtylyov
2017-07-20 15:59 ` Franklin S Cooper Jr
2017-07-19 23:36 ` [PATCH 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Franklin S Cooper Jr
2017-07-20 9:45 ` Sergei Shtylyov
2017-07-19 23:36 ` [PATCH 3/4] can: m_can: Update documentation to mention new fixed transceiver binding Franklin S Cooper Jr
2017-07-24 19:50 ` Rob Herring
2017-07-19 23:36 ` [PATCH 4/4] can: m_can: Add call to of_transceiver_is_fixed Franklin S Cooper Jr
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=055c00f5-0775-4e35-309c-0d1c8aa0afdf@ti.com \
--to=fcooper@ti.com \
--cc=andrew@lunn.ch \
--cc=dev.kurt@vandijck-laurijssen.be \
--cc=devicetree@vger.kernel.org \
--cc=linux-can@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mkl@pengutronix.de \
--cc=netdev@vger.kernel.org \
--cc=quentin.schulz@free-electrons.com \
--cc=robh+dt@kernel.org \
--cc=socketcan@hartkopp.net \
--cc=wg@grandegger.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®