mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Franklin S Cooper Jr <fcooper@ti.com>
To: Sergei Shtylyov <sergei.shtylyov@cogentembedded.com>,
	<linux-kernel@vger.kernel.org>, <devicetree@vger.kernel.org>,
	<netdev@vger.kernel.org>, <linux-can@vger.kernel.org>,
	<wg@grandegger.com>, <mkl@pengutronix.de>, <robh+dt@kernel.org>,
	<quentin.schulz@free-electrons.com>,
	<dev.kurt@vandijck-laurijssen.be>, <andrew@lunn.ch>
Subject: Re: [PATCH 1/4] can: dev: Add support for limiting configured bitrate
Date: Thu, 20 Jul 2017 10:59:36 -0500	[thread overview]
Message-ID: <79d11682-83d8-f56b-4c17-8de1beec70f3@ti.com> (raw)
In-Reply-To: <b04fea5c-c47b-4643-5305-090f5f17afe1@cogentembedded.com>



On 07/20/2017 04:52 AM, Sergei Shtylyov wrote:
> Hello!
> 
> On 7/20/2017 2:36 AM, Franklin S Cooper Jr wrote:
> 
>> Various CAN or CAN-FD IP may be able to run at a faster rate than
>> what the transceiver the CAN node is connected to. This can lead to
>> unexpected errors. However, CAN transceivers typically have fixed
>> limitations and provide no means to discover these limitations at
>> runtime. Therefore, add support for a fixed-transceiver node that
>> can be reused by other CAN peripheral drivers to determine for both
>> CAN and CAN-FD what the max bitrate that can be used. If the user
>> tries to configure CAN to pass these maximum bitrates it will throw
>> an error.
>>
>> Signed-off-by: Franklin S Cooper Jr <fcooper@ti.com>
>> ---
>>   drivers/net/can/dev.c   | 48
>> ++++++++++++++++++++++++++++++++++++++++++++++++
>>   include/linux/can/dev.h |  5 +++++
>>   2 files changed, 53 insertions(+)
>>
>> diff --git a/drivers/net/can/dev.c b/drivers/net/can/dev.c
>> index 365a8cc..fbab87d 100644
>> --- a/drivers/net/can/dev.c
>> +++ b/drivers/net/can/dev.c
> [...]
>> @@ -814,6 +830,38 @@ int open_candev(struct net_device *dev)
>>   }
>>   EXPORT_SYMBOL_GPL(open_candev);
>>   +#ifdef CONFIG_OF
>> +void of_transceiver_is_fixed(struct net_device *dev)
> 
>    Strange name for a *void* function...

Ok I see what you mean since I'm not actually returning anything. I'll
go with of_can_transceiver_fixed based on your comment also Oliver's
suggestion.

>    Also, I think 'struct net_device *' variables are typically called
> 'ndev'.

All other functions within this file uses struct net_device *dev. So I'm
just following the style currently used.

> 
>> +{
>> +    struct device_node *dn;
>> +    struct can_priv *priv = netdev_priv(dev);
>> +    u32 max_frequency;
>> +    struct device_node *np;
>> +
>> +    np = dev->dev.parent->of_node;
>> +
>> +    /* New binding */
>> +    dn = of_get_child_by_name(np, "fixed-transceiver");
>> +    if (!dn)
>> +        return;
>> +
>> +    of_property_read_u32(dn, "max-arbitration-speed", &max_frequency);
> 
>    In case this function fails, 'max_frequency' will have no value --
> you'd better initialize it...

Thanks for catching this. Will fix.

> 
>> +
>> +    if (max_frequency > 0)
>> +        priv->max_trans_arbitration_speed = max_frequency;
>> +    else
>> +        priv->max_trans_arbitration_speed = -1;
>> +
>> +    of_property_read_u32(dn, "max-data-speed", &max_frequency);
> 
>    Again, when that function fails, the variable will keep the value
> from the previous call...

Will fix.

> 
> [...]
> 
> MBR, Sergei

  reply	other threads:[~2017-07-20 15:59 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-07-19 23:36 [PATCH 0/4] can: Add new binding to limit bit rate used Franklin S Cooper Jr
2017-07-19 23:36 ` [PATCH 1/4] can: dev: Add support for limiting configured bitrate Franklin S Cooper Jr
2017-07-20  7:43   ` Oliver Hartkopp
2017-07-20 15:55     ` Franklin S Cooper Jr
2017-07-26 20:04       ` Kurt Van Dijck
2017-07-27  1:44         ` Franklin S Cooper Jr
2017-07-20  9:52   ` Sergei Shtylyov
2017-07-20 15:59     ` Franklin S Cooper Jr [this message]
2017-07-19 23:36 ` [PATCH 2/4] can: fixed-transceiver: Add documentation for CAN fixed transceiver bindings Franklin S Cooper Jr
2017-07-20  9:45   ` Sergei Shtylyov
2017-07-19 23:36 ` [PATCH 3/4] can: m_can: Update documentation to mention new fixed transceiver binding Franklin S Cooper Jr
2017-07-24 19:50   ` Rob Herring
2017-07-19 23:36 ` [PATCH 4/4] can: m_can: Add call to of_transceiver_is_fixed Franklin S Cooper Jr

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=79d11682-83d8-f56b-4c17-8de1beec70f3@ti.com \
    --to=fcooper@ti.com \
    --cc=andrew@lunn.ch \
    --cc=dev.kurt@vandijck-laurijssen.be \
    --cc=devicetree@vger.kernel.org \
    --cc=linux-can@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mkl@pengutronix.de \
    --cc=netdev@vger.kernel.org \
    --cc=quentin.schulz@free-electrons.com \
    --cc=robh+dt@kernel.org \
    --cc=sergei.shtylyov@cogentembedded.com \
    --cc=wg@grandegger.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®