From: James Morse <james.morse@arm.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
x86@kernel.org, linux-kernel@vger.kernel.org
Cc: Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
shameerali.kolothum.thodi@huawei.com,
D Scott Phillips OS <scott@os.amperecomputing.com>,
carl@os.amperecomputing.com, lcherian@marvell.com,
bobo.shaobowang@huawei.com, tan.shaopeng@fujitsu.com,
baolin.wang@linux.alibaba.com,
Jamie Iles <quic_jiles@quicinc.com>,
Xin Hao <xhao@linux.alibaba.com>,
peternewman@google.com, dfustini@baylibre.com,
amitsinght@marvell.com, David Hildenbrand <david@redhat.com>,
Rex Nie <rex.nie@jaguarmicro.com>,
Dave Martin <dave.martin@arm.com>, Koba Ko <kobak@nvidia.com>,
Shanker Donthineni <sdonthineni@nvidia.com>
Subject: Re: [PATCH v6 37/42] x86/restrl: Expand the width of dom_id by replacing mon_data_bits
Date: Fri, 28 Feb 2025 19:53:21 +0000 [thread overview]
Message-ID: <0aff0325-e410-4b14-aa69-adfabd0ac0b0@arm.com> (raw)
In-Reply-To: <bf7e9acd-01f0-4011-80e3-c11c0298fd73@intel.com>
Hi Reinette,
On 20/02/2025 05:40, Reinette Chatre wrote:
> On 2/7/25 10:18 AM, James Morse wrote:
>> MPAM platforms retrieve the cache-id property from the ACPI PPTT table.
>> The cache-id field is 32 bits wide. Under resctrl, the cache-id becomes
>> the domain-id, and is packed into the mon_data_bits union bitfield.
>> The width of cache-id in this field is 14 bits.
>>
>> Expanding the union would break 32bit x86 platforms as this union is
>> stored as the kernfs kn->priv pointer. This saved allocating memory
>> for the priv data storage.
>>
>> The firmware on MPAM platforms have used the PPTT cache-id field to
>> expose the interconnect's id for the cache, which is sparse and uses
>> more than 14 bits. Use of this id is to enable PCIe direct cache
>> injection hints. Using this feature with VFIO means the value provided
>> by the ACPI table should be exposed to user-space.
>>
>> To support cache-id values greater than 14 bits, convert the
>> mon_data_bits union to a structure. This is allocated when the kernfs
>> file is created, and free'd when the monitor directory is rmdir'd.
>> Readers and writers must hold the rdtgroup_mutex, and readers should
>> check for a NULL pointer to protect against an open file preventing
>> the kernfs file from being free'd immediately after the rmdir call.
> The last sentence is difficult to parse and took me many reads. I see
> two major parts to this statement and if I understand correctly the current
> implementation combined with this patch does not support either.
> (a) "checking for a NULL pointer from readers"
> The reader is rdtgroup_mondata_show() and it starts by calling:
> rdtgrp = rdtgroup_kn_lock_live(of->kn);
> As I understand, on return of rdtgroup_kn_lock_live() the kernfs node
> "of->kn" may no longer exist. This seems to be an issue with current code
> also.
> Considering this, it seems to me that checking if of->kn->priv is NULL
> may be futile if of->kn may no longer exist.
Certainly true.
Because the lifetime is different to the existing pointer-abuse version, I just added the
checks to be on the safe side.
I'll rip this out.
> I think this also needs a reference to the data needed by the file or
> the data needs to be stashed away before the call to
> kernfs_break_active_protection().
I've tried to hit this problem, and been unable. I'm happy to write it off as theoretical.
In particular:
* rmdir a control group while holding the mbm_local_bytes file open for reading. Any read
after the parent control group has been destroyed gets -ENODEV, even though though
/proc/<pid>/fd shows the fd as open for reading. The kernel in question had lockdep and
kasan enabled)
* take all the CPUs in a domain offline while holding the mbm_local_bytes file open for
reading. Again, read attempts get -ENODEV.
> (b) "...being free'd immediately after the rmdir call"
> I believe this refers to expectation that one task may have the file open
> while another removes the resource group directory ("rmdir") with the
> assumption that the associated struct mon_data is removed during handling
> of rmdir.
This is what I was worried about - and it seemed worth chucking in a NULL check just in
case. Trying a bit harder to hit it - it now seems theoretical.
> In this implementation the monitoring data file's struct mon_data
> is only removed when a monitoring domain goes offline.
> That is, when the
> resource group remains intact while the monitoring data files associated with
> one domain is removed (for example when all CPUs associated with that domain
> goes offline). The "rmdir" to remove a resource group does not call this code
> (mon_rmdir_one_subdir()), nor does the cleanup of the default resource group's
> "kn_mondata".
Huh, its the path via user-space calling rmdir() that I was worried about. I hadn't
spotted that there are two of these and they aren't joined up!
This would leak the priv pointer when the user-space path via rmdir() just leaves the
cleanup to kernfs.
Fixing this produces even more spaghetti as domain-offline manipulates one domain in all
rdtgroup, whereas rmdir manipulates all domains in on rdtgroup. Its going to be noisy to
merge these two paths.
A simpler approach is to use the event kn->priv pointers in the default control group as
the canonical copy, which also saves memory. For mbm_total in a domain, every control and
monitor group has the same values in struct mon_data_bits - the RMID is found by walking
up the tree to find the struct rdtgroup.
As user-space can't rmdir the default control group, we only need to free it for
domain-offline, when we know all the files for that domain are going to be removed - which
we can rely on to avoid doing it in a particular order.
> I am trying to get a handle on the different lifetimes and if I understand
> correctly this implementation does not attempt to keep the struct mon_data
> accessible as long as the file is open.
No, but I think that concern is theoretical...
> I do not think I've discovered all the implications of this yet.
Thanks,
James
next prev parent reply other threads:[~2025-02-28 19:53 UTC|newest]
Thread overview: 135+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-07 18:17 [PATCH v6 00/42] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2025-02-07 18:17 ` [PATCH v6 01/42] x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no monitors James Morse
2025-02-07 18:17 ` [PATCH v6 02/42] x86/resctrl: Add a helper to avoid reaching into the arch code resource list James Morse
2025-02-27 20:24 ` Moger, Babu
2025-02-28 19:53 ` James Morse
2025-02-07 18:17 ` [PATCH v6 03/42] x86/resctrl: Remove fflags from struct rdt_resource James Morse
2025-02-19 21:48 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 04/42] x86/resctrl: Use schema type to determine how to parse schema values James Morse
2025-02-19 21:52 ` Reinette Chatre
2025-02-28 19:50 ` James Morse
2025-02-07 18:17 ` [PATCH v6 05/42] x86/resctrl: Use schema type to determine the schema format string James Morse
2025-02-07 18:17 ` [PATCH v6 06/42] x86/resctrl: Remove data_width and the tabular format James Morse
2025-02-19 21:56 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 07/42] x86/resctrl: Add max_bw to struct resctrl_membw James Morse
2025-02-19 22:14 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 08/42] x86/resctrl: Generate default_ctrl instead of sharing it James Morse
2025-02-19 22:54 ` Reinette Chatre
2025-02-28 19:55 ` James Morse
2025-02-07 18:17 ` [PATCH v6 09/42] x86/resctrl: Add helper for setting CPU default properties James Morse
2025-02-19 23:09 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 10/42] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid() James Morse
2025-02-19 23:13 ` Reinette Chatre
2025-02-27 20:25 ` Moger, Babu
2025-02-28 19:54 ` James Morse
2025-02-07 18:17 ` [PATCH v6 11/42] x86/resctrl: Expose resctrl fs's init function to the rest of the kernel James Morse
2025-02-19 23:15 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 12/42] x86/resctrl: Move rdt_find_domain() to be visible to arch and fs code James Morse
2025-02-19 23:24 ` Reinette Chatre
2025-02-20 10:58 ` Catalin Marinas
2025-02-20 16:01 ` Reinette Chatre
2025-02-27 22:44 ` Fenghua Yu
2025-02-28 19:56 ` James Morse
2025-02-07 18:17 ` [PATCH v6 13/42] x86/resctrl: Move resctrl types to a separate header James Morse
2025-02-19 23:29 ` Reinette Chatre
2025-02-28 19:51 ` James Morse
2025-02-07 18:17 ` [PATCH v6 14/42] x86/resctrl: Add an arch helper to reset one resource James Morse
2025-02-19 23:32 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 15/42] x86/resctrl: Move monitor exit work to a resctrl exit call James Morse
2025-02-19 23:38 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 16/42] x86/resctrl: Move monitor init work to a resctrl init call James Morse
2025-02-19 23:43 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 17/42] x86/resctrl: Rewrite and move the for_each_*_rdt_resource() walkers James Morse
2025-02-19 23:47 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 18/42] x86/resctrl: Move the is_mbm_*_enabled() helpers to asm/resctrl.h James Morse
2025-02-19 23:55 ` Reinette Chatre
2025-02-28 19:55 ` James Morse
2025-02-07 18:18 ` [PATCH v6 19/42] x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC James Morse
2025-02-20 0:13 ` Reinette Chatre
2025-02-28 19:56 ` James Morse
2025-02-07 18:18 ` [PATCH v6 20/42] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers James Morse
2025-02-20 0:37 ` Reinette Chatre
2025-02-27 20:26 ` Moger, Babu
2025-02-28 19:54 ` James Morse
2025-02-07 18:18 ` [PATCH v6 21/42] x86/resctrl: Move mba_mbps_default_event init to filesystem code James Morse
2025-02-20 0:42 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 22/42] x86/resctrl: Move mbm_cfg_mask to struct rdt_resource James Morse
2025-02-20 0:45 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 23/42] x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions James Morse
2025-02-20 0:53 ` Reinette Chatre
2025-02-28 19:57 ` James Morse
2025-02-07 18:18 ` [PATCH v6 24/42] x86/resctrl: Allow an architecture to disable pseudo lock James Morse
2025-02-20 0:56 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 25/42] x86/resctrl: Make prefetch_disable_bits belong to the arch code James Morse
2025-02-20 0:59 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 26/42] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr James Morse
2025-02-20 1:03 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 27/42] x86/resctrl: Move RFTYPE flags to be managed by resctrl James Morse
2025-02-20 1:17 ` Reinette Chatre
2025-02-28 19:56 ` James Morse
2025-02-07 18:18 ` [PATCH v6 28/42] x86/resctrl: Handle throttle_mode for SMBA resources James Morse
2025-02-20 1:20 ` Reinette Chatre
2025-02-28 19:55 ` James Morse
2025-02-07 18:18 ` [PATCH v6 29/42] x86/resctrl: Move get_config_index() to a header James Morse
2025-02-20 1:27 ` Reinette Chatre
2025-02-28 19:51 ` James Morse
2025-03-01 2:28 ` Reinette Chatre
2025-03-06 19:28 ` James Morse
2025-03-06 22:52 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 30/42] x86/resctrl: Claim get_{mon,ctrl}_domain_from_cpu() helpers for resctrl James Morse
2025-02-20 4:08 ` Reinette Chatre
2025-02-27 23:05 ` Fenghua Yu
2025-02-28 19:53 ` James Morse
2025-02-07 18:18 ` [PATCH v6 31/42] x86/resctrl: Remove the limit on the number of CLOSID James Morse
2025-02-20 4:21 ` Reinette Chatre
2025-02-28 19:53 ` James Morse
2025-02-07 18:18 ` [PATCH v6 32/42] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2025-02-20 4:26 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 33/42] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2025-02-20 4:42 ` Reinette Chatre
2025-02-28 19:54 ` James Morse
2025-03-01 2:35 ` Reinette Chatre
2025-03-06 19:28 ` James Morse
2025-03-07 4:47 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 34/42] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2025-02-20 4:46 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 35/42] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2025-02-20 4:48 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 36/42] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2025-02-20 4:50 ` Reinette Chatre
2025-02-27 20:26 ` Moger, Babu
2025-02-28 19:55 ` James Morse
2025-02-28 20:59 ` Luck, Tony
2025-02-07 18:18 ` [PATCH v6 37/42] x86/restrl: Expand the width of dom_id by replacing mon_data_bits James Morse
2025-02-20 5:40 ` Reinette Chatre
2025-02-28 19:53 ` James Morse [this message]
2025-02-07 18:18 ` [PATCH v6 38/42] x86/resctrl: Remove a newline to avoid confusing the code move script James Morse
2025-02-20 5:42 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 39/42] x86/resctrl: Split trace.h James Morse
2025-02-20 5:45 ` Reinette Chatre
2025-02-25 4:36 ` Fenghua Yu
2025-02-28 19:53 ` James Morse
2025-02-27 23:16 ` Fenghua Yu
2025-02-28 19:53 ` James Morse
2025-02-07 18:18 ` [PATCH v6 40/42] fs/resctrl: Add boiler plate for external resctrl code James Morse
2025-02-20 5:54 ` Reinette Chatre
2025-02-28 19:54 ` James Morse
2025-02-07 18:18 ` [PATCH v6 41/42] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2025-02-20 6:00 ` Reinette Chatre
2025-02-28 19:57 ` James Morse
2025-02-07 18:18 ` [PATCH v6 42/42] x86/resctrl: Add python script to move resctrl code to /fs/resctrl James Morse
2025-02-20 6:10 ` Reinette Chatre
2025-02-25 16:16 ` Reinette Chatre
2025-02-28 19:57 ` James Morse
2025-02-25 5:02 ` Fenghua Yu
2025-02-28 19:57 ` James Morse
2025-02-28 20:06 ` Moger, Babu
2025-02-10 17:24 ` [PATCH v6 00/42] x86/resctrl: Move the resctrl filesystem " Reinette Chatre
2025-02-11 14:36 ` Peter Newman
2025-02-11 18:37 ` James Morse
2025-02-12 15:24 ` Moger, Babu
2025-02-11 18:37 ` James Morse
2025-02-11 19:29 ` Reinette Chatre
2025-02-12 16:04 ` Dave Martin
2025-02-28 1:15 ` Shaopeng Tan (Fujitsu)
2025-02-28 19:55 ` James Morse
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=0aff0325-e410-4b14-aa69-adfabd0ac0b0@arm.com \
--to=james.morse@arm.com \
--cc=Babu.Moger@amd.com \
--cc=amitsinght@marvell.com \
--cc=baolin.wang@linux.alibaba.com \
--cc=bobo.shaobowang@huawei.com \
--cc=bp@alien8.de \
--cc=carl@os.amperecomputing.com \
--cc=dave.martin@arm.com \
--cc=david@redhat.com \
--cc=dfustini@baylibre.com \
--cc=hpa@zytor.com \
--cc=kobak@nvidia.com \
--cc=lcherian@marvell.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peternewman@google.com \
--cc=quic_jiles@quicinc.com \
--cc=reinette.chatre@intel.com \
--cc=rex.nie@jaguarmicro.com \
--cc=scott@os.amperecomputing.com \
--cc=sdonthineni@nvidia.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=tan.shaopeng@fujitsu.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
--cc=xhao@linux.alibaba.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®