mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Fenghua Yu <fenghuay@nvidia.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
	Catalin Marinas <catalin.marinas@arm.com>
Cc: James Morse <james.morse@arm.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
	H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
	shameerali.kolothum.thodi@huawei.com,
	D Scott Phillips OS <scott@os.amperecomputing.com>,
	carl@os.amperecomputing.com, lcherian@marvell.com,
	bobo.shaobowang@huawei.com, tan.shaopeng@fujitsu.com,
	baolin.wang@linux.alibaba.com,
	Jamie Iles <quic_jiles@quicinc.com>,
	Xin Hao <xhao@linux.alibaba.com>,
	peternewman@google.com, dfustini@baylibre.com,
	amitsinght@marvell.com, David Hildenbrand <david@redhat.com>,
	Rex Nie <rex.nie@jaguarmicro.com>,
	Dave Martin <dave.martin@arm.com>, Koba Ko <kobak@nvidia.com>,
	Shanker Donthineni <sdonthineni@nvidia.com>
Subject: Re: [PATCH v6 12/42] x86/resctrl: Move rdt_find_domain() to be visible to arch and fs code
Date: Thu, 27 Feb 2025 14:44:40 -0800	[thread overview]
Message-ID: <d46cdf05-828c-4089-a418-3fb1b47f78e9@nvidia.com> (raw)
In-Reply-To: <0672ad74-782e-48b9-8591-7e0bdec84845@intel.com>

Hi, James, Reinette,

On 2/20/25 08:01, Reinette Chatre wrote:
> Hi Catalin,
>
> On 2/20/25 2:58 AM, Catalin Marinas wrote:
>> On Wed, Feb 19, 2025 at 03:24:06PM -0800, Reinette Chatre wrote:
>>> On 2/7/25 10:17 AM, James Morse wrote:
>>>> rdt_find_domain() finds a domain given a resource and a cache-id.
>>>> This is used by both the architecture code and the filesystem code.
>>>>
>>>> After the filesystem code moves to live in /fs/, this helper will no
>>>> longer be visible.
>>>>
>>>> Move it to the global header file. As its now globally visible, and
>>>> has only a handful of callers, swap the 'rdt' for 'resctrl'.
>> [...]
>>>> --- a/include/linux/resctrl.h
>>>> +++ b/include/linux/resctrl.h
>>>> @@ -372,6 +372,40 @@ static inline void resctrl_arch_rmid_read_context_check(void)
>>>>   		might_sleep();
>>>>   }
>>>>   
>>>> +/**
>>>> + * resctrl_find_domain() - Search for a domain id in a resource domain list.
>>>> + * @h:		The domain list to search.
>>>> + * @id:		The domain id to search for.
>>>> + * @pos:	A pointer to position in the list id should be inserted.
>>>> + *
>>>> + * Search the domain list to find the domain id. If the domain id is
>>>> + * found, return the domain. NULL otherwise.  If the domain id is not
>>>> + * found (and NULL returned) then the first domain with id bigger than
>>>> + * the input id can be returned to the caller via @pos.
>>>> + */
>>>> +static inline struct rdt_domain_hdr *resctrl_find_domain(struct list_head *h,
>>>> +							 int id,
>>>> +							 struct list_head **pos)
>>> Could you please provide a motivation for why this needs to be inline now?
>> It's in a header now, to avoid the compiler complaining about unused
>> static functions wherever this file is included. The alternative is a
>> prototype declaration and the actual implementation in a .c file.
> resctrl_find_domain() is currently in a .c file (arch/x86/kernel/cpu/resctrl/core.c)
> with a prototype declaration (in arch/x86/kernel/cpu/resctrl/internal.h). This patch
> switches resctrl_find_domain() to be inline without a motivation.
>
> After a fresh reading of "The inline disease" in Documentation/process/coding-style.rst
> I do see a few red flags related to making this function inline. The function is certainly
> larger than the rule of thumb of "3 lines" and considering the number of call sites I do
> not see how bloating the kernel is justified.

Agree with Reinette.


Plus, resctrl_find_domain() is only called during setup and CPU hot plug 
which are not run time paths and won't impact run time performance. 
inline doesn't help the performance but makes the kernel bigger.

I can see the function is moved from arch/x86/kernel/cpu/resctrl/core.c 
and there is no corresponding fs/resctrl/core.c.

If your motivation is to avoid fs/resctrl/core.c (which is much small) 
to have one less file and just host the function in .h, please consider 
to create fs/resctrl/core.c and put the function in it and declare it in 
the .h file. So there won't be inline issue any more.

>> (drive-by comment, I don't really understand this subsystem to make a
>> meaningful contribution)
>>
> Thanks for taking a look. The idea is not unique to resctrl.
>
> Reinette
>
Thanks.


-Fenghua


  reply	other threads:[~2025-02-27 22:44 UTC|newest]

Thread overview: 135+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-02-07 18:17 [PATCH v6 00/42] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2025-02-07 18:17 ` [PATCH v6 01/42] x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no monitors James Morse
2025-02-07 18:17 ` [PATCH v6 02/42] x86/resctrl: Add a helper to avoid reaching into the arch code resource list James Morse
2025-02-27 20:24   ` Moger, Babu
2025-02-28 19:53     ` James Morse
2025-02-07 18:17 ` [PATCH v6 03/42] x86/resctrl: Remove fflags from struct rdt_resource James Morse
2025-02-19 21:48   ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 04/42] x86/resctrl: Use schema type to determine how to parse schema values James Morse
2025-02-19 21:52   ` Reinette Chatre
2025-02-28 19:50     ` James Morse
2025-02-07 18:17 ` [PATCH v6 05/42] x86/resctrl: Use schema type to determine the schema format string James Morse
2025-02-07 18:17 ` [PATCH v6 06/42] x86/resctrl: Remove data_width and the tabular format James Morse
2025-02-19 21:56   ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 07/42] x86/resctrl: Add max_bw to struct resctrl_membw James Morse
2025-02-19 22:14   ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 08/42] x86/resctrl: Generate default_ctrl instead of sharing it James Morse
2025-02-19 22:54   ` Reinette Chatre
2025-02-28 19:55     ` James Morse
2025-02-07 18:17 ` [PATCH v6 09/42] x86/resctrl: Add helper for setting CPU default properties James Morse
2025-02-19 23:09   ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 10/42] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid() James Morse
2025-02-19 23:13   ` Reinette Chatre
2025-02-27 20:25   ` Moger, Babu
2025-02-28 19:54     ` James Morse
2025-02-07 18:17 ` [PATCH v6 11/42] x86/resctrl: Expose resctrl fs's init function to the rest of the kernel James Morse
2025-02-19 23:15   ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 12/42] x86/resctrl: Move rdt_find_domain() to be visible to arch and fs code James Morse
2025-02-19 23:24   ` Reinette Chatre
2025-02-20 10:58     ` Catalin Marinas
2025-02-20 16:01       ` Reinette Chatre
2025-02-27 22:44         ` Fenghua Yu [this message]
2025-02-28 19:56         ` James Morse
2025-02-07 18:17 ` [PATCH v6 13/42] x86/resctrl: Move resctrl types to a separate header James Morse
2025-02-19 23:29   ` Reinette Chatre
2025-02-28 19:51     ` James Morse
2025-02-07 18:17 ` [PATCH v6 14/42] x86/resctrl: Add an arch helper to reset one resource James Morse
2025-02-19 23:32   ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 15/42] x86/resctrl: Move monitor exit work to a resctrl exit call James Morse
2025-02-19 23:38   ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 16/42] x86/resctrl: Move monitor init work to a resctrl init call James Morse
2025-02-19 23:43   ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 17/42] x86/resctrl: Rewrite and move the for_each_*_rdt_resource() walkers James Morse
2025-02-19 23:47   ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 18/42] x86/resctrl: Move the is_mbm_*_enabled() helpers to asm/resctrl.h James Morse
2025-02-19 23:55   ` Reinette Chatre
2025-02-28 19:55     ` James Morse
2025-02-07 18:18 ` [PATCH v6 19/42] x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC James Morse
2025-02-20  0:13   ` Reinette Chatre
2025-02-28 19:56     ` James Morse
2025-02-07 18:18 ` [PATCH v6 20/42] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers James Morse
2025-02-20  0:37   ` Reinette Chatre
2025-02-27 20:26   ` Moger, Babu
2025-02-28 19:54     ` James Morse
2025-02-07 18:18 ` [PATCH v6 21/42] x86/resctrl: Move mba_mbps_default_event init to filesystem code James Morse
2025-02-20  0:42   ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 22/42] x86/resctrl: Move mbm_cfg_mask to struct rdt_resource James Morse
2025-02-20  0:45   ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 23/42] x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions James Morse
2025-02-20  0:53   ` Reinette Chatre
2025-02-28 19:57     ` James Morse
2025-02-07 18:18 ` [PATCH v6 24/42] x86/resctrl: Allow an architecture to disable pseudo lock James Morse
2025-02-20  0:56   ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 25/42] x86/resctrl: Make prefetch_disable_bits belong to the arch code James Morse
2025-02-20  0:59   ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 26/42] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr James Morse
2025-02-20  1:03   ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 27/42] x86/resctrl: Move RFTYPE flags to be managed by resctrl James Morse
2025-02-20  1:17   ` Reinette Chatre
2025-02-28 19:56     ` James Morse
2025-02-07 18:18 ` [PATCH v6 28/42] x86/resctrl: Handle throttle_mode for SMBA resources James Morse
2025-02-20  1:20   ` Reinette Chatre
2025-02-28 19:55     ` James Morse
2025-02-07 18:18 ` [PATCH v6 29/42] x86/resctrl: Move get_config_index() to a header James Morse
2025-02-20  1:27   ` Reinette Chatre
2025-02-28 19:51     ` James Morse
2025-03-01  2:28       ` Reinette Chatre
2025-03-06 19:28         ` James Morse
2025-03-06 22:52           ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 30/42] x86/resctrl: Claim get_{mon,ctrl}_domain_from_cpu() helpers for resctrl James Morse
2025-02-20  4:08   ` Reinette Chatre
2025-02-27 23:05     ` Fenghua Yu
2025-02-28 19:53     ` James Morse
2025-02-07 18:18 ` [PATCH v6 31/42] x86/resctrl: Remove the limit on the number of CLOSID James Morse
2025-02-20  4:21   ` Reinette Chatre
2025-02-28 19:53     ` James Morse
2025-02-07 18:18 ` [PATCH v6 32/42] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2025-02-20  4:26   ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 33/42] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2025-02-20  4:42   ` Reinette Chatre
2025-02-28 19:54     ` James Morse
2025-03-01  2:35       ` Reinette Chatre
2025-03-06 19:28         ` James Morse
2025-03-07  4:47           ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 34/42] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2025-02-20  4:46   ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 35/42] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2025-02-20  4:48   ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 36/42] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2025-02-20  4:50   ` Reinette Chatre
2025-02-27 20:26   ` Moger, Babu
2025-02-28 19:55     ` James Morse
2025-02-28 20:59       ` Luck, Tony
2025-02-07 18:18 ` [PATCH v6 37/42] x86/restrl: Expand the width of dom_id by replacing mon_data_bits James Morse
2025-02-20  5:40   ` Reinette Chatre
2025-02-28 19:53     ` James Morse
2025-02-07 18:18 ` [PATCH v6 38/42] x86/resctrl: Remove a newline to avoid confusing the code move script James Morse
2025-02-20  5:42   ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 39/42] x86/resctrl: Split trace.h James Morse
2025-02-20  5:45   ` Reinette Chatre
2025-02-25  4:36     ` Fenghua Yu
2025-02-28 19:53       ` James Morse
2025-02-27 23:16   ` Fenghua Yu
2025-02-28 19:53     ` James Morse
2025-02-07 18:18 ` [PATCH v6 40/42] fs/resctrl: Add boiler plate for external resctrl code James Morse
2025-02-20  5:54   ` Reinette Chatre
2025-02-28 19:54     ` James Morse
2025-02-07 18:18 ` [PATCH v6 41/42] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2025-02-20  6:00   ` Reinette Chatre
2025-02-28 19:57     ` James Morse
2025-02-07 18:18 ` [PATCH v6 42/42] x86/resctrl: Add python script to move resctrl code to /fs/resctrl James Morse
2025-02-20  6:10   ` Reinette Chatre
2025-02-25 16:16     ` Reinette Chatre
2025-02-28 19:57       ` James Morse
2025-02-25  5:02   ` Fenghua Yu
2025-02-28 19:57     ` James Morse
2025-02-28 20:06     ` Moger, Babu
2025-02-10 17:24 ` [PATCH v6 00/42] x86/resctrl: Move the resctrl filesystem " Reinette Chatre
2025-02-11 14:36   ` Peter Newman
2025-02-11 18:37     ` James Morse
2025-02-12 15:24     ` Moger, Babu
2025-02-11 18:37   ` James Morse
2025-02-11 19:29     ` Reinette Chatre
2025-02-12 16:04       ` Dave Martin
2025-02-28  1:15 ` Shaopeng Tan (Fujitsu)
2025-02-28 19:55   ` James Morse

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=d46cdf05-828c-4089-a418-3fb1b47f78e9@nvidia.com \
    --to=fenghuay@nvidia.com \
    --cc=Babu.Moger@amd.com \
    --cc=amitsinght@marvell.com \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=bobo.shaobowang@huawei.com \
    --cc=bp@alien8.de \
    --cc=carl@os.amperecomputing.com \
    --cc=catalin.marinas@arm.com \
    --cc=dave.martin@arm.com \
    --cc=david@redhat.com \
    --cc=dfustini@baylibre.com \
    --cc=hpa@zytor.com \
    --cc=james.morse@arm.com \
    --cc=kobak@nvidia.com \
    --cc=lcherian@marvell.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peternewman@google.com \
    --cc=quic_jiles@quicinc.com \
    --cc=reinette.chatre@intel.com \
    --cc=rex.nie@jaguarmicro.com \
    --cc=scott@os.amperecomputing.com \
    --cc=sdonthineni@nvidia.com \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=tan.shaopeng@fujitsu.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    --cc=xhao@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®