From: James Morse <james.morse@arm.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
x86@kernel.org, linux-kernel@vger.kernel.org
Cc: Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
shameerali.kolothum.thodi@huawei.com,
D Scott Phillips OS <scott@os.amperecomputing.com>,
carl@os.amperecomputing.com, lcherian@marvell.com,
bobo.shaobowang@huawei.com, tan.shaopeng@fujitsu.com,
baolin.wang@linux.alibaba.com,
Jamie Iles <quic_jiles@quicinc.com>,
Xin Hao <xhao@linux.alibaba.com>,
peternewman@google.com, dfustini@baylibre.com,
amitsinght@marvell.com, David Hildenbrand <david@redhat.com>,
Rex Nie <rex.nie@jaguarmicro.com>,
Dave Martin <dave.martin@arm.com>, Koba Ko <kobak@nvidia.com>,
Shanker Donthineni <sdonthineni@nvidia.com>,
Shaopeng Tan <tan.shaopeng@jp.fujitsu.com>,
Tony Luck <tony.luck@intel.com>
Subject: Re: [PATCH v6 42/42] x86/resctrl: Add python script to move resctrl code to /fs/resctrl
Date: Fri, 28 Feb 2025 19:57:35 +0000 [thread overview]
Message-ID: <9d4bc823-28d2-4ab4-a573-894109b51845@arm.com> (raw)
In-Reply-To: <545e4e79-e309-4bda-9a70-204d83749308@intel.com>
Hi Reinette,
On 25/02/2025 16:16, Reinette Chatre wrote:
> On 2/19/25 10:10 PM, Reinette Chatre wrote:
>> On 2/7/25 10:18 AM, James Morse wrote:
>>> To support more than one architecture resctrl needs to move from arch/x86
>>> to live under fs. Moving all the code breaks any series on the mailing
>>> list, so needs scheduling carefully.
>>>
>>> Maintaining the patch that moves all this code has proved labour intensive.
>>> It's also near-impossible to review that no inadvertent changes have
>>> crept in.
>>>
>>> To solve these problems, temporarily add a hacky python program that
>>> lists all the functions that should move, and those that should stay.
>>>
>>> No attempt to parse C code is made, this thing tries to name 'blocks'
>>> based on hueristics about the kernel coding style. It's fragile, but
>>
>> (heuristics)
>>
>>> good enough for its single use here.
>>>
>>> This only exists to show I have nothing up my sleeve.
>>> I don't suggested this gets merged.
>>>
>>> The patch this script generaets has the following corner cases:
>> (generates)
>>
>>> * The original files are regenerated, which will add newlines that are
>>> not present in the original file.
>>> * An trace-point header file the only contains boiler-plate is created
>>> in the arch and filesystem code. The parser doesn't know how to remove
>>> the includes for these - but its easy to 'keep' the file contents on
>>> the correct side. A follow-up patch will remove these files and their
>>> includes.
>>
>> Related to the tracepoints I also noticed that there are some leftover
>> tracing defines in files that no longer make use of tracing.
>> For example, arch/x86/kernel/cpu/resctrl/monitor.c contains:
>> #define CREATE_TRACE_POINTS
>> #include monitor_trace.h
>>
>> and fs/resctrl/pseudo_lock.c contains:
>> #define CREATE_TRACE_POINTS
>> #include "pseudo_lock_trace.h"
>>
>> I assumed this will also be removed in this follow-up patch?
Yup:
https://web.git.kernel.org/pub/scm/linux/kernel/git/morse/linux.git/commit/?h=mpam/snapshot/v6.14-rc1&id=3d0430324a0c7e7ad765140f9e78a9a312a13573
I'll include this patch in v7, you found a case where its not as harmless as I thought.
>>> * asm/cpu_device_id.h and a relative path for 'X86_CONFIG()' are kept
>>> in the filesystem code to ensure x86 builds. A follow-up patch will
>>> remove these.
>>> * This script doesn't know how to move the documentation, and update the
>>> links in comments. A follow-up patch does this.
>>
>> One unexpected thing I noticed is that fs/resctr/internal.h contains:
>> #ifndef _ASM_X86_RESCTRL_INTERNAL_H
>> #define _ASM_X86_RESCTRL_INTERNAL_H
>> ...
>> #endif /* _ASM_X86_RESCTRL_INTERNAL_H */
That's a new one - I'll add a follow-up patch to change those.
> It looks like another item for this list of "corner cases" is that the
> #include of all files need to be reviewed after the code move. There are
> functions depending on a particular #include that are moved out of the .c
> file but the (no longer needed) #include remains.
Indeed, that is one of the followups that I'll include in v7.
https://web.git.kernel.org/pub/scm/linux/kernel/git/morse/linux.git/commit/?h=mpam/snapshot/v6.14-rc1&id=9e2bd53f5e2b33fef69db1aae2dd7aeeaf1dd24c
I suggest all these get merged into the patch that moves the code - but I'll post them
separately in case anyone is interested in regenerating the patch using this script.
Thanks,
James
next prev parent reply other threads:[~2025-02-28 19:57 UTC|newest]
Thread overview: 135+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-02-07 18:17 [PATCH v6 00/42] x86/resctrl: Move the resctrl filesystem " James Morse
2025-02-07 18:17 ` [PATCH v6 01/42] x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no monitors James Morse
2025-02-07 18:17 ` [PATCH v6 02/42] x86/resctrl: Add a helper to avoid reaching into the arch code resource list James Morse
2025-02-27 20:24 ` Moger, Babu
2025-02-28 19:53 ` James Morse
2025-02-07 18:17 ` [PATCH v6 03/42] x86/resctrl: Remove fflags from struct rdt_resource James Morse
2025-02-19 21:48 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 04/42] x86/resctrl: Use schema type to determine how to parse schema values James Morse
2025-02-19 21:52 ` Reinette Chatre
2025-02-28 19:50 ` James Morse
2025-02-07 18:17 ` [PATCH v6 05/42] x86/resctrl: Use schema type to determine the schema format string James Morse
2025-02-07 18:17 ` [PATCH v6 06/42] x86/resctrl: Remove data_width and the tabular format James Morse
2025-02-19 21:56 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 07/42] x86/resctrl: Add max_bw to struct resctrl_membw James Morse
2025-02-19 22:14 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 08/42] x86/resctrl: Generate default_ctrl instead of sharing it James Morse
2025-02-19 22:54 ` Reinette Chatre
2025-02-28 19:55 ` James Morse
2025-02-07 18:17 ` [PATCH v6 09/42] x86/resctrl: Add helper for setting CPU default properties James Morse
2025-02-19 23:09 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 10/42] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid() James Morse
2025-02-19 23:13 ` Reinette Chatre
2025-02-27 20:25 ` Moger, Babu
2025-02-28 19:54 ` James Morse
2025-02-07 18:17 ` [PATCH v6 11/42] x86/resctrl: Expose resctrl fs's init function to the rest of the kernel James Morse
2025-02-19 23:15 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 12/42] x86/resctrl: Move rdt_find_domain() to be visible to arch and fs code James Morse
2025-02-19 23:24 ` Reinette Chatre
2025-02-20 10:58 ` Catalin Marinas
2025-02-20 16:01 ` Reinette Chatre
2025-02-27 22:44 ` Fenghua Yu
2025-02-28 19:56 ` James Morse
2025-02-07 18:17 ` [PATCH v6 13/42] x86/resctrl: Move resctrl types to a separate header James Morse
2025-02-19 23:29 ` Reinette Chatre
2025-02-28 19:51 ` James Morse
2025-02-07 18:17 ` [PATCH v6 14/42] x86/resctrl: Add an arch helper to reset one resource James Morse
2025-02-19 23:32 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 15/42] x86/resctrl: Move monitor exit work to a resctrl exit call James Morse
2025-02-19 23:38 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 16/42] x86/resctrl: Move monitor init work to a resctrl init call James Morse
2025-02-19 23:43 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 17/42] x86/resctrl: Rewrite and move the for_each_*_rdt_resource() walkers James Morse
2025-02-19 23:47 ` Reinette Chatre
2025-02-07 18:17 ` [PATCH v6 18/42] x86/resctrl: Move the is_mbm_*_enabled() helpers to asm/resctrl.h James Morse
2025-02-19 23:55 ` Reinette Chatre
2025-02-28 19:55 ` James Morse
2025-02-07 18:18 ` [PATCH v6 19/42] x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC James Morse
2025-02-20 0:13 ` Reinette Chatre
2025-02-28 19:56 ` James Morse
2025-02-07 18:18 ` [PATCH v6 20/42] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers James Morse
2025-02-20 0:37 ` Reinette Chatre
2025-02-27 20:26 ` Moger, Babu
2025-02-28 19:54 ` James Morse
2025-02-07 18:18 ` [PATCH v6 21/42] x86/resctrl: Move mba_mbps_default_event init to filesystem code James Morse
2025-02-20 0:42 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 22/42] x86/resctrl: Move mbm_cfg_mask to struct rdt_resource James Morse
2025-02-20 0:45 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 23/42] x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions James Morse
2025-02-20 0:53 ` Reinette Chatre
2025-02-28 19:57 ` James Morse
2025-02-07 18:18 ` [PATCH v6 24/42] x86/resctrl: Allow an architecture to disable pseudo lock James Morse
2025-02-20 0:56 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 25/42] x86/resctrl: Make prefetch_disable_bits belong to the arch code James Morse
2025-02-20 0:59 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 26/42] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr James Morse
2025-02-20 1:03 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 27/42] x86/resctrl: Move RFTYPE flags to be managed by resctrl James Morse
2025-02-20 1:17 ` Reinette Chatre
2025-02-28 19:56 ` James Morse
2025-02-07 18:18 ` [PATCH v6 28/42] x86/resctrl: Handle throttle_mode for SMBA resources James Morse
2025-02-20 1:20 ` Reinette Chatre
2025-02-28 19:55 ` James Morse
2025-02-07 18:18 ` [PATCH v6 29/42] x86/resctrl: Move get_config_index() to a header James Morse
2025-02-20 1:27 ` Reinette Chatre
2025-02-28 19:51 ` James Morse
2025-03-01 2:28 ` Reinette Chatre
2025-03-06 19:28 ` James Morse
2025-03-06 22:52 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 30/42] x86/resctrl: Claim get_{mon,ctrl}_domain_from_cpu() helpers for resctrl James Morse
2025-02-20 4:08 ` Reinette Chatre
2025-02-27 23:05 ` Fenghua Yu
2025-02-28 19:53 ` James Morse
2025-02-07 18:18 ` [PATCH v6 31/42] x86/resctrl: Remove the limit on the number of CLOSID James Morse
2025-02-20 4:21 ` Reinette Chatre
2025-02-28 19:53 ` James Morse
2025-02-07 18:18 ` [PATCH v6 32/42] x86/resctrl: Rename resctrl_sched_in() to begin with "resctrl_arch_" James Morse
2025-02-20 4:26 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 33/42] x86/resctrl: resctrl_exit() teardown resctrl but leave the mount point James Morse
2025-02-20 4:42 ` Reinette Chatre
2025-02-28 19:54 ` James Morse
2025-03-01 2:35 ` Reinette Chatre
2025-03-06 19:28 ` James Morse
2025-03-07 4:47 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 34/42] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2025-02-20 4:46 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 35/42] x86/resctrl: Move is_mba_sc() out of core.c James Morse
2025-02-20 4:48 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 36/42] x86/resctrl: Add end-marker to the resctrl_event_id enum James Morse
2025-02-20 4:50 ` Reinette Chatre
2025-02-27 20:26 ` Moger, Babu
2025-02-28 19:55 ` James Morse
2025-02-28 20:59 ` Luck, Tony
2025-02-07 18:18 ` [PATCH v6 37/42] x86/restrl: Expand the width of dom_id by replacing mon_data_bits James Morse
2025-02-20 5:40 ` Reinette Chatre
2025-02-28 19:53 ` James Morse
2025-02-07 18:18 ` [PATCH v6 38/42] x86/resctrl: Remove a newline to avoid confusing the code move script James Morse
2025-02-20 5:42 ` Reinette Chatre
2025-02-07 18:18 ` [PATCH v6 39/42] x86/resctrl: Split trace.h James Morse
2025-02-20 5:45 ` Reinette Chatre
2025-02-25 4:36 ` Fenghua Yu
2025-02-28 19:53 ` James Morse
2025-02-27 23:16 ` Fenghua Yu
2025-02-28 19:53 ` James Morse
2025-02-07 18:18 ` [PATCH v6 40/42] fs/resctrl: Add boiler plate for external resctrl code James Morse
2025-02-20 5:54 ` Reinette Chatre
2025-02-28 19:54 ` James Morse
2025-02-07 18:18 ` [PATCH v6 41/42] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2025-02-20 6:00 ` Reinette Chatre
2025-02-28 19:57 ` James Morse
2025-02-07 18:18 ` [PATCH v6 42/42] x86/resctrl: Add python script to move resctrl code to /fs/resctrl James Morse
2025-02-20 6:10 ` Reinette Chatre
2025-02-25 16:16 ` Reinette Chatre
2025-02-28 19:57 ` James Morse [this message]
2025-02-25 5:02 ` Fenghua Yu
2025-02-28 19:57 ` James Morse
2025-02-28 20:06 ` Moger, Babu
2025-02-10 17:24 ` [PATCH v6 00/42] x86/resctrl: Move the resctrl filesystem " Reinette Chatre
2025-02-11 14:36 ` Peter Newman
2025-02-11 18:37 ` James Morse
2025-02-12 15:24 ` Moger, Babu
2025-02-11 18:37 ` James Morse
2025-02-11 19:29 ` Reinette Chatre
2025-02-12 16:04 ` Dave Martin
2025-02-28 1:15 ` Shaopeng Tan (Fujitsu)
2025-02-28 19:55 ` James Morse
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=9d4bc823-28d2-4ab4-a573-894109b51845@arm.com \
--to=james.morse@arm.com \
--cc=Babu.Moger@amd.com \
--cc=amitsinght@marvell.com \
--cc=baolin.wang@linux.alibaba.com \
--cc=bobo.shaobowang@huawei.com \
--cc=bp@alien8.de \
--cc=carl@os.amperecomputing.com \
--cc=dave.martin@arm.com \
--cc=david@redhat.com \
--cc=dfustini@baylibre.com \
--cc=hpa@zytor.com \
--cc=kobak@nvidia.com \
--cc=lcherian@marvell.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peternewman@google.com \
--cc=quic_jiles@quicinc.com \
--cc=reinette.chatre@intel.com \
--cc=rex.nie@jaguarmicro.com \
--cc=scott@os.amperecomputing.com \
--cc=sdonthineni@nvidia.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=tan.shaopeng@fujitsu.com \
--cc=tan.shaopeng@jp.fujitsu.com \
--cc=tglx@linutronix.de \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
--cc=xhao@linux.alibaba.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®