* [PATCH] kernel option CONFIG_USB_HIDINPUT_POWERBOOK description update
@ 2007-05-02 15:00 Noèl Köthe
2007-05-03 7:56 ` Jiri Kosina
0 siblings, 1 reply; 4+ messages in thread
From: Noèl Köthe @ 2007-05-02 15:00 UTC (permalink / raw)
To: linux-usb-devel; +Cc: linux-kernel
[-- Attachment #1: Type: text/plain, Size: 1107 bytes --]
Hello together,
The description of this option needs to be extended to be correct:)
--- /usr/src/linux-2.6.21/drivers/usb/input/Kconfig 2007-04-27 18:02:46.000000000 +0200
+++ Kconfig.new 2007-05-02 16:47:56.000000000 +0200
@@ -28,12 +28,12 @@
depends on USB_HID && INPUT=n
config USB_HIDINPUT_POWERBOOK
- bool "Enable support for iBook/PowerBook special keys"
+ bool "Enable support for iBook/PowerBook/MacBook/MacBookPro special keys"
default n
depends on USB_HID
help
Say Y here if you want support for the special keys (Fn, Numlock) on
- Apple iBooks and PowerBooks.
+ Apple iBooks, PowerBooks, MacBooks and MacBook Pro's.
If unsure, say N.
This option is needed on the Apple Intel Laptops, too.
I would suggest to rename USB_HIDINPUT_POWERBOOK because its needed on Apple Laptops.
Maybe USB_HIDINPUT_APPLELAPTOPS or something like this. Is a renaming patch for this welcome?
Thanks for your answer/applying.:)
--
Noèl Köthe <noel debian.org>
Debian GNU/Linux, www.debian.org
[-- Attachment #2: Dies ist ein digital signierter Nachrichtenteil --]
[-- Type: application/pgp-signature, Size: 189 bytes --]
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] kernel option CONFIG_USB_HIDINPUT_POWERBOOK description update
2007-05-02 15:00 [PATCH] kernel option CONFIG_USB_HIDINPUT_POWERBOOK description update Noèl Köthe
@ 2007-05-03 7:56 ` Jiri Kosina
2007-05-07 19:17 ` Noèl Köthe
0 siblings, 1 reply; 4+ messages in thread
From: Jiri Kosina @ 2007-05-03 7:56 UTC (permalink / raw)
To: Noèl Köthe; +Cc: linux-usb-devel, linux-kernel
[-- Attachment #1: Type: TEXT/PLAIN, Size: 1527 bytes --]
On Wed, 2 May 2007, No?l Köthe wrote:
> The description of this option needs to be extended to be correct:)
> --- /usr/src/linux-2.6.21/drivers/usb/input/Kconfig 2007-04-27 18:02:46.000000000 +0200
> +++ Kconfig.new 2007-05-02 16:47:56.000000000 +0200
> @@ -28,12 +28,12 @@
> depends on USB_HID && INPUT=n
>
> config USB_HIDINPUT_POWERBOOK
> - bool "Enable support for iBook/PowerBook special keys"
> + bool "Enable support for iBook/PowerBook/MacBook/MacBookPro special keys"
Hi,
I will apply this into my tree, thanks.
> This option is needed on the Apple Intel Laptops, too. I would suggest
> to rename USB_HIDINPUT_POWERBOOK because its needed on Apple Laptops.
> Maybe USB_HIDINPUT_APPLELAPTOPS or something like this. Is a renaming
> patch for this welcome?
The problem here is backwards compatibility - if we would like to do the
change in a consistent way, we should rename all the places which (for
historic reasons) mention powerbook only. Unfortunately this would also
require renaming the module parameter hid_pb_fnmode, which might be a
little too intrusive with respect to maintaining backward compatibility in
userspace (ok, we have already been fiddling with this parameter anyway
during the usbhid code split, but anyway).
If you would care to make the patch which maintains backwards
compatibility (for example by aliasing the variable pb_fnmode behing two
module parameters), that might probably be ok.
Thanks,
--
Jiri Kosina
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] kernel option CONFIG_USB_HIDINPUT_POWERBOOK description update
2007-05-03 7:56 ` Jiri Kosina
@ 2007-05-07 19:17 ` Noèl Köthe
2007-05-07 21:36 ` Jiri Kosina
0 siblings, 1 reply; 4+ messages in thread
From: Noèl Köthe @ 2007-05-07 19:17 UTC (permalink / raw)
To: Jiri Kosina; +Cc: linux-usb-devel, linux-kernel
[-- Attachment #1: Type: text/plain, Size: 1592 bytes --]
Am Donnerstag, den 03.05.2007, 09:56 +0200 schrieb Jiri Kosina:
Hello Jiri,
> > The description of this option needs to be extended to be correct:)
> > config USB_HIDINPUT_POWERBOOK
> > - bool "Enable support for iBook/PowerBook special keys"
> > + bool "Enable support for iBook/PowerBook/MacBook/MacBookPro special keys"
> I will apply this into my tree, thanks.
Great thanks. Does this mean it will go into your tree and then into the
mainline kernel, or is there an additional step needed?
> > This option is needed on the Apple Intel Laptops, too. I would suggest
> > to rename USB_HIDINPUT_POWERBOOK because its needed on Apple Laptops.
> > Maybe USB_HIDINPUT_APPLELAPTOPS or something like this. Is a renaming
> > patch for this welcome?
>
> The problem here is backwards compatibility - if we would like to do the
> change in a consistent way, we should rename all the places which (for
> historic reasons) mention powerbook only. Unfortunately this would also
> require renaming the module parameter hid_pb_fnmode, which might be a
> little too intrusive with respect to maintaining backward compatibility in
> userspace (ok, we have already been fiddling with this parameter anyway
> during the usbhid code split, but anyway).
>
> If you would care to make the patch which maintains backwards
> compatibility (for example by aliasing the variable pb_fnmode behing two
> module parameters), that might probably be ok.
I understand. I will try.
--
Noèl Köthe <noel debian.org>
Debian GNU/Linux, www.debian.org
[-- Attachment #2: Dies ist ein digital signierter Nachrichtenteil --]
[-- Type: application/pgp-signature, Size: 189 bytes --]
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] kernel option CONFIG_USB_HIDINPUT_POWERBOOK description update
2007-05-07 19:17 ` Noèl Köthe
@ 2007-05-07 21:36 ` Jiri Kosina
0 siblings, 0 replies; 4+ messages in thread
From: Jiri Kosina @ 2007-05-07 21:36 UTC (permalink / raw)
To: Noèl Köthe; +Cc: linux-usb-devel, linux-kernel
[-- Attachment #1: Type: TEXT/PLAIN, Size: 494 bytes --]
On Mon, 7 May 2007, No?l Köthe wrote:
> > > config USB_HIDINPUT_POWERBOOK
> > > - bool "Enable support for iBook/PowerBook special keys"
> > > + bool "Enable support for iBook/PowerBook/MacBook/MacBookPro special keys"
> > I will apply this into my tree, thanks.
> Great thanks. Does this mean it will go into your tree and then into the
> mainline kernel, or is there an additional step needed?
No further steps needed on your side. Applied, thanks,
--
Jiri Kosina
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2007-05-07 21:37 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2007-05-02 15:00 [PATCH] kernel option CONFIG_USB_HIDINPUT_POWERBOOK description update Noèl Köthe
2007-05-03 7:56 ` Jiri Kosina
2007-05-07 19:17 ` Noèl Köthe
2007-05-07 21:36 ` Jiri Kosina
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®