mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Johannes Berg <johannes@sipsolutions.net>
To: "Rafael J. Wysocki" <rjw@sisk.pl>
Cc: Andrew Morton <akpm@linux-foundation.org>,
	LKML <linux-kernel@vger.kernel.org>, Pavel Machek <pavel@ucw.cz>,
	Nigel Cunningham <nigel@nigel.suspend2.net>,
	Pekka Enberg <penberg@cs.helsinki.fi>
Subject: Re: [PATCH -mm] PM: Separate hibernation code from suspend code
Date: Tue, 08 May 2007 10:41:36 +0200	[thread overview]
Message-ID: <1178613696.18162.28.camel@johannes.berg> (raw)
In-Reply-To: <200705072335.15357.rjw@sisk.pl>

[-- Attachment #1: Type: text/plain, Size: 670 bytes --]

On Mon, 2007-05-07 at 23:35 +0200, Rafael J. Wysocki wrote:

> > Also, you could then simplify all the instances of
> >   (hibernation_mode == HIBERNATION_PLATFORM && hibernation_ops) 
> > to just
> >   (hibernation_mode == HIBERNATION_PLATFORM)
> > in various if statements and other places.
> 
> No, that's not a good idea, because of the "reduce code duplication patch"
> that I'd like to go on top of this.  I'd rather use 'if (hibernation_ops)' here. :-)

But if you want the user to be able to change away from 'platform' mode
you still have to have
  if (hibernation_ops && hibernation_mode == HIBERNATION_PLATFORM)
in most places, no?

johannes

[-- Attachment #2: This is a digitally signed message part --]
[-- Type: application/pgp-signature, Size: 190 bytes --]

  reply	other threads:[~2007-05-08  8:39 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2007-05-04  9:32 Rafael J. Wysocki
2007-05-04 17:22 ` Satyam Sharma
2007-05-04 22:47   ` Rafael J. Wysocki
2007-05-05  6:31 ` Andrew Morton
2007-05-05 10:16   ` Rafael J. Wysocki
2007-05-05 12:21     ` Rafael J. Wysocki
2007-05-05 12:27       ` Johannes Berg
2007-05-05 13:50         ` Rafael J. Wysocki
2007-05-05 21:01           ` Pavel Machek
2007-05-07 11:46           ` Johannes Berg
2007-05-07 11:56             ` Johannes Berg
2007-05-07 21:35               ` Rafael J. Wysocki
2007-05-08  8:41                 ` Johannes Berg [this message]
2007-05-08 11:05                   ` Rafael J. Wysocki
2007-05-08 20:46             ` [PATCH -mm] swsusp: Use reasonable default for hibernation_mode Rafael J. Wysocki
2007-05-05 16:55   ` [PATCH -mm] PM: Separate hibernation code from suspend code Jason L Tibbitts III

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=1178613696.18162.28.camel@johannes.berg \
    --to=johannes@sipsolutions.net \
    --cc=akpm@linux-foundation.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=nigel@nigel.suspend2.net \
    --cc=pavel@ucw.cz \
    --cc=penberg@cs.helsinki.fi \
    --cc=rjw@sisk.pl \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®