From: "Rafael J. Wysocki" <rjw@sisk.pl>
To: Johannes Berg <johannes@sipsolutions.net>
Cc: Andrew Morton <akpm@linux-foundation.org>,
LKML <linux-kernel@vger.kernel.org>, Pavel Machek <pavel@ucw.cz>,
Nigel Cunningham <nigel@nigel.suspend2.net>,
Pekka Enberg <penberg@cs.helsinki.fi>
Subject: Re: [PATCH -mm] PM: Separate hibernation code from suspend code
Date: Mon, 7 May 2007 23:35:14 +0200 [thread overview]
Message-ID: <200705072335.15357.rjw@sisk.pl> (raw)
In-Reply-To: <1178538966.7261.18.camel@johannes.berg>
On Monday, 7 May 2007 13:56, Johannes Berg wrote:
> On Mon, 2007-05-07 at 13:46 +0200, Johannes Berg wrote:
> > On Sat, 2007-05-05 at 15:50 +0200, Rafael J. Wysocki wrote:
> >
> > > @@ -60,6 +60,9 @@ void hibernation_set_ops(struct hibernat
> > > }
> > > mutex_lock(&pm_mutex);
> > > hibernation_ops = ops;
> > > + if (ops)
> > > + hibernation_mode = HIBERNATION_PLATFORM;
> >
> > else if (hibernation_mode == HIBERNATION_PLATFORM)
> > hibernation_mode = HIBERNATION_SHUTDOWN;
>
> Also, you could then simplify all the instances of
> (hibernation_mode == HIBERNATION_PLATFORM && hibernation_ops)
> to just
> (hibernation_mode == HIBERNATION_PLATFORM)
> in various if statements and other places.
No, that's not a good idea, because of the "reduce code duplication patch"
that I'd like to go on top of this. I'd rather use 'if (hibernation_ops)' here. :-)
Greetings,
Rafael
next prev parent reply other threads:[~2007-05-07 21:30 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-05-04 9:32 Rafael J. Wysocki
2007-05-04 17:22 ` Satyam Sharma
2007-05-04 22:47 ` Rafael J. Wysocki
2007-05-05 6:31 ` Andrew Morton
2007-05-05 10:16 ` Rafael J. Wysocki
2007-05-05 12:21 ` Rafael J. Wysocki
2007-05-05 12:27 ` Johannes Berg
2007-05-05 13:50 ` Rafael J. Wysocki
2007-05-05 21:01 ` Pavel Machek
2007-05-07 11:46 ` Johannes Berg
2007-05-07 11:56 ` Johannes Berg
2007-05-07 21:35 ` Rafael J. Wysocki [this message]
2007-05-08 8:41 ` Johannes Berg
2007-05-08 11:05 ` Rafael J. Wysocki
2007-05-08 20:46 ` [PATCH -mm] swsusp: Use reasonable default for hibernation_mode Rafael J. Wysocki
2007-05-05 16:55 ` [PATCH -mm] PM: Separate hibernation code from suspend code Jason L Tibbitts III
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=200705072335.15357.rjw@sisk.pl \
--to=rjw@sisk.pl \
--cc=akpm@linux-foundation.org \
--cc=johannes@sipsolutions.net \
--cc=linux-kernel@vger.kernel.org \
--cc=nigel@nigel.suspend2.net \
--cc=pavel@ucw.cz \
--cc=penberg@cs.helsinki.fi \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®