mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 0/2] replace system_wq with system_percpu_wq, add WQ_PERCPU to alloc_workqueue
@ 2025-11-06 15:58 Marco Crivellari
  2025-11-06 15:58 ` [PATCH 1/2] xen/events: replace use of system_wq with system_percpu_wq Marco Crivellari
                   ` (2 more replies)
  0 siblings, 3 replies; 6+ messages in thread
From: Marco Crivellari @ 2025-11-06 15:58 UTC (permalink / raw)
  To: linux-kernel, xen-devel
  Cc: Tejun Heo, Lai Jiangshan, Frederic Weisbecker,
	Sebastian Andrzej Siewior, Marco Crivellari, Michal Hocko,
	Juergen Gross, Stefano Stabellini, Oleksandr Tyshchenko

Hi,

=== Current situation: problems ===

Let's consider a nohz_full system with isolated CPUs: wq_unbound_cpumask is
set to the housekeeping CPUs, for !WQ_UNBOUND the local CPU is selected.

This leads to different scenarios if a work item is scheduled on an
isolated CPU where "delay" value is 0 or greater then 0:
        schedule_delayed_work(, 0);

This will be handled by __queue_work() that will queue the work item on the
current local (isolated) CPU, while:

        schedule_delayed_work(, 1);

Will move the timer on an housekeeping CPU, and schedule the work there.

Currently if a user enqueue a work item using schedule_delayed_work() the
used wq is "system_wq" (per-cpu wq) while queue_delayed_work() use
WORK_CPU_UNBOUND (used when a cpu is not specified). The same applies to
schedule_work() that is using system_wq and queue_work(), that makes use
again of WORK_CPU_UNBOUND.

This lack of consistency cannot be addressed without refactoring the API.

=== Recent changes to the WQ API ===

The following, address the recent changes in the Workqueue API:

- commit 128ea9f6ccfb ("workqueue: Add system_percpu_wq and system_dfl_wq")
- commit 930c2ea566af ("workqueue: Add new WQ_PERCPU flag")

The old workqueues will be removed in a future release cycle.

=== Introduced Changes by this series ===

1) [P 1] Replace uses of system_wq

    system_wq is a per-CPU workqueue, but his name is not clear.
    Because of that, system_wq has been replaced with system_percpu_wq.

2) [P 2] WQ_PERCPU added to alloc_workqueue()

    This change adds a new WQ_PERCPU flag to explicitly request
    alloc_workqueue() to be per-cpu when WQ_UNBOUND has not been specified.


Thanks!


Marco Crivellari (2):
  xen/events: replace use of system_wq with system_percpu_wq
  xen: privcmd: WQ_PERCPU added to alloc_workqueue users

 drivers/xen/events/events_base.c | 6 +++---
 drivers/xen/privcmd.c            | 3 ++-
 2 files changed, 5 insertions(+), 4 deletions(-)

-- 
2.51.1


^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2026-01-05 12:30 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-11-06 15:58 [PATCH 0/2] replace system_wq with system_percpu_wq, add WQ_PERCPU to alloc_workqueue Marco Crivellari
2025-11-06 15:58 ` [PATCH 1/2] xen/events: replace use of system_wq with system_percpu_wq Marco Crivellari
2026-01-05 12:30   ` Jürgen Groß
2025-11-06 15:58 ` [PATCH 2/2] xen: privcmd: WQ_PERCPU added to alloc_workqueue users Marco Crivellari
2026-01-05 12:30   ` Jürgen Groß
2025-12-24 15:05 ` [PATCH 0/2] replace system_wq with system_percpu_wq, add WQ_PERCPU to alloc_workqueue Marco Crivellari

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®