From: David Woodhouse <dwmw2@infradead.org>
To: Marcel Holtmann <marcel@holtmann.org>
Cc: Sam Ravnborg <sam@ravnborg.org>,
linux-kernel@vger.kernel.org, aoliva@redhat.com,
alan@lxorguk.ukuu.org.uk, Abhay Salunke <Abhay_Salunke@dell.com>,
kay.sievers@vrfy.org, Takashi Iwai <tiwai@suse.de>
Subject: Re: [PATCH 2/3] firmware: Add CONFIG_BUILTIN_FIRMWARE option
Date: Sat, 24 May 2008 20:23:19 +0100 [thread overview]
Message-ID: <1211656999.540.16.camel@pmac.infradead.org> (raw)
In-Reply-To: <D56F641E-9FDB-48E5-AF0B-B8E84B08504A@holtmann.org>
On Sat, 2008-05-24 at 20:18 +0200, Marcel Holtmann wrote:
> Hi David,
>
> >> Playing with it now. I fixed the mkdir thing by including $(objtree)
> >> in the target.
> >
> > Here's what I have (on top of the git tree) now. I just need to sort
> > out
> > the clean/mrproper behaviour -- and possibly should rename the korg
> > firmware to firmware/korg/k1212.c_shipped?
>
> so using "/" within the name parameter for request_firmware() is
> actually forbidden. I know that some driver authers think it is a good
> idea, but it is not.
>
> I am actually working on a patch to make request_firmware() fail/warn
> when the name has a "/" in it.
>
> You don't need to consider any deep nesting of firmware file names. It
> was never meant to be used like this.
Hm. Is there any fundamental reason why we should forbid this? It does
seem to make sense to let people use the namespace for it.
--
dwmw2
next prev parent reply other threads:[~2008-05-24 19:23 UTC|newest]
Thread overview: 82+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-05-23 13:44 [PATCH 1/3] firmware: allow firmware files to be built into kernel image David Woodhouse
2008-05-23 13:46 ` [PATCH 2/3] firmware: Add CONFIG_BUILTIN_FIRMWARE option David Woodhouse
2008-05-23 13:50 ` [PATCH 2/3] firmware: convert korg1212 driver to use firmware loader exclusively David Woodhouse
2008-05-23 14:56 ` Takashi Iwai
2008-05-23 14:59 ` David Woodhouse
2008-05-23 16:41 ` [PATCH 2/3] firmware: Add CONFIG_BUILTIN_FIRMWARE option Sam Ravnborg
2008-05-23 17:13 ` David Woodhouse
2008-05-23 18:07 ` David Woodhouse
2008-05-23 18:11 ` Sam Ravnborg
2008-05-24 14:46 ` David Woodhouse
2008-05-24 15:22 ` Sam Ravnborg
2008-05-24 15:25 ` David Woodhouse
2008-05-24 15:34 ` David Woodhouse
2008-05-24 18:18 ` Marcel Holtmann
2008-05-24 19:23 ` David Woodhouse [this message]
2008-05-24 19:31 ` Marcel Holtmann
2008-05-25 9:30 ` Johannes Berg
2008-05-25 9:49 ` Michael Buesch
2008-05-25 11:54 ` Marcel Holtmann
2008-05-25 12:14 ` Michael Buesch
2008-05-25 13:16 ` Alan Cox
2008-05-25 13:46 ` David Woodhouse
2008-05-25 18:07 ` Marcel Holtmann
2008-05-25 11:49 ` Marcel Holtmann
2008-05-25 11:59 ` Johannes Berg
2008-05-25 13:12 ` Marcel Holtmann
2008-05-25 13:40 ` Johannes Berg
2008-05-25 18:12 ` Marcel Holtmann
2008-05-25 18:18 ` Michael Buesch
2008-05-25 18:28 ` Marcel Holtmann
2008-05-26 8:57 ` Johannes Berg
2008-05-25 12:05 ` Michael Buesch
2008-05-25 13:19 ` Marcel Holtmann
2008-05-25 13:45 ` Michael Buesch
2008-05-25 18:15 ` Marcel Holtmann
2008-05-25 18:27 ` Michael Buesch
2008-05-25 18:34 ` Marcel Holtmann
2008-05-25 14:13 ` Johannes Berg
2008-05-25 14:18 ` David Woodhouse
2008-05-25 14:22 ` Johannes Berg
2008-05-25 18:23 ` Marcel Holtmann
2008-05-25 18:39 ` Michael Buesch
2008-05-25 18:46 ` Marcel Holtmann
2008-05-25 18:53 ` Michael Buesch
2008-05-25 19:03 ` Marcel Holtmann
2008-05-25 19:21 ` Michael Buesch
2008-05-26 8:52 ` Johannes Berg
2008-05-25 17:17 ` Alexandre Oliva
2008-05-25 18:49 ` Marcel Holtmann
2008-05-25 19:53 ` Alan Cox
2008-05-26 3:30 ` Alexandre Oliva
2008-05-25 18:49 ` Michael Buesch
2008-05-25 19:01 ` Marcel Holtmann
2008-05-25 19:09 ` Michael Buesch
2008-05-26 3:13 ` Alexandre Oliva
2008-05-26 12:53 ` Michael Buesch
2008-05-26 13:08 ` Johannes Berg
2008-05-26 17:09 ` Alexandre Oliva
2008-05-26 17:11 ` Michael Buesch
2008-05-23 14:53 ` [PATCH 1/3] firmware: allow firmware files to be built into kernel image Takashi Iwai
2008-05-23 14:58 ` David Woodhouse
2008-05-23 15:19 ` Takashi Iwai
2008-05-23 15:25 ` David Woodhouse
2008-05-23 15:33 ` Alan Cox
2008-05-23 17:21 ` David Woodhouse
2008-05-23 19:14 ` David Woodhouse
2008-05-23 19:42 ` David Woodhouse
2008-05-23 20:31 ` Alan Cox
2008-05-23 21:04 ` David Woodhouse
2008-05-23 23:28 ` David Woodhouse
2008-05-23 14:56 ` Alan Cox
2008-05-23 15:11 ` David Woodhouse
2008-05-23 15:00 ` Clemens Ladisch
2008-05-23 15:20 ` David Woodhouse
2008-05-23 15:32 ` Alan Cox
2008-05-23 16:21 ` Sam Ravnborg
2008-05-23 16:37 ` David Dillow
2008-05-23 16:38 ` Lennart Sorensen
2008-05-23 16:44 ` Sam Ravnborg
2008-05-23 16:53 ` Rene Herman
2008-05-23 17:06 ` David Woodhouse
2008-05-23 17:49 ` David Woodhouse
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1211656999.540.16.camel@pmac.infradead.org \
--to=dwmw2@infradead.org \
--cc=Abhay_Salunke@dell.com \
--cc=alan@lxorguk.ukuu.org.uk \
--cc=aoliva@redhat.com \
--cc=kay.sievers@vrfy.org \
--cc=linux-kernel@vger.kernel.org \
--cc=marcel@holtmann.org \
--cc=sam@ravnborg.org \
--cc=tiwai@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®