mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [patch 1/2] slub: rename cpuslab_flush to cpu_slab_flush
@ 2009-04-23 18:38 David Rientjes
  2009-04-23 18:38 ` [patch 2/2] slub: add Documentation/ABI/testing/sysfs-kernel-slab David Rientjes
  2009-04-23 19:39 ` [patch 1/2] slub: rename cpuslab_flush to cpu_slab_flush Pekka Enberg
  0 siblings, 2 replies; 12+ messages in thread
From: David Rientjes @ 2009-04-23 18:38 UTC (permalink / raw)
  To: Pekka Enberg; +Cc: Christoph Lameter, linux-kernel

There is already a `cpu_slabs' file to display the number of cpu slabs,
so cpuslab_flush should follow this pattern.

The first documentation of this file will be in a subsequent patch that
adds Documentation/ABI/testing/sysfs-kernel-slab, so no stable guarantee
has been made that the name of this file would not change.

Cc: Christoph Lameter <cl@linux-foundation.org>
Signed-off-by: David Rientjes <rientjes@google.com>
---
 include/linux/slub_def.h |    2 +-
 mm/slub.c                |    6 +++---
 2 files changed, 4 insertions(+), 4 deletions(-)

diff --git a/include/linux/slub_def.h b/include/linux/slub_def.h
--- a/include/linux/slub_def.h
+++ b/include/linux/slub_def.h
@@ -24,7 +24,7 @@ enum stat_item {
 	ALLOC_SLAB,		/* Cpu slab acquired from page allocator */
 	ALLOC_REFILL,		/* Refill cpu slab from slab freelist */
 	FREE_SLAB,		/* Slab freed to the page allocator */
-	CPUSLAB_FLUSH,		/* Abandoning of the cpu slab */
+	CPU_SLAB_FLUSH,		/* Abandoning of the cpu slab */
 	DEACTIVATE_FULL,	/* Cpu slab was full when deactivated */
 	DEACTIVATE_EMPTY,	/* Cpu slab was empty when deactivated */
 	DEACTIVATE_TO_HEAD,	/* Cpu slab was moved to the head of partials */
diff --git a/mm/slub.c b/mm/slub.c
--- a/mm/slub.c
+++ b/mm/slub.c
@@ -1438,7 +1438,7 @@ static void deactivate_slab(struct kmem_cache *s, struct kmem_cache_cpu *c)
 
 static inline void flush_slab(struct kmem_cache *s, struct kmem_cache_cpu *c)
 {
-	stat(c, CPUSLAB_FLUSH);
+	stat(c, CPU_SLAB_FLUSH);
 	slab_lock(c->page);
 	deactivate_slab(s, c);
 }
@@ -4220,7 +4220,7 @@ STAT_ATTR(ALLOC_FROM_PARTIAL, alloc_from_partial);
 STAT_ATTR(ALLOC_SLAB, alloc_slab);
 STAT_ATTR(ALLOC_REFILL, alloc_refill);
 STAT_ATTR(FREE_SLAB, free_slab);
-STAT_ATTR(CPUSLAB_FLUSH, cpuslab_flush);
+STAT_ATTR(CPU_SLAB_FLUSH, cpu_slab_flush);
 STAT_ATTR(DEACTIVATE_FULL, deactivate_full);
 STAT_ATTR(DEACTIVATE_EMPTY, deactivate_empty);
 STAT_ATTR(DEACTIVATE_TO_HEAD, deactivate_to_head);
@@ -4274,7 +4274,7 @@ static struct attribute *slab_attrs[] = {
 	&alloc_slab_attr.attr,
 	&alloc_refill_attr.attr,
 	&free_slab_attr.attr,
-	&cpuslab_flush_attr.attr,
+	&cpu_slab_flush_attr.attr,
 	&deactivate_full_attr.attr,
 	&deactivate_empty_attr.attr,
 	&deactivate_to_head_attr.attr,

^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2009-04-28 11:32 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-04-23 18:38 [patch 1/2] slub: rename cpuslab_flush to cpu_slab_flush David Rientjes
2009-04-23 18:38 ` [patch 2/2] slub: add Documentation/ABI/testing/sysfs-kernel-slab David Rientjes
2009-04-23 18:52   ` Christoph Lameter
2009-04-24 23:26     ` [patch] " David Rientjes
2009-04-27 14:09       ` Christoph Lameter
2009-04-28 11:32       ` Pekka Enberg
2009-04-23 22:26   ` [patch 2/2] " David Rientjes
2009-04-23 22:31     ` Christoph Lameter
2009-04-23 22:52       ` David Rientjes
2009-04-23 22:55         ` Christoph Lameter
2009-04-24 23:35           ` David Rientjes
2009-04-23 19:39 ` [patch 1/2] slub: rename cpuslab_flush to cpu_slab_flush Pekka Enberg

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®