mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v1] thermal: core: Introduce thermal_governor_trip_crossed()
@ 2024-04-23 19:01 Rafael J. Wysocki
  2024-04-24  7:26 ` Lukasz Luba
  0 siblings, 1 reply; 2+ messages in thread
From: Rafael J. Wysocki @ 2024-04-23 19:01 UTC (permalink / raw)
  To: Linux PM, Daniel Lezcano; +Cc: LKML, Rafael J. Wysocki, Lukasz Luba

From: Rafael J. Wysocki <rafael.j.wysocki@intel.com>

Add a wrapper around the .trip_crossed() governor callback invocation
to reduce code duplications slightly and improve the code layout in
__thermal_zone_device_update().

No intentional functional impact.

Signed-off-by: Rafael J. Wysocki <rafael.j.wysocki@intel.com>
---

As requested in https://lore.kernel.org/linux-pm/3c169af3-e9c3-47c0-b343-48f699680009@linaro.org/

---
 drivers/thermal/thermal_core.c |   15 +++++++++++----
 1 file changed, 11 insertions(+), 4 deletions(-)

Index: linux-pm/drivers/thermal/thermal_core.c
===================================================================
--- linux-pm.orig/drivers/thermal/thermal_core.c
+++ linux-pm/drivers/thermal/thermal_core.c
@@ -450,6 +450,15 @@ static void thermal_zone_device_init(str
 		pos->initialized = false;
 }
 
+static void thermal_governor_trip_crossed(struct thermal_governor *governor,
+					  struct thermal_zone_device *tz,
+					  const struct thermal_trip *trip,
+					  bool crossed_up)
+{
+	if (governor->trip_crossed)
+		governor->trip_crossed(tz, trip, crossed_up);
+}
+
 static int thermal_trip_notify_cmp(void *ascending, const struct list_head *a,
 				   const struct list_head *b)
 {
@@ -489,16 +498,14 @@ void __thermal_zone_device_update(struct
 	list_for_each_entry(td, &way_up_list, notify_list_node) {
 		thermal_notify_tz_trip_up(tz, &td->trip);
 		thermal_debug_tz_trip_up(tz, &td->trip);
-		if (governor->trip_crossed)
-			governor->trip_crossed(tz, &td->trip, true);
+		thermal_governor_trip_crossed(governor, tz, &td->trip, true);
 	}
 
 	list_sort(NULL, &way_down_list, thermal_trip_notify_cmp);
 	list_for_each_entry(td, &way_down_list, notify_list_node) {
 		thermal_notify_tz_trip_down(tz, &td->trip);
 		thermal_debug_tz_trip_down(tz, &td->trip);
-		if (governor->trip_crossed)
-			governor->trip_crossed(tz, &td->trip, false);
+		thermal_governor_trip_crossed(governor, tz, &td->trip, false);
 	}
 
 	if (governor->manage)




^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2024-04-24  7:26 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-04-23 19:01 [PATCH v1] thermal: core: Introduce thermal_governor_trip_crossed() Rafael J. Wysocki
2024-04-24  7:26 ` Lukasz Luba

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®