From: Peter Zijlstra <peterz@infradead.org>
To: Ingo Molnar <mingo@elte.hu>
Cc: Hitoshi Mitake <mitake@dcl.info.waseda.ac.jp>,
tglx@linutronix.de, fweisbec@gmail.com,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH][RFC] Measuring term of acquiring spinlock
Date: Fri, 13 Nov 2009 09:24:21 +0100 [thread overview]
Message-ID: <1258100661.4039.1023.camel@laptop> (raw)
In-Reply-To: <20091113081722.GA14009@elte.hu>
On Fri, 2009-11-13 at 09:17 +0100, Ingo Molnar wrote:
>
>
> Btw., i think we should rename that tracepoint category from 'lockdep'
> to 'lock'. It's possible to enable them without CONFIG_PROVE_LOCKING,
> and they arent high-overhead in that case.
They're still in 'lockdep', and it does still require enabling all of
the lock debugging code, so the overhead is far from zero.
next prev parent reply other threads:[~2009-11-13 8:24 UTC|newest]
Thread overview: 32+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-11-12 6:43 Hitoshi Mitake
2009-11-12 7:39 ` Ingo Molnar
2009-11-13 4:21 ` Hitoshi Mitake
2009-11-13 8:17 ` Ingo Molnar
2009-11-13 8:24 ` Peter Zijlstra [this message]
2009-11-13 8:40 ` Frederic Weisbecker
2009-11-13 8:51 ` Ingo Molnar
2009-11-13 9:06 ` [PATCH] tracing: Rename lockdep event subsystem into lock Frederic Weisbecker
2009-11-13 9:10 ` Peter Zijlstra
2009-11-13 9:26 ` Ingo Molnar
2009-11-13 9:36 ` Frederic Weisbecker
2009-11-13 9:31 ` [tip:perf/core] tracing: Rename 'lockdep' event subsystem into 'lock' tip-bot for Frederic Weisbecker
2009-11-13 9:57 ` tip-bot for Frederic Weisbecker
2009-11-13 10:51 ` [PATCH][RFC] Measuring term of acquiring spinlock Frederic Weisbecker
2009-11-15 1:20 ` Hitoshi Mitake
2009-11-15 2:21 ` Frederic Weisbecker
2009-11-15 8:38 ` Hitoshi Mitake
2009-12-07 3:34 ` [PATCH 1/2] Does raw_field_ptr() supports __data_loc? Hitoshi Mitake
2009-12-07 4:02 ` Frederic Weisbecker
2009-12-07 16:09 ` Steven Rostedt
2009-12-07 3:34 ` [PATCH 2/2] perf lock: New subcommand "lock" to perf for analyzing lock statistics Hitoshi Mitake
2009-12-07 4:41 ` Frederic Weisbecker
2009-12-07 7:27 ` Ingo Molnar
2009-12-07 8:38 ` Xiao Guangrong
2009-12-07 15:00 ` Hitoshi Mitake
2009-12-07 16:38 ` Steven Rostedt
2009-12-07 19:48 ` Frederic Weisbecker
2009-12-07 19:57 ` Frederic Weisbecker
2009-12-08 1:31 ` Xiao Guangrong
2009-12-07 14:57 ` Hitoshi Mitake
2009-12-07 14:51 ` Hitoshi Mitake
2009-12-07 20:16 ` Frederic Weisbecker
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1258100661.4039.1023.camel@laptop \
--to=peterz@infradead.org \
--cc=fweisbec@gmail.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=mitake@dcl.info.waseda.ac.jp \
--cc=tglx@linutronix.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®