From: Steven Rostedt <rostedt@goodmis.org>
To: mingo@redhat.com, hpa@zytor.com, mathieu.desnoyers@polymtl.ca,
linux-kernel@vger.kernel.org, randy.dunlap@oracle.com,
wcohen@redhat.com, fweisbec@gmail.com, tglx@linutronix.de,
jbaron@redhat.com, mhiramat@redhat.com, mingo@elte.hu
Cc: linux-tip-commits@vger.kernel.org
Subject: Re: [tip:perf/core] tracing: Add DEFINE_EVENT(), DEFINE_SINGLE_EVENT() support to docbook
Date: Wed, 02 Dec 2009 08:52:14 -0500 [thread overview]
Message-ID: <1259761934.12870.12.camel@gandalf.stny.rr.com> (raw)
In-Reply-To: <tip-3a9089fd78367e2c6c815129030b790a0f5c2715@git.kernel.org>
On Wed, 2009-12-02 at 10:42 +0000, tip-bot for Jason Baron wrote:
> Commit-ID: 3a9089fd78367e2c6c815129030b790a0f5c2715
> Gitweb: http://git.kernel.org/tip/3a9089fd78367e2c6c815129030b790a0f5c2715
> Author: Jason Baron <jbaron@redhat.com>
> AuthorDate: Tue, 1 Dec 2009 12:18:49 -0500
> Committer: Ingo Molnar <mingo@elte.hu>
> CommitDate: Wed, 2 Dec 2009 09:57:37 +0100
>
> tracing: Add DEFINE_EVENT(), DEFINE_SINGLE_EVENT() support to docbook
Ug, I need more sleep, because I never noticed the "SINGLE" when I acked
this :-p
I thought the DEFINE_SINGLE_EVENT was still under discussion because it
is a confusing name. I suggested to call it exactly what is was.
DECLARE_CLASS_AND_DEFINE_EVENT()
-- Steve
>
> The introduction of the new 'DECLARE_EVENT_CLASS()' obviates the
> need for the 'TRACE_EVENT()' macro in some cases. Thus, docbook
> style comments that used to live with 'TRACE_EVENT()' are now
> moved to 'DEFINE_EVENT()'. Thus, we need to make the docbook
> system understand the new 'DEFINE_EVENT()' macro. In addition
> I've tried to futureproof the patch, by also adding support for
> 'DEFINE_SINGLE_EVENT()', since there has been discussion about
> renaming: TRACE_EVENT() -> DEFINE_SINGLE_EVENT().
>
> Without this patch the tracepoint docbook fails to build.
>
> I've verified that this patch correctly builds the tracepoint
> docbook which currently covers signals, and irqs.
>
> Changes in v2:
> - properly indent perl 'if' statements
>
> Signed-off-by: Jason Baron <jbaron@redhat.com>
> Acked-by: Steven Rostedt <rostedt@goodmis.org>
> Acked-by: Randy Dunlap <randy.dunlap@oracle.com>
> Cc: William Cohen <wcohen@redhat.com>
> Cc: Frederic Weisbecker <fweisbec@gmail.com>
> Cc: Mathieu Desnoyers <mathieu.desnoyers@polymtl.ca>
> Cc: Masami Hiramatsu <mhiramat@redhat.com>
> LKML-Reference: <200912011718.nB1HIn7t011371@int-mx04.intmail.prod.int.phx2.redhat.com>
> Signed-off-by: Ingo Molnar <mingo@elte.hu>
next prev parent reply other threads:[~2009-12-02 13:52 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-12-01 17:18 [PATCH v2] tracing: add " Jason Baron
2009-12-01 17:20 ` Randy Dunlap
2009-12-02 10:42 ` [tip:perf/core] tracing: Add " tip-bot for Jason Baron
2009-12-02 13:52 ` Steven Rostedt [this message]
2009-12-02 14:01 ` Ingo Molnar
2009-12-02 14:28 ` Steven Rostedt
2009-12-02 14:43 ` Ingo Molnar
2009-12-02 14:55 ` Steven Rostedt
2009-12-02 16:15 ` Randy Dunlap
2009-12-02 16:27 ` Mathieu Desnoyers
2009-12-02 17:11 ` Steven Rostedt
2009-12-02 18:06 ` Mathieu Desnoyers
2009-12-02 18:19 ` Steven Rostedt
2009-12-02 19:01 ` trace/events: DECLARE vs DEFINE semantic Mathieu Desnoyers
2009-12-02 19:19 ` Steven Rostedt
2009-12-02 19:34 ` Randy Dunlap
2009-12-02 22:36 ` Masami Hiramatsu
2009-12-02 22:46 ` Steven Rostedt
2009-12-02 22:57 ` Mathieu Desnoyers
2009-12-02 23:08 ` H. Peter Anvin
2009-12-02 23:13 ` Steven Rostedt
2009-12-02 23:18 ` H. Peter Anvin
2009-12-02 23:15 ` Mathieu Desnoyers
2009-12-03 3:24 ` Masami Hiramatsu
2009-12-02 23:10 ` Mathieu Desnoyers
2009-12-03 4:00 ` Masami Hiramatsu
2009-12-03 4:07 ` Steven Rostedt
2009-12-03 13:51 ` Masami Hiramatsu
2009-12-03 13:54 ` Steven Rostedt
2009-12-03 14:09 ` Mathieu Desnoyers
2009-12-03 14:24 ` Steven Rostedt
2009-12-03 14:42 ` Mathieu Desnoyers
2009-12-03 15:31 ` Masami Hiramatsu
2009-12-03 15:56 ` Steven Rostedt
2009-12-03 16:11 ` Masami Hiramatsu
2009-12-02 20:11 ` [PATCH][tip/perf/core] tracing: Rename TRACE_EVENT and others to something resonable Steven Rostedt
2009-12-02 20:16 ` Frederic Weisbecker
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=1259761934.12870.12.camel@gandalf.stny.rr.com \
--to=rostedt@goodmis.org \
--cc=fweisbec@gmail.com \
--cc=hpa@zytor.com \
--cc=jbaron@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=mathieu.desnoyers@polymtl.ca \
--cc=mhiramat@redhat.com \
--cc=mingo@elte.hu \
--cc=mingo@redhat.com \
--cc=randy.dunlap@oracle.com \
--cc=tglx@linutronix.de \
--cc=wcohen@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®