From: Randy Dunlap <randy.dunlap@oracle.com>
To: rostedt@goodmis.org
Cc: Ingo Molnar <mingo@elte.hu>,
mingo@redhat.com, hpa@zytor.com, mathieu.desnoyers@polymtl.ca,
linux-kernel@vger.kernel.org, wcohen@redhat.com,
fweisbec@gmail.com, tglx@linutronix.de, jbaron@redhat.com,
mhiramat@redhat.com, linux-tip-commits@vger.kernel.org,
Christoph Hellwig <hch@lst.de>
Subject: Re: [tip:perf/core] tracing: Add DEFINE_EVENT(), DEFINE_SINGLE_EVENT() support to docbook
Date: Wed, 2 Dec 2009 08:15:37 -0800 [thread overview]
Message-ID: <20091202081537.6ce846b5.randy.dunlap@oracle.com> (raw)
In-Reply-To: <1259765735.12870.42.camel@gandalf.stny.rr.com>
On Wed, 02 Dec 2009 09:55:35 -0500 Steven Rostedt wrote:
> On Wed, 2009-12-02 at 15:43 +0100, Ingo Molnar wrote:
> > * Steven Rostedt <rostedt@goodmis.org> wrote:
> >
> > > On Wed, 2009-12-02 at 15:01 +0100, Ingo Molnar wrote:
> > >
> > > > > DECLARE_CLASS_AND_DEFINE_EVENT()
> > > >
> > > > Hm, that's a bit too long. How about 'DEFINE_CLASS_EVENT()' as a
> > > > compromise? It's similarly short-ish to TRACE_EVENT(), and it also
> > > > conveys the fact that we create both a class and an event there.
> > > >
> > > > The full series would thus be:
> > > >
> > > > DECLARE_EVENT_CLASS
> > > > DEFINE_EVENT
> > > > DEFINE_CLASS_EVENT
> > > >
> > > > hm?
> > >
> > > I thought about that too, but it actually makes it more confusing.
> > > Because, looking at this with a fresh POV, I would think that after I
> > > declare a class, I would use DEFINE_CLASS_EVENT with that class.
> >
> > yeah. Hence was my second-best choice 'DEFINE_STANDALONE_EVENT' or
> > 'DEFINE_SINGLE_EVENT' - to stress the special nature it, and to actually
> > nudge people towards creating classes of events instead of doing
> > separate, standalone points. (which are a waste in the majority of
> > cases)
>
> But the current TRACE_EVENT is still defining a class. Thus, you could
> create a TRACE_EVENT (or whatever it is called) and then create
> DEFINE_EVENTs based on the TRACE_EVENT.
>
> That's why I want a name that describes this.
>
> DEFINE_EVENT_CLASS?
>
> Perhaps that's the best.
>
> DECLARE_EVENT_CLASS - only creates a class
> DEFINE_EVENT - defines an event based off of a class
> DEFINE_EVENT_CLASS - creates a class and defines an event by the same name
>
> Perhaps this is best in keeping with linux kernel naming conventions?
Yes, that seems fairly typical.
I didn't care for the
DEFINE_x_y()
and
DEFINE_y_x()
suggestion. That just opens the door for confusion IMO.
thanks,
---
~Randy
next prev parent reply other threads:[~2009-12-02 16:17 UTC|newest]
Thread overview: 37+ messages / expand[flat|nested] mbox.gz Atom feed top
2009-12-01 17:18 [PATCH v2] tracing: add " Jason Baron
2009-12-01 17:20 ` Randy Dunlap
2009-12-02 10:42 ` [tip:perf/core] tracing: Add " tip-bot for Jason Baron
2009-12-02 13:52 ` Steven Rostedt
2009-12-02 14:01 ` Ingo Molnar
2009-12-02 14:28 ` Steven Rostedt
2009-12-02 14:43 ` Ingo Molnar
2009-12-02 14:55 ` Steven Rostedt
2009-12-02 16:15 ` Randy Dunlap [this message]
2009-12-02 16:27 ` Mathieu Desnoyers
2009-12-02 17:11 ` Steven Rostedt
2009-12-02 18:06 ` Mathieu Desnoyers
2009-12-02 18:19 ` Steven Rostedt
2009-12-02 19:01 ` trace/events: DECLARE vs DEFINE semantic Mathieu Desnoyers
2009-12-02 19:19 ` Steven Rostedt
2009-12-02 19:34 ` Randy Dunlap
2009-12-02 22:36 ` Masami Hiramatsu
2009-12-02 22:46 ` Steven Rostedt
2009-12-02 22:57 ` Mathieu Desnoyers
2009-12-02 23:08 ` H. Peter Anvin
2009-12-02 23:13 ` Steven Rostedt
2009-12-02 23:18 ` H. Peter Anvin
2009-12-02 23:15 ` Mathieu Desnoyers
2009-12-03 3:24 ` Masami Hiramatsu
2009-12-02 23:10 ` Mathieu Desnoyers
2009-12-03 4:00 ` Masami Hiramatsu
2009-12-03 4:07 ` Steven Rostedt
2009-12-03 13:51 ` Masami Hiramatsu
2009-12-03 13:54 ` Steven Rostedt
2009-12-03 14:09 ` Mathieu Desnoyers
2009-12-03 14:24 ` Steven Rostedt
2009-12-03 14:42 ` Mathieu Desnoyers
2009-12-03 15:31 ` Masami Hiramatsu
2009-12-03 15:56 ` Steven Rostedt
2009-12-03 16:11 ` Masami Hiramatsu
2009-12-02 20:11 ` [PATCH][tip/perf/core] tracing: Rename TRACE_EVENT and others to something resonable Steven Rostedt
2009-12-02 20:16 ` Frederic Weisbecker
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20091202081537.6ce846b5.randy.dunlap@oracle.com \
--to=randy.dunlap@oracle.com \
--cc=fweisbec@gmail.com \
--cc=hch@lst.de \
--cc=hpa@zytor.com \
--cc=jbaron@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-tip-commits@vger.kernel.org \
--cc=mathieu.desnoyers@polymtl.ca \
--cc=mhiramat@redhat.com \
--cc=mingo@elte.hu \
--cc=mingo@redhat.com \
--cc=rostedt@goodmis.org \
--cc=tglx@linutronix.de \
--cc=wcohen@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome