mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [GIT PATCH] driver core patches for 2.6.33-git
@ 2009-12-11 21:26 Greg KH
  2009-12-11 22:24 ` [PATCH 01/27] hpilo: add locking comment Greg Kroah-Hartman
                   ` (26 more replies)
  0 siblings, 27 replies; 35+ messages in thread
From: Greg KH @ 2009-12-11 21:26 UTC (permalink / raw)
  To: Linus Torvalds, Andrew Morton; +Cc: linux-kernel

Here is the big driver core merge for the 2.6.33-git tree.

Nothing major here:
	- sysfs reworks to make things nicer and fix minor problems
	- firmware api changes
	- devtmpfs tweaks to resolve minor issues reported by users.
	- platform devices early buffer changes
	- debugfs bugfix

Please pull from:
	master.kernel.org:/pub/scm/linux/kernel/git/gregkh/driver-core-2.6.git/

All of these patches have been in the linux-next and mm trees for a
while.

The patches will be sent as a follow-on to this message to lkml for people
to see.

thanks,

greg k-h

------------


 drivers/base/core.c                         |   14 +-
 drivers/base/devtmpfs.c                     |  100 ++++----
 drivers/base/firmware_class.c               |   14 +-
 drivers/base/platform.c                     |   29 ++-
 drivers/firmware/dell_rbu.c                 |    9 +-
 drivers/misc/hpilo.h                        |   13 +-
 drivers/serial/ucc_uart.c                   |    8 +-
 drivers/staging/comedi/drivers/usbdux.c     |    5 +-
 drivers/staging/comedi/drivers/usbduxfast.c |    5 +-
 drivers/usb/atm/ueagle-atm.c                |    7 +-
 fs/debugfs/inode.c                          |   55 +++--
 fs/namei.c                                  |   22 --
 fs/sysfs/dir.c                              |  388 +++++++++------------------
 fs/sysfs/file.c                             |   41 +---
 fs/sysfs/inode.c                            |  176 ++++++++-----
 fs/sysfs/symlink.c                          |   11 +-
 fs/sysfs/sysfs.h                            |    9 +-
 include/linux/device.h                      |    2 +-
 include/linux/firmware.h                    |    5 +-
 include/linux/namei.h                       |    1 -
 include/linux/platform_device.h             |   20 +-
 21 files changed, 428 insertions(+), 506 deletions(-)

---------------

Alan Stern (1):
      Driver core: fix race in dev_driver_string

David Altobelli (1):
      hpilo: add locking comment

Eric W. Biederman (15):
      Driver core: Don't remove kobjects in device_shutdown.
      sysfs: Update sysfs_setxattr so it updates secdata under the sysfs_mutex
      sysfs: Rename sysfs_d_iput to sysfs_dentry_iput
      sysfs: Use dentry_ops instead of directly playing with the dcache
      sysfs: Simplify sysfs_chmod_file semantics
      sysfs: Simplify iattr time assignments
      sysfs: Fix locking and factor out sysfs_sd_setattr
      sysfs: Update s_iattr on link and unlink.
      sysfs: Nicely indent sysfs_symlink_inode_operations
      sysfs: Implement sysfs_getattr & sysfs_permission
      sysfs: In sysfs_chmod_file lazily propagate the mode change.
      sysfs: Gut sysfs_addrm_start and sysfs_addrm_finish
      sysfs: Propagate renames to the vfs on demand
      sysfs: Factor out sysfs_rename from sysfs_rename_dir and sysfs_move_dir
      sysfs: sysfs_setattr remove unnecessary permission check.

Johannes Berg (1):
      firmware_class: make request_firmware_nowait more useful

Kay Sievers (6):
      Driver Core: devtmpfs: ignore umask while setting file mode
      Driver core: devtmpfs: prevent concurrent subdirectory creation and removal
      Driver Core: devtmpfs: use sys_mount()
      Driver Core: devtmpfs: do not remove non-kernel-created directories
      Driver Core: devtmpfs: cleanup node on device creation error
      Driver-Core: devtmpfs - set root directory mode to 0755

Magnus Damm (1):
      Driver Core: Early platform driver buffer

Mathieu Desnoyers (1):
      debugfs: fix create mutex racy fops and private data

Stefan Richter (1):
      sysfs: mark a locally-only used function static


^ permalink raw reply	[flat|nested] 35+ messages in thread

end of thread, other threads:[~2009-12-22 21:25 UTC | newest]

Thread overview: 35+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2009-12-11 21:26 [GIT PATCH] driver core patches for 2.6.33-git Greg KH
2009-12-11 22:24 ` [PATCH 01/27] hpilo: add locking comment Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 02/27] sysfs: mark a locally-only used function static Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 03/27] Driver Core: devtmpfs: ignore umask while setting file mode Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 04/27] Driver core: devtmpfs: prevent concurrent subdirectory creation and removal Greg Kroah-Hartman
2009-12-21 13:37   ` Kirill A. Shutemov
2009-12-21 14:37     ` Kay Sievers
2009-12-22 14:10       ` Kirill A. Shutemov
2009-12-22 16:56         ` Greg KH
2009-12-22 16:57         ` Kay Sievers
2009-12-22 18:56           ` Kirill A. Shutemov
2009-12-22 21:25             ` Kay Sievers
2009-12-11 22:24 ` [PATCH 05/27] Driver Core: devtmpfs: use sys_mount() Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 06/27] Driver Core: devtmpfs: do not remove non-kernel-created directories Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 07/27] Driver Core: devtmpfs: cleanup node on device creation error Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 08/27] Driver-Core: devtmpfs - set root directory mode to 0755 Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 09/27] firmware_class: make request_firmware_nowait more useful Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 10/27] Driver core: Don't remove kobjects in device_shutdown Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 11/27] debugfs: fix create mutex racy fops and private data Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 12/27] sysfs: Update sysfs_setxattr so it updates secdata under the sysfs_mutex Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 13/27] sysfs: Rename sysfs_d_iput to sysfs_dentry_iput Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 14/27] sysfs: Use dentry_ops instead of directly playing with the dcache Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 15/27] sysfs: Simplify sysfs_chmod_file semantics Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 16/27] sysfs: Simplify iattr time assignments Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 17/27] sysfs: Fix locking and factor out sysfs_sd_setattr Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 18/27] sysfs: Update s_iattr on link and unlink Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 19/27] sysfs: Nicely indent sysfs_symlink_inode_operations Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 20/27] sysfs: Implement sysfs_getattr & sysfs_permission Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 21/27] sysfs: In sysfs_chmod_file lazily propagate the mode change Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 22/27] sysfs: Gut sysfs_addrm_start and sysfs_addrm_finish Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 23/27] sysfs: Propagate renames to the vfs on demand Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 24/27] sysfs: Factor out sysfs_rename from sysfs_rename_dir and sysfs_move_dir Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 25/27] sysfs: sysfs_setattr remove unnecessary permission check Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 26/27] Driver Core: Early platform driver buffer Greg Kroah-Hartman
2009-12-11 22:24 ` [PATCH 27/27] Driver core: fix race in dev_driver_string Greg Kroah-Hartman

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®